LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 09-28-2003, 07:01 PM   #1
coolamit78
Member
 
Registered: Aug 2003
Location: New Delhi, India
Distribution: RHEL AS 3/4, Windows XP
Posts: 546

Rep: Reputation: 31
Volume Control In Gnome


Hello.....This is another small issue that I'd like to get resolved with the help of u all guys...

Whenever I log-in to linux as root or a normal user, the volume control settings go back to the default system settings...

I tried to save my new volume settings, but on the next login, it again reverts back to the original system settings. I also tried and running aumix and kmix from the console and saving settings from there, but it dosent help either..

How do i save my own settings? I have RH 9 with GNOME...
 
Old 09-29-2003, 12:20 PM   #2
coolamit78
Member
 
Registered: Aug 2003
Location: New Delhi, India
Distribution: RHEL AS 3/4, Windows XP
Posts: 546

Original Poster
Rep: Reputation: 31
Hey...right now, lot of u friends are browsing the forum....i hope to find the solution to this problem at least now...


pls try and help

thanks
 
Old 09-29-2003, 12:48 PM   #3
rberry88
Member
 
Registered: Aug 2003
Location: Arlington Heights, IL USA
Distribution: Fedora Core 1 & WinXP Pro & Gentoo 1.4 & Arch Linux
Posts: 558

Rep: Reputation: 30
You could try adding the Kmix applet to the taskbar so you can change the volume just by clicking on the Kmix taskbar icon. I'm not sure but once you have the Kmix applet on your taskbar you may be able to right-click it and open up the properties for Kmix that should have an option of loading current settings at startup.

rberry88
 
Old 09-29-2003, 02:25 PM   #4
coolamit78
Member
 
Registered: Aug 2003
Location: New Delhi, India
Distribution: RHEL AS 3/4, Windows XP
Posts: 546

Original Poster
Rep: Reputation: 31
hi rberry88....

I have the applet on my panel.....but the problem is that once i reboot, my own settings are not saved. This happens only in GNOME and not KDE as far as I remember...although i can't say surely because I switched to GNOME as KDE was hell of a slow to load....

But one thing is confirmed, my own settings last only till the machine is up. Once I reboot, it reverts back to the default system settings....

any other ideas?
 
Old 09-30-2003, 06:20 PM   #5
coolamit78
Member
 
Registered: Aug 2003
Location: New Delhi, India
Distribution: RHEL AS 3/4, Windows XP
Posts: 546

Original Poster
Rep: Reputation: 31
Well, so far I havent got a proper solution for a small issue like this one.....I request the moderators to take a look at my question and provide me some solution in case none of my other forum friends are able to help....

thanks
 
Old 10-02-2003, 12:15 PM   #6
webtoe
Member
 
Registered: Apr 2001
Location: Cambridge, England
Distribution: Slackware 10, Fedora Core 3, Mac OS X
Posts: 617

Rep: Reputation: 30
Hmmm, I used to have this problem before as well (I'm afraid that I've only just returned to these forums after a stint away with all things mac).

Basically it goes like this. Volume settings don't really get saved, or they never have for me. As far as I can tell this can be for one of several reasons (which I'm not entirely certain of so could be very wrong).

1.) Alsa usually has this problem since when it is initially loaded at boot time the volume is often down all the way. This has caught many a n00b out and still gets me.

2.) When sound drivers (either alsa or the built in ones [OSS]) are loaded as modules I think that the volumes may get reset when they are reloaded. I'm not certain on this since I try to have as few modules as possible and usually just live XMMS running so the modules are always in use.

Anyway, my way of fixing it is to use a small script in the boot sequence. Its not a perfect way to do things but hey. You'll need a program called aumix (which you may already have). Then place the following commands into a file in boot up scriptes (you'll have to look for help on this since I use slackware as my distro which does this differently from most other distros).

/usr/bin/aumix -v100 -w90

This sets the main volume to 100% and then the PCM volume to 90%. I actually haven't done this command in a while since I'm lazy and just manually use the mixer each time but it does work. Adjust the numbers to your liking. I just got looked all the settings up again on the net so you can too if you need it

Hope that helps

Alex
 
Old 10-02-2003, 03:34 PM   #7
Truti
LQ Newbie
 
Registered: Aug 2003
Location: Denmark - Soenderbronx
Distribution: Debian / FreeBSD
Posts: 11

Rep: Reputation: 0
kmix i the beauti, over the sound controles!
 
Old 10-02-2003, 03:46 PM   #8
Andrew Benton
Senior Member
 
Registered: Aug 2003
Location: Birkenhead/Britain
Distribution: Linux From Scratch
Posts: 2,073

Rep: Reputation: 64
I use Mandrake 9.1 and I've found that if I choose the default KDE the it's like you say, the sound defaults to mute the next time you log in, even if you change to gnome. But I find that if I reinstall Mandrake and choose Gnome as the default desktop environment so that it boots into Gnome the first time you log in, the sound is set to mute but if you change it it then remembers the new setting the next time you reboot. Good luck.
 
Old 10-02-2003, 07:51 PM   #9
coolamit78
Member
 
Registered: Aug 2003
Location: New Delhi, India
Distribution: RHEL AS 3/4, Windows XP
Posts: 546

Original Poster
Rep: Reputation: 31
Ok Alex......Your suggestion has helped me...but only 50%......(although I didnt know that I would need to put 'aumix' in my startup script to get those volume settings to 100% level.....I have already used this script to load my sound modules and bttv modules previously though)

Lets see what ideas I can get from everyone out here....

I have the Yamaha OPL3 SA3 soundboard....and I use OSS drivers in XMMS....

However, the volume control in (both GNOME and KDE), has 2 tabs:

1. MS_SOUND_SYSTEM_CS4231 and

2. Yamaha OPL3 SA3

Now using your suggestion alex, I set the volume, synth, cd, speaker and line-in settings to maximum .....However this is the 1st tab , that is, MS_Sound_System......My Master Volume, bass and treble settings are in the other tab, that is, Yamaha OPL3 SA3 tab.....

Now I dont know how do I set their settings to 100% from command line?

any ideas?

Regards,

amit
 
Old 10-03-2003, 04:18 AM   #10
webtoe
Member
 
Registered: Apr 2001
Location: Cambridge, England
Distribution: Slackware 10, Fedora Core 3, Mac OS X
Posts: 617

Rep: Reputation: 30
hmmm, so you have two sound cards?

You can specify which device aumix changes the volumes of by using the -d /dev/mixer switch.

/dev/mixer is the default and seems to be the ms_sound_system_cs4231 (a generic on board card i think). Try changing the following to change treble and bass levels:

Code:
aumix -d /dev/mixer1 -v100 -t60 -b60
I've only looked this up in the man page for aumix so I may not have the /dev/mixer device right. It may say on the tab which device the yamaha is.

Hope that helps

Alex

P.S. post back if you need some clarification
 
Old 10-03-2003, 11:45 AM   #11
coolamit78
Member
 
Registered: Aug 2003
Location: New Delhi, India
Distribution: RHEL AS 3/4, Windows XP
Posts: 546

Original Poster
Rep: Reputation: 31
Ok Alex, your suggestions have done the job for me....However, there's still a small issue....

Due to the volume setttings being initialized at boot time, 'kmix' is loaded at startup...However, a nagging kmix window pops up too.....Is there any way, I can stop that window from appearing on my desktopn and at the same time allow kmix to keep working in background?

Regards,

amit
 
Old 10-03-2003, 11:07 PM   #12
coolamit78
Member
 
Registered: Aug 2003
Location: New Delhi, India
Distribution: RHEL AS 3/4, Windows XP
Posts: 546

Original Poster
Rep: Reputation: 31
Hi Everyone!....

Firstly, a big thanks to Alex for helping me get my issue resolved.

However, just for the benefit of those, who are quite new to Linux or those who aren't able to resolve the Volume issue....I'd like to restate the problem and the solution...

The Issue
--------------

The Volume Settings in RH 9( GNOME ) are automatically reset to the defaults every time the system starts up.

The Solution
------------------

1. I checked up my audio devices. Noticed that there are 2 tabs for sound boards namely -

(a) MS_SOUND_SYSTEM_CS4231
which is /dev/mixer

(b) Yamaha OPL3 SA3 sound board
which is /dev/mixer1

2. I already have a script load_sound_tv_radio.sh that loads during system startup. It basically loads the bttv tv tuner and sound modules in memory at the time system starts up. This script is placed in /usr/local/bin.

The above script is called from the file /etc/rc.d/rc.local which is pasted below for reference....

#!/bin/sh
#
# This script will be executed *after* all the other init scripts.
# You can put your own initialization stuff in here if you don't
# want to do the full Sys V style init stuff.

touch /var/lock/subsys/local

#Executes the script that loads sound,tv, radio modules and sets the volume settings at startup

/usr/local/bin/load_sound_tv_radio.sh


3. In this script, I also add lines that inititalize the new values for the Volume Settings...

Below is the complete script load_sound_tv_radio.sh for reference.

#Initialize the sound module
modprobe opl3sa2

#Initialize the settings for Tv Tuner Modules
modprobe tuner type=5 debug=1
modprobe bttv card=2 radio=1 pll=1

#Initialize the default Volume settings for MS_SOUND_SYSTEM_CS4231
/usr/bin/aumix -d /dev/mixer -v100 -w100 -s100 -p100 -l100 -c100

#Initialize the Volume default settings for Yamaha OPL3 SA3 sound
/usr/bin/aumix -d /dev/mixer1 -v90 -b75 -t75

I hope this post will be of help to my friends at LQ. At the end, a big thanks to everyone who has taken the effort to solve this small but extremely vital issue.

Regards,

amit
 
Old 10-06-2003, 05:40 AM   #13
webtoe
Member
 
Registered: Apr 2001
Location: Cambridge, England
Distribution: Slackware 10, Fedora Core 3, Mac OS X
Posts: 617

Rep: Reputation: 30
Glad I could help.

Also the precise at the end of what you did is great. Next time someone has this problem we can point them to this.

Alex
 
Old 10-06-2003, 09:58 AM   #14
coolamit78
Member
 
Registered: Aug 2003
Location: New Delhi, India
Distribution: RHEL AS 3/4, Windows XP
Posts: 546

Original Poster
Rep: Reputation: 31
Hi...!

Thanx for the appreciation Alex ......Hope all friends at LQ will find our discussion informative....

Regards,

amit
 
Old 10-07-2003, 11:49 PM   #15
laydros
Member
 
Registered: Jun 2003
Location: Raleigh, NC, US
Distribution: Slackware
Posts: 63

Rep: Reputation: 15
umm, i have been fighting with this issue a bit, and i (gasp) opened teh helpfile on the gnome volume applet. it shows a "save settings" window in the volume preferences, but i don't have the screen they show, when i go to preferences its just which settings will be shown (ie: cd, pcm, etc)

im running slack 9.1, so its gnome 2.4, and totally clean. quite wierd, and i really wish i could get to that setting.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
No Volume Control in GNOME kushalkoolwal Debian 6 05-12-2009 07:39 PM
Volume Control in Gnome dudeman41465 Linux - Software 3 10-09-2005 02:15 PM
Volume Control in Gnome dudeman41465 Mandriva 2 10-09-2005 05:22 AM
gnome volume control problem e88z4 Linux - Software 0 06-05-2004 05:58 AM
Gnome Volume Control Problems 74039186 Mandriva 1 05-07-2004 02:45 PM


All times are GMT -5. The time now is 01:16 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration