LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices



Reply
 
Search this Thread
Old 04-15-2009, 06:46 PM   #1
dasoberdick
Member
 
Registered: Aug 2004
Location: Michigan
Distribution: redhat 9.0
Posts: 99

Rep: Reputation: 15
vmware on slackware 12.2


I just installed vmware server 2.0 on slackware 12.2 and when I run the command "vmware" it brings me to:http://localhost:8222/ui/# and asks for a user name and password.

What the heck is my user name and password? I was never asked to specify this. I have tried root and roots password along with my user name and password as Google suggested but neither one gets me in.
 
Old 04-16-2009, 08:18 AM   #2
Hangdog42
LQ Veteran
 
Registered: Feb 2003
Location: Maryland
Distribution: Slackware
Posts: 7,791
Blog Entries: 1

Rep: Reputation: 414Reputation: 414Reputation: 414Reputation: 414Reputation: 414
When you installed VMWare, it should have asked for a user to run under. That is the username and password you need.
 
Old 04-16-2009, 08:20 AM   #3
sycamorex
LQ Veteran
 
Registered: Nov 2005
Location: London
Distribution: Slackware64-current
Posts: 5,605
Blog Entries: 1

Rep: Reputation: 1047Reputation: 1047Reputation: 1047Reputation: 1047Reputation: 1047Reputation: 1047Reputation: 1047Reputation: 1047
If not, try username: root and your root password
 
Old 04-16-2009, 10:54 AM   #4
dasoberdick
Member
 
Registered: Aug 2004
Location: Michigan
Distribution: redhat 9.0
Posts: 99

Original Poster
Rep: Reputation: 15
Like I said in my first post. I tried both of those suggestions and neither one of them worked.
 
Old 04-16-2009, 11:09 AM   #5
dasoberdick
Member
 
Registered: Aug 2004
Location: Michigan
Distribution: redhat 9.0
Posts: 99

Original Poster
Rep: Reputation: 15
do these warnings present a problem?

root@darkstar:/home/lusher00# vmware
Launching VMware Web Access using /usr/bin/xdg-open
kbuildsycoca running...
kdecore (KLibLoader): WARNING: KLibrary: /usr/lib/libcrypto.so.0.9.8: undefined symbol: PKCS7_content_free
kdecore (KLibLoader): WARNING: KLibrary: /usr/lib/libcrypto.so.0.9.8: undefined symbol: OpenSSL_add_all_algorithms
kdecore (KLibLoader): WARNING: KLibrary: /usr/lib/libcrypto.so.0.9.8: undefined symbol: OPENSSL_add_all_algorithms
kdecore (KLibLoader): WARNING: KLibrary: /usr/lib/libcrypto.so.0.9.8: undefined symbol: OpenSSL_add_all_algorithms_conf
kdecore (KLibLoader): WARNING: KLibrary: /usr/lib/libcrypto.so.0.9.8: undefined symbol: PKCS7_content_free
kdecore (KLibLoader): WARNING: KLibrary: /usr/lib/libcrypto.so.0.9.8: undefined symbol: OpenSSL_add_all_algorithms
kdecore (KLibLoader): WARNING: KLibrary: /usr/lib/libcrypto.so.0.9.8: undefined symbol: OPENSSL_add_all_algorithms
kdecore (KLibLoader): WARNING: KLibrary: /usr/lib/libcrypto.so.0.9.8: undefined symbol: OpenSSL_add_all_algorithms_conf
Launched ok, pid = 6202
kdecore (KLibLoader): WARNING: KLibrary: /usr/lib/libcrypto.so.0.9.8: undefined symbol: PKCS7_content_free
kdecore (KLibLoader): WARNING: KLibrary: /usr/lib/libcrypto.so.0.9.8: undefined symbol: OpenSSL_add_all_algorithms
kdecore (KLibLoader): WARNING: KLibrary: /usr/lib/libcrypto.so.0.9.8: undefined symbol: OPENSSL_add_all_algorithms
kdecore (KLibLoader): WARNING: KLibrary: /usr/lib/libcrypto.so.0.9.8: undefined symbol: OpenSSL_add_all_algorithms_conf
kdecore (KLibLoader): WARNING: KLibrary: /usr/lib/libcrypto.so.0.9.8: undefined symbol: PKCS7_content_free
kdecore (KLibLoader): WARNING: KLibrary: /usr/lib/libcrypto.so.0.9.8: undefined symbol: OpenSSL_add_all_algorithms
kdecore (KLibLoader): WARNING: KLibrary: /usr/lib/libcrypto.so.0.9.8: undefined symbol: OPENSSL_add_all_algorithms
kdecore (KLibLoader): WARNING: KLibrary: /usr/lib/libcrypto.so.0.9.8: undefined symbol: OpenSSL_add_all_algorithms_conf

I ran back through the config process and specified lusher00 (my user name) as the administrator but it never asked me for a pass word. I used lusher00's pass word to log in but it still wont let me log in.
 
Old 04-16-2009, 11:45 AM   #6
Hangdog42
LQ Veteran
 
Registered: Feb 2003
Location: Maryland
Distribution: Slackware
Posts: 7,791
Blog Entries: 1

Rep: Reputation: 414Reputation: 414Reputation: 414Reputation: 414Reputation: 414
Quote:
oot@darkstar:/home/lusher00# vmware
That is NOT how you start VMware. If you installed via the VMWare documentation, there should be a script in /etc/init.d that gets called from /etc/rc.d/rc3.d and /etc/rc.d/rc4.d. Yes, this isn't how Slackware normally starts things, but it does work, provided you instlled VMware correctly.
Quote:
I ran back through the config process and specified lusher00 (my user name) as the administrator but it never asked me for a pass word. I used lusher00's pass word to log in but it still wont let me log in.

It should use luser00's password, but I suspect since you haven't installed/started it correctly, that is causing the trouble. You can't log in if it isn't running. Also, VMware server 2 requires the PAM libraries to be installed before login works. Did you do that? If not, read this for how to do it.
 
Old 04-16-2009, 12:13 PM   #7
dasoberdick
Member
 
Registered: Aug 2004
Location: Michigan
Distribution: redhat 9.0
Posts: 99

Original Poster
Rep: Reputation: 15
I followed the tutorial for installing PAM when I installed VMware. He said just run the install.pl script and accept the defaults so that's what I did. was that not the correct install procedure? where in the docs do I find the startup procedures?
 
Old 04-16-2009, 12:31 PM   #8
Hangdog42
LQ Veteran
 
Registered: Feb 2003
Location: Maryland
Distribution: Slackware
Posts: 7,791
Blog Entries: 1

Rep: Reputation: 414Reputation: 414Reputation: 414Reputation: 414Reputation: 414
Quote:
Originally Posted by dasoberdick View Post
I followed the tutorial for installing PAM when I installed VMware. He said just run the install.pl script and accept the defaults so that's what I did. was that not the correct install procedure? where in the docs do I find the startup procedures?
If you ran vmware-install.pl, then vmware-configure.pl, that should have you in good shape. However, you're still not starting VMware correctly. To be honest, if you ran vmware-install.pl, that should set up VMware so that it does start at boot, and all you need to do is point your browser at http://localhost:portnumber where portnumber is the port you specified VMWare to listen to. I think it defaults to 80, but if you're also running a web server, that might be a conflict (which would also cause problems).

Check to make sure that there is an executable vmware script in /etc/init.d and that there are links in /etc/rc.d/rc3.d and /etc/rc.d/rc4.d. If they are there, then it should be starting at boot. If they are not, then likely something went wrong with the install.

As far as docs go, I've always found this to be the most useful.
 
Old 04-16-2009, 12:53 PM   #9
dasoberdick
Member
 
Registered: Aug 2004
Location: Michigan
Distribution: redhat 9.0
Posts: 99

Original Poster
Rep: Reputation: 15
damn... that's exactly what im doing. I can see VMware starting up at boot and all the processes say they start up ok. when you run vmware in a shell, all it does is open up a browser. the browser opens to localhost port 8333 which is where it asks for the user name and password that I don't know. I have tried to login as root and with my user name and password. where am I going wrong?
 
Old 04-16-2009, 01:14 PM   #10
Hangdog42
LQ Veteran
 
Registered: Feb 2003
Location: Maryland
Distribution: Slackware
Posts: 7,791
Blog Entries: 1

Rep: Reputation: 414Reputation: 414Reputation: 414Reputation: 414Reputation: 414
Quote:
when you run vmware in a shell
Don't do this. Ever. It is useless at best and could be causing all sorts of issues at worst.
Quote:
all it does is open up a browser. the browser opens to localhost port 8333 which is where it asks for the user name and password that I don't know. I have tried to login as root and with my user name and password. where am I going wrong?
If the install went fine, then you're doing everything right, with the exception of running vmware in the console. So reboot, open a web browser and navigate to localhost:8333 and try to log in as luser00. If that doesn't work, then post any errors you are seeing. I suspect that either the PAM install went bad or you didn't set up the soft links after PAM was installed.

Oh, one more thing. Did you install PAM before or after VMWare?

Last edited by Hangdog42; 04-16-2009 at 01:15 PM.
 
Old 04-16-2009, 02:11 PM   #11
dasoberdick
Member
 
Registered: Aug 2004
Location: Michigan
Distribution: redhat 9.0
Posts: 99

Original Poster
Rep: Reputation: 15
I am missing the links in rc3.d and rc4.d. What should they look like? What should the link be called and what am I linking to? I have a file called vmware* in rc.d. Is that what I should link to? Somewhere I read that I should create r.0.d thourhg rc9.d in rc.d but I cant find that post anymore. Are those causing a problem?
 
Old 04-16-2009, 02:41 PM   #12
dasoberdick
Member
 
Registered: Aug 2004
Location: Michigan
Distribution: redhat 9.0
Posts: 99

Original Poster
Rep: Reputation: 15
This may be a problem. /etc/pam.d was not executable by any user so I made it executable by all users using chmod a+x. When I try to execute it I get:

lusher00@darkstar:/etc$ pam.d
./pam.d: line 2: auth: command not found
./pam.d: line 3: account: command not found

Does this help?
 
Old 04-16-2009, 07:15 PM   #13
Hangdog42
LQ Veteran
 
Registered: Feb 2003
Location: Maryland
Distribution: Slackware
Posts: 7,791
Blog Entries: 1

Rep: Reputation: 414Reputation: 414Reputation: 414Reputation: 414Reputation: 414
Quote:
I am missing the links in rc3.d and rc4.d. What should they look like? What should the link be called and what am I linking to? I have a file called vmware* in rc.d. Is that what I should link to?
At least to me, this is sounding like the initial install went very wrong. The vmware-install.pl script is set up for a System V type startup (which is pretty much everything except Slackware). The vmware script should be in /etc/init.d, not /etc/rc.d. Did you download directly from VMware or did you find some other package?

Quote:
This may be a problem. /etc/pam.d was not executable by any user so I made it executable by all users using chmod a+x. When I try to execute it I get:
Um, pam.d should be a directory (which is executable) and should contain the vmware-authd file. If I remember correctly, the install should copy that from the /etc/vmware/pam.d directory to /etc/pam.d. If you didn't create the /etc/pam.d directory prior to installing VMware, that may have been a problem. If I remember correctly, VMWare assumes it is there (which it is on a PAM enabled system) and doesn't create it if it isn't.

To be honest, I think the best solution at this point would be to uninstall what you've got and re-install from a fresh download.
 
Old 04-17-2009, 09:51 AM   #14
dasoberdick
Member
 
Registered: Aug 2004
Location: Michigan
Distribution: redhat 9.0
Posts: 99

Original Poster
Rep: Reputation: 15
Ok your right the vmware startup script is in init.d no rc.d. I think my problem is that PAM is not starting correctly. I followed your tutorial to the t but I still get the "bas user name and pass word" when I try to log in which is exactly the problem you say I will have if I don't have PAM. Can we chat somehow, perhaps on IRC?
 
Old 04-17-2009, 10:40 AM   #15
dasoberdick
Member
 
Registered: Aug 2004
Location: Michigan
Distribution: redhat 9.0
Posts: 99

Original Poster
Rep: Reputation: 15
vmware-authd was a binary file??? Someone on IRC game me their vmware-authd which was:

#%PAM-1.0
auth required pam_unix.so shadow nullok
account required pam_unix.so

and now it works!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Vmware on Slackware 12.1 Mig21 Slackware 13 06-09-2008 10:45 PM
Slackware on vmware. zetox Slackware 14 10-31-2007 09:40 PM
vmware server 2.5 Vmware tools in slackware 12 mr_sarge Slackware 5 07-18-2007 07:14 AM


All times are GMT -5. The time now is 12:07 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration