LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 11-17-2007, 01:48 PM   #1
acromez
LQ Newbie
 
Registered: Nov 2007
Posts: 25

Rep: Reputation: 15
Angry vmware help in fc8


when ever i install it give this msg

None of the pre-built vmmon modules for VMware Workstation is suitable for your
running kernel. Do you want this program to try to build the vmmon module for
your system (you need to have a C compiler installed on your system)? [yes]

Using compiler "/usr/bin/gcc". Use environment variable CC to override.

What is the location of the directory of C header files that match your running
kernel? [/usr/src/linux/include]

hav tried yum install kernel kernel-devel but it says u hav latest

plzplzpzl ppl HELP me
 
Old 11-17-2007, 02:11 PM   #2
Lenard
Senior Member
 
Registered: Dec 2005
Location: Indiana
Distribution: RHEL/CentOS/SL 5 i386 and x86_64 pata for IDE in use
Posts: 4,790

Rep: Reputation: 56
Show us please; rpm -qa 'kernel*'

BTW; you also need to have the kernel-headers package(s) installed.
 
Old 11-17-2007, 02:14 PM   #3
acromez
LQ Newbie
 
Registered: Nov 2007
Posts: 25

Original Poster
Rep: Reputation: 15
guide me how to install it thankz
 
Old 11-17-2007, 02:19 PM   #4
acromez
LQ Newbie
 
Registered: Nov 2007
Posts: 25

Original Poster
Rep: Reputation: 15
kernel-2.6.23.1-42.fc8
kernel-2.6.23.1-49.fc8
 
Old 11-17-2007, 02:27 PM   #5
acromez
LQ Newbie
 
Registered: Nov 2007
Posts: 25

Original Poster
Rep: Reputation: 15
update kernel header but nth happen more help plz
 
Old 11-17-2007, 06:13 PM   #6
Lenard
Senior Member
 
Registered: Dec 2005
Location: Indiana
Distribution: RHEL/CentOS/SL 5 i386 and x86_64 pata for IDE in use
Posts: 4,790

Rep: Reputation: 56
First you do not have the kernel-devel package installed for either kernel.

As root type: yum install kernel-devel kernel-headers
 
Old 11-18-2007, 12:33 AM   #7
acromez
LQ Newbie
 
Registered: Nov 2007
Posts: 25

Original Poster
Rep: Reputation: 15
[root@localhost ~]# yum install kernel-devel kernel-headers
Setting up Install Process
Parsing package install arguments
Package kernel-devel - 2.6.23.1-49.fc8.i686 is already installed.
Package kernel-headers - 2.6.23.1-49.fc8.i386 is already installed.
Resolving Dependencies
--> Running transaction check
---> Package kernel-devel.i686 0:2.6.23.1-42.fc8 set to be updated
--> Finished Dependency Resolution

Dependencies Resolved

=============================================================================
Package Arch Version Repository Size
=============================================================================
Installing:
kernel-devel i686 2.6.23.1-42.fc8 fedora 4.8 M

Transaction Summary
=============================================================================
Install 1 Package(s)
Update 0 Package(s)
Remove 0 Package(s)

Total download size: 4.8 M
Is this ok [y/N]: y
Downloading Packages:
Running rpm_check_debug
Running Transaction Test
Finished Transaction Test


Transaction Check Error:
package kernel-devel-2.6.23.1-49.fc8 (which is newer than kernel-devel-2.6.23.1-42.fc8) is already installed

Error Summary
-------------

[root@localhost ~]#
nth happened
 
Old 11-18-2007, 12:34 AM   #8
acromez
LQ Newbie
 
Registered: Nov 2007
Posts: 25

Original Poster
Rep: Reputation: 15
Plz Do Something Lenard
 
Old 11-18-2007, 05:52 AM   #9
acromez
LQ Newbie
 
Registered: Nov 2007
Posts: 25

Original Poster
Rep: Reputation: 15
plz add me on yahoo acromez@yahoo.de
 
Old 11-18-2007, 08:09 AM   #10
Lenard
Senior Member
 
Registered: Dec 2005
Location: Indiana
Distribution: RHEL/CentOS/SL 5 i386 and x86_64 pata for IDE in use
Posts: 4,790

Rep: Reputation: 56
Are you running the 2.6.23.1-49.fc8 kernel, the same one that has the kernel-devel and kernel-headers installed???

uname -a

Please make sure you did type the command I posted earlier, you should have seen both kernels, the kernel-devel and kernel-headers packages, for example;

$ rpm -qa 'kernel*'
kernel-2.6.18-8.1.15.el5.x86_64
kernel-devel-2.6.18-53.el5.x86_64
kernel-headers-2.6.18-53.el5.x86_64
kernel-2.6.18-53.el5.x86_64
 
Old 11-18-2007, 11:41 AM   #11
acromez
LQ Newbie
 
Registered: Nov 2007
Posts: 25

Original Poster
Rep: Reputation: 15
sorry lenard i forget to write it

kernel-devel-2.6.23.1-49.fc8
kernel-headers-2.6.23.1-49.fc8
kernel-2.6.23.1-42.fc8
kernel-2.6.23.1-49.fc8
kernel-xen-2.6.21-2950.fc8
 
Old 11-18-2007, 03:11 PM   #12
Lenard
Senior Member
 
Registered: Dec 2005
Location: Indiana
Distribution: RHEL/CentOS/SL 5 i386 and x86_64 pata for IDE in use
Posts: 4,790

Rep: Reputation: 56
Once again, you have to be running the 2.6.23.1-49 kernel in order for the VMWare installer to work. You may need to answer the question and tell the installer where these files are also, for example;

/usr/src/kernels/<version_number>/include

.
 
Old 11-19-2007, 04:45 AM   #13
acromez
LQ Newbie
 
Registered: Nov 2007
Posts: 25

Original Poster
Rep: Reputation: 15
how do i run this kernel???
 
Old 11-19-2007, 06:13 AM   #14
acromez
LQ Newbie
 
Registered: Nov 2007
Posts: 25

Original Poster
Rep: Reputation: 15
plz explain me in detail
 
Old 11-19-2007, 06:16 AM   #15
Lenard
Senior Member
 
Registered: Dec 2005
Location: Indiana
Distribution: RHEL/CentOS/SL 5 i386 and x86_64 pata for IDE in use
Posts: 4,790

Rep: Reputation: 56
Boot the system to the new kernel!!! You will be given th chance to do so when booting.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
fc8 firefox and yum problems lsropia Linux - General 1 11-16-2007 10:04 AM
FC8 Font Problems xchequer Fedora 1 11-11-2007 05:23 AM
FC8 + ndiswrapper disco192 Fedora 1 11-09-2007 09:18 AM
FC8 dbus error sir-lancealot Linux - Desktop 1 10-11-2007 12:52 AM
what means fc8 in fedora core 6? Yentor Linux - Software 1 08-28-2007 09:56 AM


All times are GMT -5. The time now is 02:23 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration