LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
LinkBack Search this Thread
Old 03-06-2009, 10:21 AM   #1
SteveInTallyFL
Member
 
Registered: May 2008
Location: Tallahassee, FL
Distribution: RHEL4, RHEL 5, OEL4, OEL5
Posts: 58

Rep: Reputation: 17
Vmware guest OS install jam


I have an RHEL4u7 (x86_64) server running Vmware Server 2.0.0 build 122589. There is already one virtual server running RHEL4u5 (32-bit). Today I want to add another virtual server as RHEL4u7 (x86_64) - the same as the host operating system. On virtual startup for the guest OS install I immediately get the "Your CPU does not support long mode. Use the 32-bit distribution" error.

Is this a limit of the free Vmware server? Is this because the first virtual server I made was 32-bit? Could I have missed a critical setting during the creation wizard?
 
Old 04-23-2009, 09:17 AM   #2
SteveInTallyFL
Member
 
Registered: May 2008
Location: Tallahassee, FL
Distribution: RHEL4, RHEL 5, OEL4, OEL5
Posts: 58

Original Poster
Rep: Reputation: 17
The answer is. . . .system BIOS setting change needed

Quote:
Originally Posted by SteveInTallyFL View Post
I have an RHEL4u7 (x86_64) server running Vmware Server 2.0.0 build 122589. There is already one virtual server running RHEL4u5 (32-bit). Today I want to add another virtual server as RHEL4u7 (x86_64) - the same as the host operating system. On virtual startup for the guest OS install I immediately get the "Your CPU does not support long mode. Use the 32-bit distribution" error.

Is this a limit of the free Vmware server? Is this because the first virtual server I made was 32-bit? Could I have missed a critical setting during the creation wizard?
I needed to set the VT switch in the BIOS to ON. This allows for mixed OS platform level calls to be handled by the CPU. Once this was set everyting went fine.
 
Old 04-23-2009, 10:04 AM   #3
okcomputer44
Member
 
Registered: Jun 2008
Location: /home/laz
Distribution: CentOS/Debian
Posts: 236

Rep: Reputation: 51
Quote:
Originally Posted by SteveInTallyFL View Post
I needed to set the VT switch in the BIOS to ON. This allows for mixed OS platform level calls to be handled by the CPU. Once this was set everyting went fine.
Yeah that is right.

I had the same problem on a friend of mine machine´s.
It was a DELL server and the virtualization was switched off by default.

The first VMware machine was 32bit and mine was 64bit and same thing happened to me.

Laz.
 
  


Reply

Tags
rhel4, vmware


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Configuration to access internet from vmware(host=winXP, guest on vmware=linux-5) afz_linux Linux - Newbie 3 12-30-2008 12:20 AM
Install vmware tools on Ubuntu 7.10 guest problem optimizer Ubuntu 7 02-25-2008 03:25 AM
version.h problem trying to install VMtools into SUSE 10.3 as VMware guest tonyrs Suse/Novell 0 11-25-2007 05:08 PM
Install guest OS on vmware robsr6 Fedora 1 04-02-2007 12:35 PM
Unable to install guest OS on VMWare ZhiYi Linux - Software 1 06-25-2005 03:04 AM


All times are GMT -5. The time now is 11:39 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration