LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (http://www.linuxquestions.org/questions/linux-software-2/)
-   -   Vmware freezes my system when Loading Virtual Machine (http://www.linuxquestions.org/questions/linux-software-2/vmware-freezes-my-system-when-loading-virtual-machine-111198/)

Peelo 11-01-2003 03:30 PM

Vmware freezes my system when Loading Virtual Machine
 
Hi,

My problem is that, once I have installed vmware 4 workstation on my redhat 9 system (kernel : 2.4.20-20.9smp), and I have configured it, every thing looks fine. Until I try to "Power on" a virtual machine. The whole system freezes completely and then all that is left to do is a cold reboot.

When I look into the logs (/var/log/messages), the only relevant message that I can see is:

Nov 1 15:11:07 localhost kernel: application bug: vmware(5185) has SIGCHLD set
to SIG_IGN but calls wait().

I have absolutely no idea what does that mean so I was hoping that someone could give me a clue of what is going on.

Is it fixeable?

Thanks,

Peelo

musrum 11-01-2003 03:41 PM

Well, generally that is a problem, but not necessarily! However, you should report that one to VMWare. They may be doing it deliberately for some reason.

I notice that you are running an SMP kernel. Is your machine an SMP machine? That would have no effect on anything normally. The reason I ask is I have had ZERO problems with VMWare EXCEPT on SMP machines.

When this freeze occurs, did you try either 1. getting to a console by Ctrl-Alt-F1 or Alt-F1?; 2. getting into the box from another machine via ssh or telnet? Or is it well and truly dead?

Peelo 11-02-2003 02:59 PM

Nice advices, I'll try that!

If you don't have any news from me within 2 weeks, means it's solved.

I'll try to write down what was the problem..


Thanks a lot!

Peelo


All times are GMT -5. The time now is 12:44 AM.