LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 05-18-2011, 04:55 PM   #1
baronobeefdip
Senior Member
 
Registered: Jul 2009
Distribution: Debian Squeeze
Posts: 1,172

Rep: Reputation: 32
VLC won't show video but plays sound


after updating from these repositories
Code:

#### Debian Backports - http://backports.debian.org/
deb http://backports.debian.org/debian-backports squeeze-backports main

#### Debian Multimedia - http://www.debian-multimedia.org/
## Run this command: apt-get update && apt-get install debian-multimedia-keyring && apt-get update
deb http://www.debian-multimedia.org stable main non-free

#### Google Linux Software Repositories - http://www.google.com
## Run this command: wget -q -O - https://dl-ssl.google.com/linux/linux_signing_key.pub | apt-key add -
deb http://dl.google.com/linux/deb/ stable non-free main

#### Google Linux Software Repositories (Testing) - http://www.google.com
## Run this command: wget -q -O - https://dl-ssl.google.com/linux/linux_signing_key.pub | apt-key add -
deb http://dl.google.com/linux/deb/ testing non-free

#### Skype - http://www.skype.com
## Run this command: gpg --keyserver pgp.mit.edu --recv-keys 0xd66b746e && gpg --export --armor 0xd66b746e | apt-key add -
deb http://download.skype.com/linux/repos/debian/ stable non-free

#### VirtualBox - http://www.virtualbox.org
## Run this command: wget -q http://download.virtualbox.org/virtualbox/debian/oracle_vbox.asc -O- | apt-key add -
deb http://download.virtualbox.org/virtualbox/debian squeeze contrib

#### Wine - http://www.winehq.org/
## Run this command: wget -O - http://www.lamaresh.net/apt/key.gpg | apt-key add -
vlc started to playing only the audio and not the video, i tried setting the video preferences but all video outputs didn't work. how do i get my video back
 
Old 05-18-2011, 07:42 PM   #2
SalmonEater
Member
 
Registered: Jun 2010
Location: Up the Big River w/o paddle
Distribution: Salent & Slackel
Posts: 131

Rep: Reputation: 19
Don't know if it still applies, but I had to do it a couple times in the past --

http://forum.videolan.org/viewtopic.php?t=70719&f=13

. . . but probably were aware of this. I would hope it is not still a problem!
 
Old 05-19-2011, 08:14 AM   #3
segmentation_fault
Member
 
Registered: Sep 2008
Location: Ioannina, Greece
Distribution: Gentoo
Posts: 332

Rep: Reputation: 54
I had the same problem few days ago. Reinstall of vlc solved the problem.
 
Old 05-19-2011, 12:11 PM   #4
baronobeefdip
Senior Member
 
Registered: Jul 2009
Distribution: Debian Squeeze
Posts: 1,172

Original Poster
Rep: Reputation: 32
i tried that and it didn't work
 
Old 05-20-2011, 07:59 AM   #5
segmentation_fault
Member
 
Registered: Sep 2008
Location: Ioannina, Greece
Distribution: Gentoo
Posts: 332

Rep: Reputation: 54
What version of vlc are you using? Have you tried downgrading? Have you tried disabling the debian-multimedia as suggested on the other forum?
When I had this problem I also installed some additional packages, like vlc-sdl but I can't tell if that did the trick.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
When playing an AVI with Kaffeine, the sound plays, but no video. Vetruvet Linux - Software 2 10-05-2008 03:20 PM
mplayer plays sound but NOT video of a .ogg video file minike Linux - Software 5 03-14-2007 08:51 AM
flash: sound plays slower than video Gay R0b0t Linux - Software 1 06-14-2005 11:03 PM
xine - plays sound but no video edudlive Linux - Software 3 08-29-2004 07:17 PM
Mplayer plays sound but not video. help! mordin Linux - Software 5 10-27-2003 01:59 PM


All times are GMT -5. The time now is 05:06 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration