LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 06-07-2009, 07:40 AM   #1
pathum
LQ Newbie
 
Registered: Mar 2009
Posts: 13

Rep: Reputation: 0
Exclamation VLC terminates when i try to play an AVI file.


This is what i get when i JUST RUN VLC from the TERMINAL

Quote:
patz@patz-desktop:~$ vlc
VLC media player 0.9.4 Grishenko
[00000001] main libvlc debug: VLC media player - version 0.9.4 Grishenko - (c) 1996-2008 the VideoLAN team
[00000001] main libvlc debug: libvlc was configured with ./configure '--build=i486-linux-gnu' '--enable-maintaner-mode' '--enable-release' '--prefix=/usr' '--enable-libtool' '--enable-fast-install' '--with-binary-version=1ubuntu3.1' '--disable-update-check' '--disable-gnome' '--disable-gtk' '--disable-familiar' '--disable-fb' '--enable-ggi' '--enable-sdl' '--enable-esd' '--enable-mad' '--enable-arts' '--enable-jack' '--enable-pulse' '--enable-lirc' '--enable-a52' '--enable-aa' '--enable-dvbpsi' '--enable-mozilla' '--with-mozilla-pkg=libxul-plugin' '--disable-kde' '--enable-mp4' '--enable-dvb' '--disable-satellite' '--enable-ogg' '--enable-vorbis' '--enable-shout' '--enable-qt4' '--disable-slp' '--enable-flac' '--disable-skins' '--disable-basic-skins' '--enable-skins2' '--enable-freetype' '--enable-mkv' '--enable-speex' '--enable-caca' '--enable-live555' '--enable-libmpeg2' '--enable-fribidi' '--enable-cdio' '--enable-mod' '--enable-theora' '--enable-modplug' '--enable-dvdnav' '--enable-gnutls' '--enable-ffmpeg' '--enable-ncurses' '--enable-smb' '--disable-gnomevfs' '--enable-bonjour' '--enable-mpc' '--enable-vcd' '--enable-vcdx' '--enable-notify' '--enable-twolame' '--enable-x264' '--enable-faad' '--disable-zvbi' '--enable-telx' '--enable-mediacontrol-bindings' '--disable-atmo' '--enable-taglib' '--enable-libass' '--enable-libdca' '--enable-alsa' '--enable-dv' '--enable-v4l' '--enable-v4l2' '--enable-pvr' '--enable-svgalib' '--enable-dvd' '--without-dvdcss' 'build_alias=i486-linux-gnu' 'CFLAGS=-g -O2' 'LDFLAGS=-Wl,--as-needed' 'CPPFLAGS=' 'CXXFLAGS=-g -O2'
[00000001] main libvlc debug: translation test: code is "C"
[00000001] main libvlc: Running vlc with the default interface. Use 'cvlc' to use vlc without interface.
X Error: BadMatch (invalid parameter attributes) 8
Major opcode: 2 (X_ChangeWindowAttributes)
Resource id: 0x4400048

And THIS is what i GET when i try to PLAY and AVI file on it
Quote:
QPainter::begin: Paint device returned engine == 0, type: 1
QPainter::begin: Paint device returned engine == 0, type: 1
[????????] x11 video output error: X11 request 147.3 failed with error code 8:
BadMatch (invalid parameter attributes)
[????????] x11 video output notice: buggy X11 server claims shared memory
[????????] x11 video output notice: support though it does not work (OpenSSH?)
[????????] x11 video output error: X11 request 147.3 failed with error code 8:
BadMatch (invalid parameter attributes)
X Error of failed request: BadMatch (invalid parameter attributes)
Major opcode of failed request: 147 (MIT-SHM)
Minor opcode of failed request: 3 (X_ShmPutImage)
Serial number of failed request: 63
Current serial number in output stream: 64
APPRECIATE IF ONE OF THE SMARTER GUYS COULD SUGGEST A SOLUTION
 
Old 06-07-2009, 12:33 PM   #2
Undeadzz
LQ Newbie
 
Registered: Apr 2008
Posts: 28

Rep: Reputation: 16
check a known good avi file and try to play that. at least u'll know if its the vlc that is bad or the avi file is corrupt.
 
Old 06-07-2009, 05:15 PM   #3
unixmen
Member
 
Registered: Jan 2009
Posts: 39

Rep: Reputation: 16
i thing that you media is missing some dependecies .

please install it again from the package manager

(remove the package first then
apt-get install vlc
of with yum if you are behind fedora of centos
 
Old 06-08-2009, 08:11 AM   #4
pathum
LQ Newbie
 
Registered: Mar 2009
Posts: 13

Original Poster
Rep: Reputation: 0
Question

Quote:
Originally Posted by Undeadzz View Post
check a known good avi file and try to play that. at least u'll know if its the vlc that is bad or the avi file is corrupt.

Bro i've already tried this...
 
  


Reply

Tags
avi, close, file, playing, vlc


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
HOW TO:enable totem and vlc to play avi files Nindoksei Linux - Software 1 04-17-2009 03:30 PM
unable to play .wmv and .avi files in vlc nkd Fedora 11 04-15-2008 08:21 PM
how can I play file avi file with DivX6.40 1280x720 24fps nos1833 Debian 2 12-27-2007 11:45 PM
I can't play .avi file Gins Linux - General 9 08-19-2007 01:56 PM
My player cant play rmvb file while avi file is ok......what's going on??!!! shuvernce Linux - General 6 03-28-2006 09:45 PM


All times are GMT -5. The time now is 09:22 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration