LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 10-03-2006, 02:04 AM   #1
large_satchell
LQ Newbie
 
Registered: Jul 2006
Posts: 17

Rep: Reputation: 0
VLC/mplayer can't play x264 HD-TV capture.


Yeah, so, when I try to watch a x264 (also called h264) encoded HD file (its a .mkv file), I get good audio, but the video is useless. (the video is a 720P HD capture). It looks all "blocky" and "choppy" (and generally unwatchable) like you're watching satellite TV during a hailstorm. How can I fix that?

heres what mplayer complains about:
====================================
Error while decoding frame!21 ct: 0.013 9/ 9 ??% ??% ??,?% 4 0
[h264 @ 0x876b98c]concealing 2720 DC, 2720 AC, 2720 MV errors6% 5 0
Error while decoding frame!72 ct: 0.018 17/ 17 128% 8% 4.4% 6 0
Error while decoding frame!33 ct: 0.024 20/ 20 119% 7% 4.1% 8 0
Error while decoding frame!12 ct: 0.022 21/ 21 113% 7% 4.1% 8 0
[h264 @ 0x876b98c]concealing 2720 DC, 2720 AC, 2720 MV errors6% 8 0
Error while decoding frame!41 ct: 0.016 29/ 29 106% 8% 3.6% 9 0

heres what vlc has to say about the situation:
===============================================
VLC media player 0.8.4a Janus
[00000293] a52 decoder: A/52 channels:6 samplerate:48000 bitrate:384000
No accelerated IMDCT transform found
[00000301] ffmpeg decoder error: more than 5 seconds of late video -> dropping frame (computer too slow ?)
[00000301] ffmpeg decoder error: more than 5 seconds of late video -> dropping frame (computer too slow ?)

Any ideas?

(BTW, I can play a 1080i HDTV captures just fine [.ts files]. They look fan-freakin-tastic.)
 
Old 02-06-2009, 06:18 AM   #2
Lancelot1
Member
 
Registered: Dec 2007
Location: Amsterdam
Distribution: (K)Ubuntu
Posts: 102

Rep: Reputation: 15
I had a problem playing back mkv files with vlc. I'm using Ubunto distro. I found that if you change the access filters in vlc dump from 32mb to a way higher value (i did 512mb) the slow video playback issue resolves and the high resolution mkv files i play 1080p/720p have no more problems. Sometimes you need to play around with the default preferences to get the best result!

BTW if you think you have any problems with your vlc and if it is compiled correctly just visit the www.videolan.org(I'm in no way connected to them!) site. They have linux support for alot of distro's
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
VLC Player crashes when asked to play LoveKing Linux - Software 7 09-16-2006 08:24 AM
".cam" webcam video -- is there a codec? Can I play it with xine, Mplayer, VLC, ...? ErrorBound Linux - Software 0 07-09-2006 10:44 AM
mplayer with x264 compile error jaykup Linux - Software 1 04-19-2006 02:22 PM
Cannot compile MPlayer 1.0pre7 with x264 support ginobili_mvp Linux - Software 3 12-04-2005 11:25 AM
VLC - RHEL4 - cant play dvds IcoNyx Linux - Software 1 09-30-2005 08:58 AM


All times are GMT -5. The time now is 11:18 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration