LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 03-20-2008, 12:30 PM   #1
Markz
LQ Newbie
 
Registered: Mar 2008
Posts: 6

Rep: Reputation: 0
VLC Media Player problems


Hey people. New to linux, new to the forums obviously. Just a little background..

To start, I absolutely LOVE linux. I am currently running PCLinuxOS MiniMe 2008 on an ANCIENT Dell OptiPlex GX1 with 128 mb of RAM. I have to say, I am VERY impressed with the performance of PCLOS on such a restricted computer hardware-wise. This is my second linux distro install ever, my first being a former Ubuntu 7.10 install I had tried a few months ago (I think in December) on this same computer. I was happy with Ubuntu for the few days I had it, but since it was Gnome-based it ran rather sluggishly on this computer's hardware. From there I switched to Damn Small Linux which was great but I had it for about two hours before discovering PCLinuxOS, which, again, I am very impressed with. The only limitations that take away from this distro's performance are the microscopic amouts of RAM and video memory.

But anyways, that aside, my main problem is VLC Media Player. I was never a fan of VLC, even on my current (yes, still running and still used) Windows XP install. It was VERY prone to crashing at random moments, but then again it was faster than Windows Media Player 11 so I had no choice but to use VLC. I had tried MPlayer on Windows but that was even more of an idiotic program than VLC was, with both sound and videos COMPLETELY out of sync be it a fresh install or whatever. Here on PCLOS, however, I have yet to try MPlayer.

With VLC on this computer, if I open ANY video file using the program, VLC will open, the player will resize to fit the video file's specifications, but then immediately close again. No warnings, no pop-up notifications, no windows asking me if I want to Terminate or Keep Running. It just closes. For the past few days I've had PCLOS installed as a fully up-and-running system, VLC has continued to consistently push my nerves to the limit. I really cannot find ANY reason as to why it does this, and have not found any answers on the internet either.

My other VLC issue is that it refuses to play sound based on the other programs currently running alongside it. For example, I found out from another site on the internet that a person was experiencing problems with VLC not playing any sound whatsoever but ONLY if Firefox was running. If he closed Firefox, focus would shift to VLC and the program would play like normally. I tried this myself and found out that I am in the same situation as he is; Firefox open, VLC mad. Again, however, I have yet to try any other media players aside from VLC.

Sorry for being so wordy. I do that a lot on forums.

Any help would be appreciated. Oh and I have to say, I really like this site, even though I've only been on it for about an hour haha.

Thanks in advance,

Mark

Last edited by Markz; 03-20-2008 at 12:33 PM.
 
Old 03-20-2008, 03:47 PM   #2
{BBI}Nexus{BBI}
Senior Member
 
Registered: Jan 2005
Location: Nottingham, UK
Distribution: Mageia 4
Posts: 4,305

Rep: Reputation: 205Reputation: 205Reputation: 205
A good comprehensive post. I suggest starting VLC from commandline (startup the konsole and type vlc), that way you will see any error messages, you can then copy and paste the output here to this forum. I prefer to use Xine or Kaffeine.
 
Old 03-20-2008, 05:28 PM   #3
larryfroot
LQ Newbie
 
Registered: Feb 2008
Location: I am a United Kingdom penguin
Distribution: Ubuntu / PClinuxOS
Posts: 22

Rep: Reputation: 15
Hi...

....I had the exact same thing happen to me whilst operating vlc with an ageing rather than ancient ati FireGL radeon 9000...in a dell laptop, as it happens. What I was advised to do was to open up vlc...go to preferences, check the advanced box on the bottom right hand corner. Then select output modules and a single drop down menu will appear on the right. You may have to maximise the window to see it properly though. I frustrated myself a while over that silly little detail...I then chose X11 as my preferred output mode and hey presto, vlc works fine. There are other modes you can experiment with, but it seems as if X11 is the one to go with older hardware. I really hope this works for you...

Last edited by larryfroot; 03-20-2008 at 05:30 PM.
 
Old 03-20-2008, 09:40 PM   #4
Markz
LQ Newbie
 
Registered: Mar 2008
Posts: 6

Original Poster
Rep: Reputation: 0
Nexus, thanks for the suggestions. I'll be sure to try Xine and Kaffeine.

larryfroot, either I'm stupid or the option of selecting output modules is not there..? Perhaps you discovered this solution in a previous version of VLC. I know somewhere I saw the designation of X11 but I just can't remember where..
 
Old 03-21-2008, 01:41 AM   #5
Electro
Guru
 
Registered: Jan 2002
Posts: 6,042

Rep: Reputation: Disabled
VLC versions after 0.0.72. Also VLC is picky on what compile options and gcc compiler that you use.

I suggest use mplayer from the command line. If you are using a nvVidia video card, use OpenGL as the video output device while playing back video. It gives better quality and more fluid video. The media player mplayer is meant to be used in Linux not in Windows. In Windows, I suggest use Media Player Classic.

You do need at least a 1 GHz processor to play back video files in Linux. Sure you can use xine-lib, but it does not have high tolerance of media errors.

Since the computer is old, the power supply could be causing you problems. Unfortunately Dell have history of using proprietary power supplies, so the the upgrade may not be easy to find.
 
Old 03-21-2008, 04:08 PM   #6
larryfroot
LQ Newbie
 
Registered: Feb 2008
Location: I am a United Kingdom penguin
Distribution: Ubuntu / PClinuxOS
Posts: 22

Rep: Reputation: 15
Hi Mark, sorry for the delay in getting back to you, my ubuntu laptop decided to lose the locale settings on bootup...very strange problem...anyways the vlc I am using is...

VLC media player 0.8.6c (wxWidgets interface)

And perhaps you might be making the same mistake as I did - and I should have flagged this up on my original post, if its at all relevant to a solution for you, then please accept my apologies.

I looked in the output module options for ages trying to work out how to switch the output to X11 before discovering the panel I needed to do it from is present when I simply clicked on the 'output modules' title without delving into the submenu it heads. I think I missed it partly because the sole drop-down menu on its panel is positioned almost out of sight when vlc isn't maximised.

God, did I feel dumb when I discovered my oversight! Ah well, all part of growing up I suppose.

Last edited by larryfroot; 03-21-2008 at 04:10 PM.
 
Old 03-21-2008, 07:47 PM   #7
Markz
LQ Newbie
 
Registered: Mar 2008
Posts: 6

Original Poster
Rep: Reputation: 0
Ahh yes, thank you for clearing that up. I too apparently missed the whole submenu concept haha.

I will attempt the change to X11 output and get back to you with the results.

Thanks!

UPDATE: Thank you so much! The X11 output solution works and has fixed all the problems I've so far identified. Thanks once again!

Last edited by Markz; 03-21-2008 at 07:50 PM.
 
Old 03-21-2008, 09:12 PM   #8
Markz
LQ Newbie
 
Registered: Mar 2008
Posts: 6

Original Poster
Rep: Reputation: 0
On second thought..

The problem has resumed.

I restarted the computer and everything was back to the old crappy "normal", even though the settings were still left at X11 output as I had saved them prior to rebooting.

Now my patience has REALLY been tried with VLC..

Heh I'm a bit of an impatient person, as you can tell
 
Old 03-22-2008, 05:12 AM   #9
larryfroot
LQ Newbie
 
Registered: Feb 2008
Location: I am a United Kingdom penguin
Distribution: Ubuntu / PClinuxOS
Posts: 22

Rep: Reputation: 15
Hold on...an idea!

At least my brain is starting to function as my previous post was made about 30 mins after I woke up.

I had exactly the same experience as you...

I had set the X11 output in the submenu, closed preferences and then enjoyed the sight of vlc running with compiz enabled - which was the reason I needed to enable X11 output in the first place.

Next time I tried it, instant death...however after continuing to faff around in the settings for a while I realised that the switch to use X11 in every session was not in the sub menu itself, but on the header for the submenu...which simply says 'output modules'. So if you have gone into the submenu and got a one off success, there is a chance that, like me, you simply went for the X11 tag in the submenu. Just maximise vlc, make sure you have advanced settings enabled and click on 'output modules' do not go into the submenu itself...a drop-down menu should then appear on the panel to the far right of the output modules button. Select X11 from that.

Please accept my apologies if this is exactly what you have already done, but I was fooled by the output modules submenu suddenly springing an X11 option on me. I saw X11 and simply wandered into it. God knows why it works the once and not subsequently.

From here on in I am not going to make posts before the first cup of industrial grade coffee of the day...

Last edited by larryfroot; 03-22-2008 at 05:54 AM.
 
Old 03-23-2008, 01:56 AM   #10
Electro
Guru
 
Registered: Jan 2002
Posts: 6,042

Rep: Reputation: Disabled
Again, VLC is glitchy and picky during compiling. I recommend use 0.7.x of VLC. It is a lot more stable than 0.8.x.
 
Old 03-23-2008, 08:44 AM   #11
Markz
LQ Newbie
 
Registered: Mar 2008
Posts: 6

Original Poster
Rep: Reputation: 0
I've done everything you have suggested, larryfroot, and yet VLC still refuses to cooperate.
I think I might just ditch VLC altogether until this problem is fixed for good.
Thank you for your help though.
Oh and I know where you're coming from in terms of needing coffee in the morning.
Only with me it's scrambled eggs and orange juice

MPlayer is throwing me these stupid errors as well.
No matter WHAT audio output I choose, it always comes back to me with the error:

"Could not open/initialize audio device -> no sound."

Hm.
 
Old 03-23-2008, 10:16 AM   #12
{BBI}Nexus{BBI}
Senior Member
 
Registered: Jan 2005
Location: Nottingham, UK
Distribution: Mageia 4
Posts: 4,305

Rep: Reputation: 205Reputation: 205Reputation: 205
Maybe another process is hogging the sound device. Do Ctrl & Esc to bring up your process manager, then kill the sound server or the app hogging the sound.
 
Old 03-24-2008, 12:47 AM   #13
larryfroot
LQ Newbie
 
Registered: Feb 2008
Location: I am a United Kingdom penguin
Distribution: Ubuntu / PClinuxOS
Posts: 22

Rep: Reputation: 15
This is an odd one...I am not too sure about vlc being hampered by other background processes...one thing that we haven't looked at is the hardware, could be an incompatability issue with the less than useful driver being handed to the system by unhappy default. Anyone with an ageing ati card on linux will grimly nod their agreement on that one...So Mark...whats under the hood of your box? And could there be a better driver for it?

But what really gets me is that it appeared to work...the option to try an earlier build of vlc could work. Or a replacement graphics card brought dead cheap and second hand.

So it looks like a list...

try an earlier build of vlc.

get a clear idea of what graphics card you have and search the forum with the make and model and the magic word 'problem'. That should stand a chance of meeting the right people who may help. Also check out the drivers allocated to the card and see if there are better ones, either open source or propriety. Did you use envy by any chance? Its an app that if you have an ati or an nvidia finds, downloads and installs the apprpriate drivers for you. Personally I was a little underwhelmed by it, but then plenty of other people swear by it.

In the light of all that you may find using a light-weight window manager/distro a good idea. generally they are optimised to run on older hardware...it could be the bulk of PCLOS geting in the way. if you are running compiz, turn it off and try vlc again. if you can bear it, that is. Zenwalk, damn small linux, puppy linux...generally they use xfce as the window manager so if bloat is causing poor performance in key areas, xfce will help with that, and the distro will almost certainly be better at handling ageing hardware. Well it is where their bread and butter is. Xubuntu 7.04 was ace. Xubuntu 7.10 is (IMHO) a victim of feature enrichment...ran unbelievably slow on my ageing laptop, as I was warned it would by a friend of mine. Who laughed in my face when I told him he was right.

lastly you can take your machine to an army firing range to deploy high explosive catharsis. I know thats what i would like to do...sometimes...good luck.

Last edited by larryfroot; 03-24-2008 at 12:49 AM.
 
Old 03-24-2008, 10:36 AM   #14
{BBI}Nexus{BBI}
Senior Member
 
Registered: Jan 2005
Location: Nottingham, UK
Distribution: Mageia 4
Posts: 4,305

Rep: Reputation: 205Reputation: 205Reputation: 205
Quote:
Originally Posted by Markz View Post
"Could not open/initialize audio device -> no sound."
That sometimes happens when the correct output device has not been selected in the mixer app. Open the mixer and see if you have a drop down box, with device choices.

In order for us to give better help/advice you need to post the output(s) of the error messages you recieve.

Your problems could also stem from the fact you are only running on 128mb of ram, 196mb is normally the required minimum if you intend to run the gui.
 
Old 03-24-2008, 12:22 PM   #15
Markz
LQ Newbie
 
Registered: Mar 2008
Posts: 6

Original Poster
Rep: Reputation: 0
According to the PCLOS hardware list, the card in this computer is an ATi Mach/Rage [?]

Being a linux noob I don't really know much on how to find updated drivers for outdated cards so not sure what to do here.

I agree with you, Nexus. Most likely a lot of problems are being caused by the small amount of RAM.

But I can't seem to find any drop-down lists in KMix that allow me to choose sound output devices.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
For all those having problems playing with VideoLan Client (VLC media player) stees Linux - Software 2 01-04-2013 09:23 AM
How to Set VLC Media Player as Default .wmv Player JonBL Linux - Software 2 04-24-2008 01:06 AM
VLC Media Player marvin00001 Linux - Laptop and Netbook 5 09-12-2006 06:04 AM
VLC Media Player carlosinfl Linux - Software 2 05-04-2006 03:24 PM
VLC media player problems unclejessie77 Linux - Software 0 10-26-2003 02:19 PM


All times are GMT -5. The time now is 08:18 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration