LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 01-14-2008, 03:54 PM   #1
speedygeo
LQ Newbie
 
Registered: Mar 2007
Location: Italy
Distribution: Archlinux, Debian
Posts: 29

Rep: Reputation: 15
Question VirtualBox shared folders


I use a linux guest on a linux host.
I set like shared folder my host's root.
But I don't know what device I should use to mount in the guest the host filesystem.
Until now the VB's manual and the VB's forum are useless for my trouble.
 
Old 01-14-2008, 04:10 PM   #2
speedygeo
LQ Newbie
 
Registered: Mar 2007
Location: Italy
Distribution: Archlinux, Debian
Posts: 29

Original Poster
Rep: Reputation: 15
This is the output:
Quote:
#mount -t vboxsf myroot /media/myroot
/sbin/mount.vboxsf: mounting failed with the error: No such device
 
Old 01-14-2008, 04:46 PM   #3
dracolich
Senior Member
 
Registered: Jul 2005
Distribution: Slackware
Posts: 1,173

Rep: Reputation: 47
Quote:
#mount -t vboxsf myroot /media/myroot
I'm not sure about vboxfs as a filesystem type. The path to the share should be //vboxsrv/myroot instead of just myroot.
Code:
#mount -t auto //vboxsrv/myroot /media/myroot
Also, make sure you have the VirtualBox additions installed in the guest. I think they're required for sharing to work.
 
Old 01-14-2008, 04:57 PM   #4
speedygeo
LQ Newbie
 
Registered: Mar 2007
Location: Italy
Distribution: Archlinux, Debian
Posts: 29

Original Poster
Rep: Reputation: 15
Doesn't work! Thanks.
 
Old 01-24-2008, 07:38 PM   #5
rbees
Member
 
Registered: Mar 2004
Location: northern michigan usa
Distribution: Debian Squeeze, Whezzy, Jessie
Posts: 664

Rep: Reputation: 42
If your network is working right you can share files without the guest additions via samba. Just set up your shares and you should be good to go. There is a post in the virtualbox forms that gives instructions for xp, but they worked fine when I setup a win95 guest on a debian host.

Just a tought
 
Old 01-24-2008, 10:57 PM   #6
speedygeo
LQ Newbie
 
Registered: Mar 2007
Location: Italy
Distribution: Archlinux, Debian
Posts: 29

Original Poster
Rep: Reputation: 15
It works too for a linux guest on a linux host?
 
Old 01-24-2008, 11:23 PM   #7
speedygeo
LQ Newbie
 
Registered: Mar 2007
Location: Italy
Distribution: Archlinux, Debian
Posts: 29

Original Poster
Rep: Reputation: 15
Question

What do you think?
This can help me?

Quote:
/proc/bus/usb usbfs devgid=1001,devmode=664 0 0
in /etc/fstab file.
 
Old 07-14-2009, 04:31 PM   #8
robinherbots
LQ Newbie
 
Registered: Jul 2009
Distribution: Slackware
Posts: 4
Blog Entries: 2

Rep: Reputation: 0
the correct command is

mount -t vboxsf SharedFolder /mnt/<folder>
 
Old 07-14-2009, 09:21 PM   #9
Zeedok
LQ Newbie
 
Registered: Jun 2007
Location: Sydney
Distribution: Ubuntu
Posts: 12

Rep: Reputation: 0
Quote:
Originally Posted by robinherbots View Post
the correct command is

mount -t vboxsf SharedFolder /mnt/<folder>
How can you mount the shared folders at login. Do you have to run a script (with the above command) or is their an entry in the FSTAB that will do the trick??
 
Old 07-16-2009, 03:01 AM   #10
robinherbots
LQ Newbie
 
Registered: Jul 2009
Distribution: Slackware
Posts: 4
Blog Entries: 2

Rep: Reputation: 0
in /etc/fstab

add the following line

SharedFolder /mnt/<folder> vboxsf defaults 0 0
 
Old 04-09-2010, 02:07 PM   #11
gbrisson
LQ Newbie
 
Registered: Jun 2009
Posts: 1

Rep: Reputation: 0
First, you should create a folder to be used as your mounting point (for example):

sudo mkdir /mnt/MyShare

Then, mount the shared folder using the name you set in VirtualBox for your share; for example, if you named your share "VirtualShare":

sudo mount -t vboxsf VirtualShare /mnt/MyShare

Hope that helps, cheers!
 
Old 10-15-2011, 05:21 PM   #12
taufikfahrudin
LQ Newbie
 
Registered: Oct 2011
Location: Yogyakarta, Indonesia
Distribution: Ubuntu, Debian, Puppy, W**d*s
Posts: 1

Rep: Reputation: Disabled
Quote:
Originally Posted by gbrisson View Post
First, you should create a folder to be used as your mounting point (for example):

sudo mkdir /mnt/MyShare

Then, mount the shared folder using the name you set in VirtualBox for your share; for example, if you named your share "VirtualShare":

sudo mount -t vboxsf VirtualShare /mnt/MyShare

Hope that helps, cheers!
Thanks, it works on my Debian Guest OS (from netinstall)
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Can't See Shared Folders Harpo Linux - Networking 2 09-03-2007 11:19 AM
virtualbox shared folder phantom_cyph Linux - Software 10 08-09-2007 01:14 PM
Shared Folders dudeman41465 Linux - Software 3 10-10-2005 03:12 AM
Shared Folders dudeman41465 Linux - Security 1 06-28-2005 06:38 PM
Shared Folders dudeman41465 Linux - Networking 2 06-27-2005 02:29 PM


All times are GMT -5. The time now is 08:12 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration