LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (http://www.linuxquestions.org/questions/linux-software-2/)
-   -   virtualbox shared folder (http://www.linuxquestions.org/questions/linux-software-2/virtualbox-shared-folder-574061/)

phantom_cyph 08-01-2007 09:36 PM

virtualbox shared folder
 
OK, I know there are some brief instructions in Virtualbox as to how to set up the shared folder, but, i don't really understand. The shared folder is in /home/phantom/unrealtourn I am trying to share it with WinXP. (Debian host, XP virtual) I don't know if the "net use x:..." command is to be used in the windows command prompt or what. I'm not familiar with setting up a lot of windows crap.

I simply need one folder to be accessable from XP to the unrealtourn folder in Debian. How do I do it? And please be specific.

Thanks!

bosewicht 08-02-2007 12:26 AM

In a Windows guest, use the following command:

net use x: \\vboxsvr\shareDirectory

vboxsvr is a fixed name, replace "x:" with the drive letter that you want to use for the share, and "shareDirectory" with the share name specified with VBoxManage. The space after the x: is needed!!

phantom_cyph 08-02-2007 08:59 AM

OK...that still doesn't work, but I'm probably doing something wrong.

I open command prompt in the guest account (guest, not limited user) and type:
Quote:

net use e: \\vboxsvr\unrealtourn
What is wrong?

phantom_cyph 08-02-2007 10:35 PM

Tried just about everything, renaming the file, etc. Given the folder is designated by virtualbox, do i need a pathname? (i.e. /home/phantomcyph/unrealtourn) to use in Windows? Is there some bs rule that you have to register Windows first before setting this up?

<edit>

Here is an exact copy of what the command prompt is telling me:
Quote:

MICROSOFT WINDOWS XP [VERSION 5.1.2600]
<C> COPYRIGHT 1985-2001 Microsoft Corp.

C:\Documents and Settings\test>net use e: \\vboxsvr\shared
System error 53 has occurred.

The network path was not found.

C:\Documents and Settings\test>
Note that "test" is a limited account, not guest, not admin.

phantom_cyph 08-05-2007 08:21 PM

Still not working, USB doesn't mount even when enabled,can read but not copy files from CD, I really need a shared folder set up, anyone have ideas?

david.hilton 08-08-2007 08:53 PM

This maps a network drive on Windows.
I only received this error when I misspelled the path.

Good luck!

David

crashmeister 08-08-2007 09:11 PM

I tried that and didn't get anywhere.Did get it to share folders but they always would disappear after reboot of the guest.After fiddling around I just got tired of the whole thing and setup samba to share between host and guest - works w/o any trouble.

Almost forgot - as with everything involving MS reboot at any oportunity.

david.hilton 08-09-2007 09:44 AM

Getting it to load at every boot up is as simple as Clicking on My Computer, Tools, Map Network Drive, setting the drive letter, and entering the path.

Of course you could do that with any network share.

David

phantom_cyph 08-09-2007 01:17 PM

Quote:

Originally Posted by david.hilton
Getting it to load at every boot up is as simple as Clicking on My Computer, Tools, Map Network Drive, setting the drive letter, and entering the path.

Of course you could do that with any network share.

David

Just tried that. Named "b", then entered "\\vboxsvr\shared", and it tried to connect but couldn't. Any suggestions?

dracolich 08-09-2007 01:40 PM

Which version of VirtualBox are you using? If it's at least 1.38 there should be an option under the VM settings to set certain paths as shared folders. Earlier versions has to manually use the vboxmanage command before starting the daemon. After that mapping the network drive should work ok. The net use command never worked for me but the menu option does and there is a checkbox for "Reconnect at logon".

How did you get it working using Samba? That sounds interesting.

crashmeister 08-09-2007 02:14 PM

Quote:

Originally Posted by dracolich
How did you get it working using Samba? That sounds interesting.

Just install samba on the host and xp should find the shared folders if the permissions are ok.

The only trouble I ran into was that I forgot to reboot xp in the vm.I don't know if it is strictly required but just editing the samba config,restarting samba and trying to find the folders in xp didn't work before a reboot.

Thats the config I used:

[global]
netbios name = kaiser
workgroup = GRUPO
security = user
[data]
path = /data2
read only = Yes
guest ok = Yes
browseable = yes
writeable = yes
[virt]
path = /vdata
read only = no
guest ok = yes
browseable = yes
writeable = yes
[nokia]
path = /media/1
read-only = no
guest ok = yes
browseable = yes
writeable = yes

Of course this is not the safest setup in the world but I live on the edge ;)


All times are GMT -5. The time now is 05:11 AM.