LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 10-13-2012, 02:25 PM   #1
kronflux
LQ Newbie
 
Registered: Jul 2008
Location: Halifax, NS.
Distribution: Linux Mint & Ubuntu Server
Posts: 3

Rep: Reputation: 0
Virtual JFS Partition mounting issue


I'm trying to set up a virtual JFS partition
(following this tutorial: http://maurits.tv/data/garrysmod/wik...index3761.html )

but when I get to the mounting stage, the command is the following:
"sudo mount -o rw,loop /root/gmod.img /mnt/gmod/"

I'm getting:
"mount: Could not find any loop device. Maybe this kernel does not know about the loop device? (If so, recompile or `modprobe loop'.)"

can anyone help me out here?


PS: The reason I'm doing this is to overcome the limitation of case sensitivity breaking certain addons for the Source Dedicated Server and Garry's Mod.
It is recommended on their wiki that one use a virtual VFS Partition/File to get around this.
 
Old 10-14-2012, 06:08 AM   #2
whansard
Senior Member
 
Registered: Dec 2002
Location: Mosquitoville
Distribution: RH 6.2, Gen2, Knoppix, 98,2000 + various
Posts: 3,171

Rep: Reputation: 52
are there any loop devices in your /dev? is this a custom kernel, and you accidently disabled loop devices? did you run "modprobe loop" to see if loop was a module?
 
Old 10-14-2012, 11:59 AM   #3
kronflux
LQ Newbie
 
Registered: Jul 2008
Location: Halifax, NS.
Distribution: Linux Mint & Ubuntu Server
Posts: 3

Original Poster
Rep: Reputation: 0
It's on a VPS, running Ubuntu Server 12.04 64bit
"modprobe loop" gives me:

"WARNING: Deprecated config file /etc/modprobe.conf, all config files belong into /etc/modprobe.d/.
FATAL: Module loop not found."

and under /dev I don't see anything reflecting "loop"

I don't really know what any of this means :P I'm not very experienced with linux yet.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Partition mounting issue scopiansl Linux - Server 5 09-30-2011 03:56 AM
Mounting partition issue.. criacuervo Linux - Newbie 10 08-18-2009 12:22 AM
trouble mounting jfs hdd fatman Linux - Hardware 0 08-31-2006 04:14 AM
How do I convert an empty ext3 partition to a jfs partition? lothario Linux - Software 3 02-28-2006 11:40 AM
Mounting a JFS LVM vbtalent Fedora 4 08-29-2005 12:28 PM


All times are GMT -5. The time now is 02:57 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration