LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (http://www.linuxquestions.org/questions/linux-software-2/)
-   -   Virtual JFS Partition mounting issue (http://www.linuxquestions.org/questions/linux-software-2/virtual-jfs-partition-mounting-issue-4175432047/)

kronflux 10-13-2012 01:25 PM

Virtual JFS Partition mounting issue
 
I'm trying to set up a virtual JFS partition
(following this tutorial: http://maurits.tv/data/garrysmod/wik...index3761.html )

but when I get to the mounting stage, the command is the following:
"sudo mount -o rw,loop /root/gmod.img /mnt/gmod/"

I'm getting:
"mount: Could not find any loop device. Maybe this kernel does not know about the loop device? (If so, recompile or `modprobe loop'.)"

can anyone help me out here?


PS: The reason I'm doing this is to overcome the limitation of case sensitivity breaking certain addons for the Source Dedicated Server and Garry's Mod.
It is recommended on their wiki that one use a virtual VFS Partition/File to get around this.

whansard 10-14-2012 05:08 AM

are there any loop devices in your /dev? is this a custom kernel, and you accidently disabled loop devices? did you run "modprobe loop" to see if loop was a module?

kronflux 10-14-2012 10:59 AM

It's on a VPS, running Ubuntu Server 12.04 64bit
"modprobe loop" gives me:

"WARNING: Deprecated config file /etc/modprobe.conf, all config files belong into /etc/modprobe.d/.
FATAL: Module loop not found."

and under /dev I don't see anything reflecting "loop"

I don't really know what any of this means :P I'm not very experienced with linux yet.


All times are GMT -5. The time now is 07:18 PM.