LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 04-13-2012, 10:27 PM   #1
DrSpatula
LQ Newbie
 
Registered: Nov 2011
Location: Buffalo, NY
Distribution: Arch
Posts: 4

Rep: Reputation: Disabled
vim omnicomplete not showing dropdown menu of completion choices


I'm attempting to set up omnicompletion for Ruby in vim as per this article

http://www.cuberick.com/2008/10/ruby...te-in-vim.html

I have this working on a VirtualBox VM running Arch, but my laptop installation of the same distro using the same .vim folder and .vimrc will not show the autocomplete menu when I press tab (using SuperTab plugin). Instead I get the first item, and need to keep pressing tab to get the other possible options. The menu is obviously more convenient, and I'd like to get it working. Any ideas?
 
Old 04-13-2012, 11:43 PM   #2
Asido
Member
 
Registered: Jan 2010
Location: Denmark
Distribution: Gentoo, Archlinux, FreeBSD, Slackware
Posts: 84

Rep: Reputation: 24
I couldn't see in the article completeopt set. I honestly doubt if this is a case, but I always have it and worth to try. In example: set completeopt=longest,menuone
 
Old 04-14-2012, 10:52 AM   #3
DrSpatula
LQ Newbie
 
Registered: Nov 2011
Location: Buffalo, NY
Distribution: Arch
Posts: 4

Original Poster
Rep: Reputation: Disabled
Already had that in my .vimrc. Thanks just the same.
 
Old 04-14-2012, 11:19 AM   #4
DrSpatula
LQ Newbie
 
Registered: Nov 2011
Location: Buffalo, NY
Distribution: Arch
Posts: 4

Original Poster
Rep: Reputation: Disabled
Solved my problem. For whatever reason, on this particular machine, the line:

highlight Pmenu ctermbg=238 gui=bold

from the tutorial was making my omnicomplete menu invisible (black on black). That combined with setting SuperTab's default completion type to omni solved the issue.

let g:SuperTabDefaultCompletionType = "<C-x><C-o>"
 
  


Reply

Tags
ruby, vim


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
how to edit right click dropdown menu in RHEL ws4 cruise.xiong Red Hat 1 08-18-2010 05:28 AM
KDM Dropdown Menu Font bill.ramby Linux - Software 2 03-29-2005 03:20 PM
CXOFFICE dropdown menu glitch TuxFreak Linux - Software 0 03-12-2005 07:03 PM
PHP Dropdown menu agallant Programming 1 06-10-2004 01:48 PM
PHP code and DropDown Menu Gerardoj Programming 2 04-15-2004 02:53 AM


All times are GMT -5. The time now is 01:42 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration