LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 07-01-2007, 11:47 AM   #1
robinhood1995
Member
 
Registered: Jan 2002
Location: Ohio
Distribution: CentOS 5.2
Posts: 52

Rep: Reputation: 15
Vim colors not working as root but okay in normal logins


Hi All,

We I just installed CentOS 5 on a new server and I have a strange thing going on.

In the past I never used a .vimrc and all worked okay for all the the redhat and centos versions.

After the install I created some users and logged in. Here no problem with the vim-enchanced mode all the colors are on when in vi mode to edit scripts.

No if I login as root I do not get any colors, does anyone have any ideas?

Thanks
 
Old 07-01-2007, 01:38 PM   #2
Ahmed
Member
 
Registered: May 2005
Location: München, Germany
Distribution: Slackware
Posts: 386

Rep: Reputation: 41
It worked for me by copying .vimrc to /usr/share/vim/vim71/vimrc
Just to make sure, in that directory you'll find files called vimrc_example.vim

-A
 
Old 07-01-2007, 04:35 PM   #3
robinhood1995
Member
 
Registered: Jan 2002
Location: Ohio
Distribution: CentOS 5.2
Posts: 52

Original Poster
Rep: Reputation: 15
I can't copy a .vimrc as I do not have on on the system.
 
Old 07-01-2007, 06:52 PM   #4
druuna
LQ Veteran
 
Registered: Sep 2003
Posts: 10,532
Blog Entries: 7

Rep: Reputation: 2371Reputation: 2371Reputation: 2371Reputation: 2371Reputation: 2371Reputation: 2371Reputation: 2371Reputation: 2371Reputation: 2371Reputation: 2371Reputation: 2371
Hi,

There should be an example vimrc in /usr/share/vim/vim70/ called vimrc_example.vim (change the vim70 part to your vim version). Copy that to /etc/vimrc (I assume there isn't a /etc/vimrc present). Edit /etc/vimrc to your liking.

/etc/vimrc is read globally by vim, so root should read it too, no need for individual ~/.vimrc file(s) although you can still create one for specific, user dependent settings.

Hope this helps.
 
Old 07-01-2007, 07:08 PM   #5
robinhood1995
Member
 
Registered: Jan 2002
Location: Ohio
Distribution: CentOS 5.2
Posts: 52

Original Poster
Rep: Reputation: 15
Thanks guys so far for the help.

That is what is so strange the /etc/vimrc does exist and I guess that is what the normal logins are using as they do work perfectly and as I do not have and .vimrc files on the system.

My version is also vm70 but the only one it does not work on is the root login funny enough...

I will try to replace with the vimrc_example.vim you both suggested.
 
Old 07-01-2007, 07:31 PM   #6
druuna
LQ Veteran
 
Registered: Sep 2003
Posts: 10,532
Blog Entries: 7

Rep: Reputation: 2371Reputation: 2371Reputation: 2371Reputation: 2371Reputation: 2371Reputation: 2371Reputation: 2371Reputation: 2371Reputation: 2371Reputation: 2371Reputation: 2371
Hi,

Strange.

Just some other things you could check:

- Is there a root alias that starts vi(m) with the -u NORC option? [starts vim without reading the vimrc file(s)]
- What does :version (in command mode) say about where it looks for vimrc files?
My output looks like this:
Quote:
system vimrc file: "/etc/vimrc"
user vimrc file: "$HOME/.vimrc"
user exrc file: "$HOME/.exrc"
- Is vimrc found during startup (I used strace and found he following in all the lines of output, At the time I had no .vimrc present only a /etc/vimrc):
Quote:
.
.
.
chdir("/etc") = 0
getcwd("/etc", 1024) = 5
fchdir(3) = 0
close(3) = 0
stat64("/etc/vimrc", {st_mode=S_IFREG|0644, st_size=1045, ...}) = 0
open("/etc/vimrc", O_RDONLY) = 3
fstat64(3, {st_mode=S_IFREG|0644, st_size=1045, ...}) = 0
mmap2(NULL, 4096, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1, 0) = 0xb7fc6000
read(3, "\" Begin /etc/vimrc\n\" General opt"..., 4096) = 1045
_llseek(3, 0, [0], SEEK_SET) = 0
stat64("/etc/vimrc", {st_mode=S_IFREG|0644, st_size=1045, ...}) = 0
read(3, "\" Begin /etc/vimrc\n\" General opt"..., 4096) = 1045
open(".", O_RDONLY) = 4
.
.
.
Hope this gets you closer to a solution.
 
  


Reply

Tags
vim, vimrc


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
vim colors AndeAnderson Linux - Software 3 03-09-2007 06:41 AM
Enabling colors for C++ in VIM gdeward Programming 2 07-24-2006 06:00 AM
vim colors fw12 Linux - General 5 07-02-2006 11:49 PM
vim colors Erik Thorsson Debian 1 02-09-2005 09:38 AM
syslog and normal user logins bujecas Slackware 9 12-20-2004 11:18 AM


All times are GMT -5. The time now is 11:30 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration