LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 10-16-2004, 12:05 AM   #1
alexchannell
Member
 
Registered: Nov 2003
Posts: 47

Rep: Reputation: 15
Video adapter, how to change?


I am running a Mobility Radeon 7500 (of course there is no specific driver for this card, thanks ATI). I am using SUSE 9.1 and used the YAST tool to change the adapter easily, then I updated the computer with APT and now it uses xorg instead of xfree, now I cannot use the YAST to change my video driver and I'm not about to do it by editing the files myself (way to much room for screwing something up). So how do I get the gui for the adapter to work again? (btw it says to install xfree so it can do it, I let it, and then when I hit the "change settings" the screen flashes and thats it, no dialog like usual. Any ideas?

Thanks, Alex
 
Old 10-16-2004, 12:24 AM   #2
alexchannell
Member
 
Registered: Nov 2003
Posts: 47

Original Poster
Rep: Reputation: 15
to add on, I can run some games in OpenGL like, tuxracer etc, but cant run Doom3

# /.../
# SaX generated XFree86 config file
# Created on: 2004-10-15T00:35:52-0400.
#
# Version: 4.8
# Contact: Marcus Schaefer <sax@suse.de>, 2002
#
# Automatically generated by [ISaX] (4.8)
# PLEASE DO NOT EDIT THIS FILE!
#
Section "Files"
FontPath "/usr/X11R6/lib/X11/fonts/misc:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/local"
FontPath "/usr/X11R6/lib/X11/fonts/75dpi:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/100dpi:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/Type1"
FontPath "/usr/X11R6/lib/X11/fonts/URW"
FontPath "/usr/X11R6/lib/X11/fonts/Speedo"
FontPath "/usr/X11R6/lib/X11/fonts/PEX"
FontPath "/usr/X11R6/lib/X11/fonts/cyrillic"
FontPath "/usr/X11R6/lib/X11/fonts/latin2/misc:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/latin2/75dpi:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/latin2/100dpi:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/latin2/Type1"
FontPath "/usr/X11R6/lib/X11/fonts/latin7/75dpi:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/baekmuk:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/japanese:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/kwintv"
FontPath "/usr/X11R6/lib/X11/fonts/truetype"
FontPath "/usr/X11R6/lib/X11/fonts/uni:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/CID"
FontPath "/usr/X11R6/lib/X11/fonts/ucs/misc:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/ucs/75dpi:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/ucs/100dpi:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/hellas/misc:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/hellas/75dpi:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/hellas/100dpi:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/hellas/Type1"
FontPath "/usr/X11R6/lib/X11/fonts/misc/sgi:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/xtest"
FontPath "/opt/kde3/share/fonts"
InputDevices "/dev/ttyS0"
InputDevices "/dev/ttyS1"
InputDevices "/dev/ttyS2"
InputDevices "/dev/ttyS3"
InputDevices "/dev/ttyS4"
InputDevices "/dev/ttyS5"
InputDevices "/dev/ttyS6"
InputDevices "/dev/ttyS7"
InputDevices "/dev/ttyS8"
InputDevices "/dev/psaux"
InputDevices "/dev/logibm"
InputDevices "/dev/sunmouse"
InputDevices "/dev/atibm"
InputDevices "/dev/amigamouse"
InputDevices "/dev/atarimouse"
InputDevices "/dev/inportbm"
InputDevices "/dev/gpmdata"
InputDevices "/dev/mouse"
InputDevices "/dev/usbmouse"
InputDevices "/dev/adbmouse"
InputDevices "/dev/input/mice"
InputDevices "/dev/input/event0"
InputDevices "/dev/pointer0"
InputDevices "/dev/pointer1"
InputDevices "/dev/pointer2"
InputDevices "/dev/pointer3"
EndSection

Section "ServerFlags"
Option "AllowMouseOpenFail"
Option "RandR" "on"
EndSection

Section "Module"
Load "glx"
Load "dbe"
Load "extmod"
Load "freetype"
Load "v4l"
Load "type1"
Load "speedo"
Load "dri"
EndSection

Section "InputDevice"
Driver "kbd"
Identifier "Keyboard[0]"
Option "Protocol" "Standard"
Option "XkbLayout" "us"
Option "XkbModel" "pc104"
Option "XkbRules" "xfree86"
EndSection

Section "InputDevice"
Driver "mouse"
Identifier "Mouse[1]"
Option "Device" "/dev/input/mice"
Option "Name" "Autodetection"
Option "Protocol" "explorerps/2"
Option "Vendor" "Sysp"
EndSection

Section "InputDevice"
Driver "mouse"
Identifier "Mouse[3]"
Option "Buttons" "5"
Option "Device" "/dev/input/mice"
Option "Name" "Autodetection"
Option "Protocol" "explorerps/2"
Option "Vendor" "Sysp"
EndSection

Section "InputDevice"
Driver "mouse"
Identifier "Mouse[5]"
Option "Buttons" "5"
Option "Device" "/dev/input/mice"
Option "Name" "Autodetection"
Option "Protocol" "explorerps/2"
Option "Vendor" "Sysp"
Option "ZAxisMapping" "4 5"
EndSection

Section "Monitor"
Option "CalcAlgorithm" "CheckDesktopGeometry"
DisplaySize 360 270
HorizSync 59-85
Identifier "Monitor[0]"
ModelName "1600X LAPTOP DISPLA PANEL"
VendorName "DELL"
VertRefresh 40-90
UseModes "Modes[0]"
EndSection

Section "Modes"
Identifier "Modes[0]"
Modeline "1600x1200" 155.47 1600 1704 1880 2160 1200 1201 1204 1241
Modeline "1600x1200" 162.00 1600 1664 1856 2160 1200 1201 1204 1250 +HSync +VSync
Modeline "1600x1200" 181.80 1600 1712 1888 2176 1200 1201 1204 1247
EndSection

Section "Screen"
DefaultDepth 16
SubSection "Display"
Depth 15
Modes "1600x1200"
EndSubSection
SubSection "Display"
Depth 16
Modes "1600x1200"
EndSubSection
SubSection "Display"
Depth 24
Modes "1600x1200"
EndSubSection
SubSection "Display"
Depth 32
Modes "1600x1200"
EndSubSection
SubSection "Display"
Depth 8
Modes "1600x1200"
EndSubSection
Device "Device[0]"
Identifier "Screen[0]"
Monitor "Monitor[0]"
EndSection

Section "Device"
BoardName "Radeon QD"
Driver "radeon"
Identifier "Device[0]"
Screen 0
Option "Rotate" "off"
VendorName "ATI"
EndSection

Section "ServerLayout"
Identifier "Layout[all]"
InputDevice "Keyboard[0]" "CoreKeyboard"
InputDevice "Mouse[1]" "CorePointer"
InputDevice "Mouse[3]" "SendCoreEvents"
InputDevice "Mouse[5]" "SendCoreEvents"
Option "Clone" "off"
Option "Xinerama" "off"
Screen "Screen[0]"
EndSection

Section "DRI"
Group "video"
Mode 0660
EndSection
 
Old 10-16-2004, 12:25 AM   #3
alexchannell
Member
 
Registered: Nov 2003
Posts: 47

Original Poster
Rep: Reputation: 15
doom3 error:


--------------------------------------
----- Initializing Decls -----
------------------------------
/proc/cpuinfo CPU frequency: 1196.06 MHz
guessing video ram ( use +set sys_videoRam to force ) ..
guess failed, return default low-end VRAM setting ( 64MB VRAM )
Detected
1.20 GHz CPU
496 MB of System memory
64 MB of Video memory on an optimal video architecture

This system qualifies for Low quality.
------- Initializing renderSystem --------
using ARB renderSystem
renderSystem initialized.
--------------------------------------
5151 strings read from strings/english.lang
Couldn't open journal files
execing editor.cfg
execing default.cfg
couldn't exec DoomConfig.cfg
couldn't exec autoexec.cfg
5151 strings read from strings/english.lang
----- Initializing Sound System ------
sound system initialized.
--------------------------------------
----- R_InitOpenGL -----
dlopen(libGL.so.1)
Open X display
Initializing OpenGL display
Using XFree86-VidModeExtension Version 2.2
DGA DirectVideo Mouse (Version 2.0) initialized
Free86-VidModeExtension Activated at 640x480
Couldn't get a visual
dlopen(libGL.so.1)
Initializing OpenGL display
Using XFree86-VidModeExtension Version 2.2
DGA DirectVideo Mouse (Version 2.0) initialized
Free86-VidModeExtension Activated at 640x480
Couldn't get a visual
idRenderSystem::Shutdown()
Fatal X Error:
Major opcode of failed request: 105
Minor opcode of failed request: 0
Serial number of failed request: 47
BadValue (integer parameter out of range for operation)
Fatal X Error:
Major opcode of failed request: 2
Minor opcode of failed request: 0
Serial number of failed request: 51
BadWindow (invalid Window parameter)
Fatal X Error:
Major opcode of failed request: 4
Minor opcode of failed request: 0
Serial number of failed request: 52
BadWindow (invalid Window parameter)
Sys_Error: Unable to initialize OpenGL




I get 1500 fps in glxgears so I know opengl works, so whats going on?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Video overlays full of ectoplasm after adapter change. IamI Mandriva 1 08-24-2004 08:41 PM
Video adapter problem John Micheal Linux - Hardware 1 04-11-2004 03:11 AM
video/network adapter schneider Linux - Newbie 1 03-19-2004 03:47 AM
How to configure Video Adapter XPediTioN Slackware 1 07-07-2003 02:17 PM
Video Conferencing Adapter Stephanie Linux - General 0 10-10-2001 02:10 PM


All times are GMT -5. The time now is 02:07 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration