LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 07-02-2003, 11:53 AM   #1
phoeniXflame
Member
 
Registered: Feb 2003
Location: Somewhere, UK
Distribution: Slack, OpenBSD, Debian, SuSE
Posts: 189

Rep: Reputation: 30
VI & VIM dont behave


for some reason the copy of vi and vim that run on my local machine seem to behave totally differently to those ran by a shell provider that I host with, dispite the fact that they are the same versions and where compiled in the same way (ie. with no special options etc.)

when I asked my shell providers about this they suggested that my local machine may have the wrong terminal settings, however, I'm not entirly sure what they mean by this ? I use xterm to run the editors from fluxbox, this is what I'd usually do to edit a file on my remote shell ....

1. open file using "vim filename"
2. navigate to the area what needs changing using arrow keys
3. find area which needs editing and press "i" to bring up INSERT
4. delete/insert text using delete key etc. etc.
5. press escape to leave INSERT mode
6. press ":" and enter "wq" to write and quit the editor

this just dosnt seem to work on my local machine, when in INSERT mode the arrow keys seem to insert letters insted of moving the cursor ? and I cant seem to create a new line, lots of things like that really its very frustracting because I hate using editors such as PICO, I'd LOVE to be able to use vim or vi on this machine, please help me !
 
Old 07-02-2003, 12:25 PM   #2
kkempter
Member
 
Registered: Dec 2002
Posts: 187

Rep: Reputation: 30
it sounds like a term issue, check and see what your $TERM environment variable is set to (at the command line type echo $TERM).

Also what distro and what term program are you running (xterm, terminal, etc) ?

setting to vt100 (export TERM=vt100) is a good all-around setting to try unless you are running under cygwin, then the term must be 'cygwin'
 
Old 07-02-2003, 12:40 PM   #3
phoeniXflame
Member
 
Registered: Feb 2003
Location: Somewhere, UK
Distribution: Slack, OpenBSD, Debian, SuSE
Posts: 189

Original Poster
Rep: Reputation: 30
hiya, thanks for the suggestion, its xterm under fluxbox on a slackware system, term env is set to 'xterm' I tried changing to vt100 but to no noticable effect/change in the situation
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Possible problem with VISUAL=vi (vim & bash) redthor Linux - Newbie 2 04-26-2005 07:19 AM
vim & aspell configuration edM Slackware 4 03-29-2005 01:50 PM
VI & VIM are borked! d33pdream Linux - Software 4 11-15-2004 03:57 AM
vim 6.2 & set nocp JJX Linux - Newbie 6 04-08-2004 07:34 AM
XFCE 4.0.1 & vim fr0zen Linux - Software 2 12-11-2003 03:23 PM


All times are GMT -5. The time now is 01:14 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration