LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 01-09-2005, 11:36 AM   #1
lasindi
Member
 
Registered: Apr 2004
Distribution: Slackware, Ubuntu
Posts: 101

Rep: Reputation: 15
Very Poor Multi-tasking, Apparent Hard Drive I/O Issue


This is a very weird issue and I'll try my best to explain it. Whenever a process tries accessing the hard drive, the computer will stutter, and if a process is doing it all of the time, everything else completely slows to a crawl. Here's what I mean:

Say I want to burn a CD while I'm listening to music and browsing the web. XCDRoast hogs the CPU, the music stutters so badly that I get a headache listening to it, and the mouse cursor is very choppy when I move it, so much so that it's highly inconvenient to do anything with it. Typing text will take forever, etc. Specifically, the kblockd daemon takes up about 25% CPU (according to the KDE System Guard).

There are other processes that will do this, but CD burning is quite bad. CD burning, extracting tar balls, and moving files on the hard drive are pretty much the worst, all of which involve using the hard drive (CD burning would mean accessing an ISO image). Even activity like downloading a file from the Internet will cause the computer to stutter about every five seconds. I'm guessing that that's because file doesn't copy as quickly as moving a file from one directory to another. Now that I can't even download without getting bothered, I've really gotten fed up with the issue. I very strongly suspect that the kernel is at fault (kblockd is a kernel daemon, isn't it?). I'm running 2.6.10, but I've tried this with lots of others, including 2.4.x, and I still have the same problems. Am I forgetting to enable/disable some option? Help would be *greatly* appreciated.

lasindi
 
Old 01-09-2005, 05:38 PM   #2
teval
Member
 
Registered: Jul 2003
Location: Toronto, Canada
Distribution: Gentoo
Posts: 720

Rep: Reputation: 30
Post the results of
hdparm -tT /dev/hda (or whatever drive you're booting from)
hdparm /dev/hda
hdparm -i /dev/hda

And look on google for people promising to make your drives faster by using hdparm. There are quite a few guides out there. If they don't help, come, post, and we'll try again.
Also try running your filesystem check utility of choice. (it varies according to what fs you're running)
 
Old 01-09-2005, 11:31 PM   #3
lasindi
Member
 
Registered: Apr 2004
Distribution: Slackware, Ubuntu
Posts: 101

Original Poster
Rep: Reputation: 15
Fixed! I believe the problem was with the kernel's support for my IDE chipset. In the kernel configuration, I went into "Device Drivers" -> "ATA/ATAPI/MFM/RLL support". There, I enabled "PCI IDE chipset support", "Generic PCI IDE Chipset Support", "Use PCI DMA by default when available" and "AMD and nVidia IDE support" (this is because my motherboard chipset is NVIDIA nForce2). Now everything works great. I'm not sure if I can or should disable any of these options, but now it works so I'm not really touching it. I do know that my "timing buffered disk" rate (what you get with 'hdparm -t /dev/hdX') is now up from about 6 or 7 MB/sec to 32 MB/sec, which is a great bonus (I think it must be because of the DMA), even though the trouble wasn't with the transfer rate. Anyhow, thank you teval for your help.

Boy I'm glad that's fixed. It was the biggest thorn in my side for such a long time.

lasindi
 
Old 01-10-2005, 01:41 AM   #4
daihard
Member
 
Registered: Jul 2003
Location: Seattle, WA
Distribution: Kubuntu 12.04
Posts: 913

Rep: Reputation: 32
Talking

Quote:
Originally posted by lasindi
I do know that my "timing buffered disk" rate (what you get with 'hdparm -t /dev/hdX') is now up from about 6 or 7 MB/sec to 32 MB/sec, which is a great bonus (I think it must be because of the DMA), even though the trouble wasn't with the transfer rate. Anyhow, thank you teval for your help.
Well, I do think that the trouble was the transfer rate you're talking about. From what I've learned on this forum, the result of "hdparm -t" is a sustained transfer rate, which means the internal read/write speed of the disk.

The rate jumped most probably because of the chipset support you compiled into the kernel. I doubt the DMA setting ("hdparm -d") would make much of a difference. My hard disk has an STR of about 50 MB/sec, whether or not I enable DMA on it.

Glad you got your problem solved, anyway.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Hard Drive Issue The Oate Mandriva 6 07-28-2004 12:43 PM
Hard drive(s) issue randyriver10 Linux - Hardware 10 07-12-2004 05:57 PM
Grub to access new hard drive and old multi os hard drive ? gedi1 Linux - Hardware 0 06-03-2004 01:01 PM
2nd hard drive issue aotweb Linux - Hardware 3 06-30-2003 11:50 AM
a multi compatible hard drive... xconspirisist Linux - Networking 0 12-22-2002 01:43 PM


All times are GMT -5. The time now is 11:45 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration