LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 02-24-2003, 07:01 AM   #1
BadGuy
LQ Newbie
 
Registered: Feb 2003
Location: Netherlands
Posts: 2

Rep: Reputation: 0
version 'GLIBC_2.3' not found


Ok what am I doing? I'm trying to run samba I downloaded a clean version and tried to build it but it wouldn't for some reason (same reason it won't run?) so I got up and went to the slackware ftp (as I am running slackware). And got the current version of samba (also 2.2.7a) as a package. Wich DID install. Now I'm testing if it IS installed and can be run and I get this error:

Code:
smbd: /lib/libc.so.6: version 'GLIBC_2.3' not found (required by smbd)
I tried reinstalling glibc from my slackware cd (wich should have been installed by default and probably also has been...). I tried surfing abit and go through some google stuff. But no results that actually helped. They all went on about recompiling what ever it is you are having problems with. That's not an option. If it's the only way to get it to run I will dish up the problem I am having when building. But I'm a bit of a and well try to be clear or maybe give an url whatever.

Summary:
Running a server with slackware 8.1 upgraded samba to the latest version it won't run because of version error in the GLIBC.

Any help would be greatly appreciated.
 
Old 02-24-2003, 07:15 AM   #2
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,407

Rep: Reputation: 1965Reputation: 1965Reputation: 1965Reputation: 1965Reputation: 1965Reputation: 1965Reputation: 1965Reputation: 1965Reputation: 1965Reputation: 1965Reputation: 1965
run
Code:
strings /lib/libc.so.6 | grep GLIBC
and see if its does contain the define, if there's nothing about 2.3 then you'll need to upgrade your glib package. 2.3.1 is the newest stable version.
 
Old 02-24-2003, 07:50 AM   #3
BadGuy
LQ Newbie
 
Registered: Feb 2003
Location: Netherlands
Posts: 2

Original Poster
Rep: Reputation: 0
Fixed it

Yes thnx turned out I needed that upgrade (figured that out myself too) I just went to slackware current and searched for the glibc (of wich I did not know the location). I found it wit the l packages. So if anyone using slackware needs the package it's in the l dir and not in the d as the slackware site makes you believe
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
version GLIBC_2.3 not found error when cross compiled executable is run on targert sateeshgalla Programming 3 05-14-2008 10:42 AM
/lib/libpthread.so.): version 'GLIBC_2.3.2' not found solutionseeker Linux - Newbie 21 01-29-2005 09:02 PM
GlibC_2.3 not found message when .configure shazam75 Linux - Software 0 10-15-2004 03:33 AM
Problem with Insight II - version GLIBC_2.2 not defined in file libc.so.6... belga Linux - Software 3 08-18-2004 01:01 PM
xauth: /lib/i686/libc.so.6: version 'GLIBC_2.3.2' not found yigald Linux - Newbie 0 02-20-2004 11:52 PM


All times are GMT -5. The time now is 04:05 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration