LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 01-17-2012, 02:21 AM   #1
kaz2100
Senior Member
 
Registered: Apr 2005
Location: Penguin land, with apple, no gates
Distribution: Debian testing woody(32) sarge etch lenny squeeze(+64) wheezy jessie
Posts: 1,436

Rep: Reputation: 83
/usr/local/lib/libproj.a /usr/lib/libproj.so conflict. (QLandkarteGT)


Hya

System
Debian wheezy, amd64

Situation
For some reason, /usr/local/lib/libproj.a exists.

I want to compile qlandkarte, because I need to add several locales.

I followed the instruction found here.

svn... OK
mkdir... OK
cd... OK
ccmake... OK (cmake also works.)

Then,
make chokes, because of existence of /usr/local/lib/libproj.a

I do not remember why this file exists, however, it is a bit risky to remove.

Malformed solution
As I do not have much experience with cmake, I manually edited several files (src/CMakeFiles/qlandkartegt.dir/build.make, CMakeCache.txt, 3rdparty/cache2gtiff/CMakeFiles/cache2gtiff.dir/build.make and 3rdparty/map2gcm/CMakeFiles/map2gcm.dir/build.make) which point /usr/local/lib/libproj.a. Now, these files point /usr/lib/libproj.so

Things went well, good!

However, is there any easier way?
 
Old 01-17-2012, 04:37 AM   #2
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen, DK
Distribution: pclos2014, Slack14.1 DebWheezy, +50+ other Linux OS, for test only.
Posts: 13,642

Rep: Reputation: 2531Reputation: 2531Reputation: 2531Reputation: 2531Reputation: 2531Reputation: 2531Reputation: 2531Reputation: 2531Reputation: 2531Reputation: 2531Reputation: 2531
Quote:
I do not remember why this file exists, however, it is a bit risky to remove.
Well, then just hide all /usr/local/lib/ libproj*
while compiling and testing QLandkarteGT.


But : The package "QLandkarteGT" is actually available for Wheezy
http://packages.debian.org/wheezy/qlandkartegt
# apt-get install qlandkartegt

I'd guess that the Wheezy qlandkartegt-1.2.3 is a late version,
as the files you can get with 'svn' are dated 2010.

.

Last edited by knudfl; 01-17-2012 at 04:55 AM.
 
  


Reply

Tags
cmake, conflicts, library


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
OPENNMS INSTALLATION ERROR -install –disU –l /usr/lib/jni:/usr/lib ramecare Linux - Server 4 07-11-2011 12:06 PM
opennms installation error -install –disU –l /usr/lib/jni:/usr/lib ramecare Linux - Server 2 07-08-2011 10:51 AM
Compromised? Files "/usr/lib.hwm", "/usr/lib.pwd", "/usr/lib.pwi" Klaus Pforte Linux - Security 4 09-28-2004 11:33 PM
Installing software, /usr/lib directory and /usr/local millertime Linux - Software 2 07-10-2004 09:21 AM


All times are GMT -5. The time now is 03:31 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration