LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 03-23-2004, 03:16 PM   #1
Baryonic Being
Member
 
Registered: Mar 2004
Distribution: Arch
Posts: 139

Rep: Reputation: 15
Using the 'make' command consistently returns errors


This is occurring to me frequently whenever I use the 'make' command or attempt to compile a KDevelop project, so there's probably a simple explanation. For example, I am trying to compile the Konserve software from source, and when using 'make' I receive the following:

make all-recursive
make[1]: Entering directory `/home/konserve-0.10'
Making all in konserve
make[2]: Entering directory `/home/konserve-0.10/konserve'
Making all in .
make[3]: Entering directory `/home/konserve-0.10/konserve'
/bin/sh ../libtool --silent --mode=link --tag=CXX g++ -Wnon-virtual-dtor -Wno-long-long -Wundef -Wall -pedantic -W -Wpointer-arith -Wwrite-strings -ansi -D_XOPEN_SOURCE=500 -D_BSD_SOURCE -Wcast-align -Wconversion -O2 -fno-exceptions -fno-check-new -o konserve -L/usr/X11R6/lib -L/usr/lib/qt3/lib -L/usr/lib -R /usr/lib -R /usr/lib/qt3/lib -R /usr/X11R6/lib helper.o backupprofile.o profilemanager.o dumpable.o timeinterval.o configurator.o systemtraywidget.o wizard.o profilemngrinterface.o configurationdlg.o main.o konserve.o configurationdlgbase.o identifierwidget.o sourceurlwidget.o backupurlwidget.o timeintervalwidget.o finalwidget.o konserve.moc.o systemtraywidget.moc.o profilemanager.moc.o backupprofile.moc.o wizard.moc.o configurationdlg.moc.o -lqt-mt -lpng -lz -lm -lXext -lX11 -lSM -lICE -lpthread -lkdecore -lkdeui -lkio
libtool: link: cannot find the library `/usr/lib/libfam.la'
make[3]: *** [konserve] Error 1
make[3]: Leaving directory `/home/konserve-0.10/konserve'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/home/konserve-0.10/konserve'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/home/konserve-0.10'
make: *** [all] Error 2

Any light on the matter would be greatly appreciated.
 
Old 03-23-2004, 03:22 PM   #2
trickykid
LQ Guru
 
Registered: Jan 2001
Posts: 24,149

Rep: Reputation: 234Reputation: 234Reputation: 234
Well, it appears it can't find: libfam.la

Your error here:
libtool: link: cannot find the library `/usr/lib/libfam.la'

Check out this link, first hit off a google search to bring you back to great 'ol LQ.org: http://www.linuxquestions.org/questions/history/69312
 
Old 03-23-2004, 03:32 PM   #3
Baryonic Being
Member
 
Registered: Mar 2004
Distribution: Arch
Posts: 139

Original Poster
Rep: Reputation: 15
Thanks. I've installed the right package and I now get the following:

make all-recursive
make[1]: Entering directory `/home/duck/Documents/konserve-0.10'
Making all in konserve
make[2]: Entering directory `/home/duck/Documents/konserve-0.10/konserve'
Making all in .
make[3]: Entering directory `/home/duck/Documents/konserve-0.10/konserve'
/bin/sh ../libtool --silent --mode=link --tag=CXX g++ -Wnon-virtual-dtor -Wno-long-long -Wundef -Wall -pedantic -W -Wpointer-arith -Wwrite-strings -ansi -D_XOPEN_SOURCE=500 -D_BSD_SOURCE -Wcast-align -Wconversion -O2 -fno-exceptions -fno-check-new -o konserve -L/usr/X11R6/lib -L/usr/lib/qt3/lib -L/usr/lib -R /usr/lib -R /usr/lib/qt3/lib -R /usr/X11R6/lib helper.o backupprofile.o profilemanager.o dumpable.o timeinterval.o configurator.o systemtraywidget.o wizard.o profilemngrinterface.o configurationdlg.o main.o konserve.o configurationdlgbase.o identifierwidget.o sourceurlwidget.o backupurlwidget.o timeintervalwidget.o finalwidget.o konserve.moc.o systemtraywidget.moc.o profilemanager.moc.o backupprofile.moc.o wizard.moc.o configurationdlg.moc.o -lqt-mt -lpng -lz -lm -lXext -lX11 -lSM -lICE -lpthread -lkdecore -lkdeui -lkio
make[3]: Leaving directory `/home/duck/Documents/konserve-0.10/konserve'
make[2]: Leaving directory `/home/duck/Documents/konserve-0.10/konserve'
Making all in po
make[2]: Entering directory `/home/duck/Documents/konserve-0.10/po'
make[2]: Nothing to be done for `all'.
make[2]: Leaving directory `/home/duck/Documents/konserve-0.10/po'
Making all in doc
make[2]: Entering directory `/home/duck/Documents/konserve-0.10/doc'
Making all in .
make[3]: Entering directory `/home/duck/Documents/konserve-0.10/doc'
make[3]: Nothing to be done for `all-am'.
make[3]: Leaving directory `/home/duck/Documents/konserve-0.10/doc'
Making all in konserve
make[3]: Entering directory `/home/duck/Documents/konserve-0.10/doc/konserve'
/usr/bin/meinproc --check --cache index.cache.bz2 ./index.docbook
make[3]: Leaving directory `/home/duck/Documents/konserve-0.10/doc/konserve'
make[2]: Leaving directory `/home/duck/Documents/konserve-0.10/doc'
make[2]: Entering directory `/home/duck/Documents/konserve-0.10'
make[2]: Nothing to be done for `all-am'.
make[2]: Leaving directory `/home/duck/Documents/konserve-0.10'
make[1]: Leaving directory `/home/duck/Documents/konserve-0.10'

Make install doesn't work either.
 
Old 03-23-2004, 04:16 PM   #4
andrewlkho
Member
 
Registered: Jul 2003
Location: London
Posts: 548

Rep: Reputation: 30
Um...I can't see an error message above. Perhaps you haven't posted all of the final output?
 
Old 03-24-2004, 02:02 PM   #5
Baryonic Being
Member
 
Registered: Mar 2004
Distribution: Arch
Posts: 139

Original Poster
Rep: Reputation: 15
Sorry. You're quite right. There isn't an error. The error was in the make install command but I've fixed that now because I realise I should have been in root.

Thanks for your help.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
make command gives errors whizz Linux - Newbie 4 04-02-2005 12:14 PM
The MAKE command SuSE 9.2 gives errors jasone SUSE / openSUSE 2 04-01-2005 09:15 AM
command: make errors alltime Mandriva 0 01-26-2005 03:31 PM
Log errors from 'make' command, how do i? winky Linux - Software 13 08-21-2003 12:31 PM
LFS Chap 5 - gcc first make command errors antken Linux From Scratch 3 03-17-2003 11:38 PM


All times are GMT -5. The time now is 08:16 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration