LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (http://www.linuxquestions.org/questions/linux-software-2/)
-   -   using gnome-screensaver in XFCE and NOT xscreensaver (http://www.linuxquestions.org/questions/linux-software-2/using-gnome-screensaver-in-xfce-and-not-xscreensaver-458516/)

tokyo_ 06-26-2006 03:52 PM

using gnome-screensaver in XFCE and NOT xscreensaver
 
im currently using Ubuntu 6.06 XFCE and i would like to make gnome-screensaver the default screensaver app.

both xscreensaver and gnome-screensaver are installed.

i would like to know how to:
1. make gnome-screensaver the default
2. how to configure gnome-screensaver (it's not showing up in any of the menus)

any help would be appreciated, cheers.

fortran01 09-16-2006 11:00 AM

By default, xfce screensaver requires xscreensaver. You have the *option* to remove xscreensaver using the following command (as privileged):

Code:

apt-get remove xscreensaver
To install gnome-screensaver use the following command (as privileged):

Code:

apt-get install gnome-screensaver
To auto-start gnome-screensaver, add it as an Autostarted Application:

Xfce menu > Settings > Autostarted Applications

The command for starting the gnome-screensaver daemon is:

Code:

gnome-screensaver
To be able to use the action button "Lock screen" to start gnome-screensaver immediately and lock your screen, modify the file /usr/bin/xflock4:

Code:

#xscreensaver-command -lock || xlock $*
gnome-screensaver-command --lock
exit 0

Note that the original xscreensaver command is now commented. To be safe, backup the original copy of xflock4 (as privileged):

Code:

cp /usr/bin/xflock4 /usr/bin/xflock4.orig
Hope that helps.

JWilliamCupp 08-12-2008 08:02 AM

*Don't* want gnome-screensaver
 
I have the opposite problem. I have both xscreensaver and gnome-screensaver installed. I used yum for regular updates and at some point recently it seems a gnome update changed things in a way I don't want.

For quite a while xscreensaver has been running just fine. Now, however, xscreensaver does not run. When I start it manually, I get an error "gnome-screensaver daemon is running and must be stopped first."

I haven't done anything with regard to gnome-screensaver (meaning I didn't configure the daemon to start on boot up or log in). So this is why I suspect the change occurred through a yum update.

How can I get gnome-screensaver to stay out of the way so that xscreensaver will run normally?

- Bill


All times are GMT -5. The time now is 12:27 PM.