LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 06-21-2009, 09:45 AM   #1
sadarax
Member
 
Registered: Sep 2005
Distribution: Ubuntu
Posts: 249

Rep: Reputation: 30
(SOLVED) Using Gimp with Cintiq pen-tool AND mouse at same time


I am running Jaunty 9.04 with KDE 4.2.4, using Gimp 2.6.6. I have successfully setup my Cintiq 12WX in Gimp. My problem is that I cannot use the Cintiq input at the same time as using the regular mouse. Either I can use the pen-tool and pad, or I can use my mouse to click and scroll, but not both at the same time in the Gimp drawing area.

EDIT: It appears that one has to click the gimp toolbox first which re-enables the mouse as a cursor. Once this is done, unless you use the pen-tool again, which will take over cursor control, you can use the mouse like normal. Note I disabled the Wacom Cintiq 12WX pad input.

My setup:

1) Plugin tablet
2) Open Nvidia-settings
3) Disable main monitor and enable Wacom tablet as the only monitor (this is an ugly work around for what I believe is a long standing X-Windows bug).
4) Save settings to Xorg.conf
5) Restart KDM
6) Open Gimp. (All the input options are default so far).
7) Edit -> Preferences -> Input Devices -> Configure Extended Input Devices
8) Set the four options from "Disabled" to "Screen"
  • Wacom Cintiq 12WX
  • Wacom Cintiq 12WX pad
  • Wacom Cintiq 12WX cursor
  • Wacom Cintiq 12WX eraser
I leave the rest of the options default.
9) Click Save and then close.
10) The pen-tool works but now the mouse does not. I cannot click or scroll in the Gimp window drawing area. If I use the mouse outside the drawing area, like in the Zoom % area, it works though.

Does anyone know how to enable the Cintiq pen-tool and mouse to work at the same time in Gimp 2.6.6?

My /etc/X11/xorg.conf (generated by my system, with no manual configuration on my part):

Code:
# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings:  version 1.0  (buildd@crested)  Sun Feb  1 20:25:37 UTC 2009

# xorg.conf (X.Org X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# Note that some configuration settings that could be done previously
# in this file, now are automatically configured by the server and settings
# here are ignored.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
#   sudo dpkg-reconfigure -phigh xserver-xorg

Section "ServerLayout"
    Identifier     "Default Layout"
    Screen      0  "Screen0" 0 0
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
EndSection

Section "Module"
    Load           "glx"
EndSection

Section "ServerFlags"

# Removed Option "Xinerama" "0"
# Removed Option "Xinerama" "1"
    Option         "DontZap" "False"
    Option         "Xinerama" "0"
EndSection

Section "InputDevice"

    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"
EndSection

Section "InputDevice"

    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "Monitor"
    Identifier     "Configured Monitor"
EndSection

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "WAC Cintiq 12WX"
    HorizSync       31.0 - 82.0
    VertRefresh     56.0 - 75.0
EndSection

Section "Monitor"
    Identifier     "Monitor1"
    VendorName     "Unknown"
    ModelName      "WAC Cintiq 12WX"
    HorizSync       31.0 - 82.0
    VertRefresh     56.0 - 75.0
EndSection

Section "Device"
    Identifier     "Configured Video Device"
    Driver         "nvidia"
    Option         "NoLogo" "True"
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "GeForce 9400 GT"
EndSection

Section "Device"
    Identifier     "Device1"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "GeForce 9400 GT"
    BusID          "PCI:5:0:0"
    Screen          1
EndSection

Section "Screen"
    Identifier     "Default Screen"
    Device         "Configured Video Device"
    Monitor        "Configured Monitor"
    DefaultDepth    24
EndSection

Section "Screen"
# Removed Option "metamodes" "DFP: nvidia-auto-select +0+0"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "TwinView" "0"
    Option         "metamodes" "CRT: nvidia-auto-select +0+0"
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection

Section "Screen"
    Identifier     "Screen1"
    Device         "Device1"
    Monitor        "Monitor1"
    DefaultDepth    24
    Option         "TwinView" "0"
    Option         "metamodes" "CRT: nvidia-auto-select +0+0"
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection

Last edited by sadarax; 06-24-2009 at 12:13 AM.
 
  


Reply

Tags
gimp, mouse, xorg


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Pressure control on gimp-2.4.7, slackware 12.1, G-Pen 450. ErV Linux - Software 1 08-22-2008 04:58 PM
Polygon tool in the gimp ? randyriver10 Linux - Software 3 01-21-2008 01:54 PM
Writing a new Gimp Tool Help sadarax Programming 1 09-17-2007 04:47 AM
Recommend Mouse-Pen for use with GIMP tarheel92x Linux - Hardware 3 08-23-2006 07:58 AM
GIMP tool question KungFuHamster Linux - Software 3 10-21-2003 06:05 PM


All times are GMT -5. The time now is 04:29 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration