LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 06-13-2006, 03:57 PM   #1
dinolinux
Member
 
Registered: Jun 2005
Location: Oslo, Norway
Distribution: Slackware 11, Solaris 10, Solaris 9, Sourcemage 0.9.6
Posts: 322

Rep: Reputation: 31
usb won't work with udev


Hi

I'm running linux 2.6.16 with udev on sourcemage and I can't mount my USB stick or use my USB mouse properly. When I plug in my USB stick and try to mount it, I get an error saying I don't have /dev/sda1. dmesg shows the USB stick, but nothing more. Udevmonitor also sees the stick, but doesn't create a /dev/sd* entry for it. If I let the system boot with the USB stick, it mounts without problems. I tried recompiling udev, the kernel, hotplug, restarting hotplug and udev, tried mounting on other distros (it works) and tried connecting on another port. I'm really out of ideas now
 
Old 06-13-2006, 06:45 PM   #2
bosewicht
Senior Member
 
Registered: Aug 2003
Location: Honolulu, HI
Distribution: Arch
Posts: 1,380

Rep: Reputation: 47
what does dmesg | tail give you after you plug in the usb stick?
 
Old 06-14-2006, 12:33 AM   #3
dinolinux
Member
 
Registered: Jun 2005
Location: Oslo, Norway
Distribution: Slackware 11, Solaris 10, Solaris 9, Sourcemage 0.9.6
Posts: 322

Original Poster
Rep: Reputation: 31
Code:
uhci_hcd 0000:00:1f.2: port 1 portsc 0093,00
hub 1-0:1.0: port 1, status 0101, change 0001, 12 Mb/s
hub 1-0:1.0: debounce: port 1: total 100ms stable 100ms status 0x101
usb 1-1: new full speed USB device using uhci_hcd and address 7
usb 1-1: default language 0x0409
usb 1-1: new device strings: Mfr=0, Product=2, SerialNumber=3
usb 1-1: Product: USB Flash Memory
usb 1-1: SerialNumber: 0C806B51100128CF
usb 1-1: uevent
usb 1-1: device is bus-powered
usb 1-1: configuration #1 chosen from 1 choice
usb 1-1: adding 1-1:1.0 (config #1, interface 0)
usb 1-1:1.0: uevent
ub 1-1:1.0: usb_probe_interface
ub 1-1:1.0: usb_probe_interface - got id
midi 1-1:1.0: usb_probe_interface
midi 1-1:1.0: usb_probe_interface - got id
midi: probe of 1-1:1.0 failed with error -5
drivers/usb/core/inode.c: creating file '007'
hub 1-0:1.0: state 7 ports 2 chg 0000 evt 0002
Sometimes it gives me nothing.
 
Old 06-14-2006, 01:50 AM   #4
Samotnik
Member
 
Registered: Jun 2006
Location: Belarus
Distribution: Debian GNU/Linux testing/unstable
Posts: 471

Rep: Reputation: 40
Give the syslog output, when you plug usb stick in.
 
Old 06-14-2006, 10:21 AM   #5
osor
HCL Maintainer
 
Registered: Jan 2006
Distribution: (H)LFS, Gentoo
Posts: 2,450

Rep: Reputation: 70
What are your udev rules associated with usb?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
udev rules all_partitions doesn't work arubin Slackware 1 06-10-2006 05:46 PM
Making UDEV Work dannyl Slackware 42 01-29-2006 12:20 AM
Udev usb issues exvor Linux - Software 1 06-25-2005 10:27 AM
udev and usb mouse ajvbun Fedora 1 11-30-2004 01:07 AM
udev, USB Flash Drives, and usb-mount talkingwires Debian 13 11-07-2004 12:15 PM


All times are GMT -5. The time now is 02:16 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration