LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 09-05-2004, 06:57 PM   #1
vexer
Member
 
Registered: Jan 2003
Location: Sudbury Ontario, Canada
Distribution: Slackware
Posts: 388

Rep: Reputation: 30
USB Mass storage.


I'm having difficulty with the usb mass storage devices. I have a usb digital still camera. I plugged it into my USB drive, turned it on and tried to make my way to /dev/scsi/hostX/... to get to the place where I mount or view the pictures. Problem is, the device is called generic and doesn't mount. I don't have an /dev/sda either.

Dmesg
Code:
scsi3 : SCSI emulation for USB Mass Storage devices
  Vendor: FUJIFILM  Model: USB-DRIVEUNIT     Rev: 1.00
  Type:   Direct-Access                      ANSI SCSI revision: 02
USB Mass Storage device found at 8
Does anyone know where I need to go to mount it?

I have as modules, scsi generic/disk/cdrom support. (Although cdrom has nothing to do with it, I figured I might as well mention it :P).


Any ideas on where to go/what to do to fix it?
 
Old 09-05-2004, 07:15 PM   #2
Tinkster
Moderator
 
Registered: Apr 2002
Location: in a fallen world
Distribution: slackware by choice, others too :} ... android.
Posts: 22,978
Blog Entries: 11

Rep: Reputation: 879Reputation: 879Reputation: 879Reputation: 879Reputation: 879Reputation: 879Reputation: 879
It's always a first try to check
/proc/scsi/scsi
and run
fdisk -l



Cheers,
Tink
 
Old 09-05-2004, 09:00 PM   #3
khellendros
LQ Newbie
 
Registered: Sep 2004
Posts: 5

Rep: Reputation: 0
Same sorta thing for me. I have a USB flash drive, as well as a USB camera. I've had both working in Linux, then killed the install, and ended up reloading from scratch. My custom configged kernel (2.6.5) has some option wrong, so I can't get to my files.

My fault, but any ideas about what I did wrong would be awesome!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
USB Mass Storage Daniboy Linux - Software 10 09-12-2005 08:30 AM
USB mass storage Roy-Svork Linux - Hardware 9 09-24-2003 04:34 PM
USB Mass Storage Zebee Linux - Hardware 2 08-03-2003 08:17 PM
usb mass storage Erwan Linux - Hardware 6 07-08-2003 05:39 PM
usb mass storage mohapi Linux - Hardware 3 06-03-2003 12:44 AM


All times are GMT -5. The time now is 03:41 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration