LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 09-18-2003, 06:03 PM   #1
bkeating
Member
 
Registered: Mar 2002
Location: San Francisco, CA
Distribution: Open/FreeBSD, Gentoo, SuSE
Posts: 511

Rep: Reputation: 38
USB Hotplug (card reader) wont show up


I do dmesg and get this; (bold areas = USB related)

Code:
Linux version 2.4.20-gentoo-r6 (root@blue) (gcc version 3.2.3 20030422 (Gentoo Linux 1.4 3.2.3-r1, propolice)) #9 Thu Sep 11 17:16:37 CDT 2003
BIOS-provided physical RAM map:
 BIOS-e820: 0000000000000000 - 000000000009fc00 (usable)
 BIOS-e820: 000000000009fc00 - 00000000000a0000 (reserved)
 BIOS-e820: 00000000000f0000 - 0000000000100000 (reserved)
 BIOS-e820: 0000000000100000 - 000000001dff0000 (usable)
 BIOS-e820: 000000001dff0000 - 000000001dff3000 (ACPI NVS)
 BIOS-e820: 000000001dff3000 - 000000001e000000 (ACPI data)
 BIOS-e820: 00000000fec00000 - 00000000fec01000 (reserved)
 BIOS-e820: 00000000fee00000 - 00000000fee01000 (reserved)
 BIOS-e820: 00000000ffff0000 - 0000000100000000 (reserved)
479MB LOWMEM available.
ACPI: have wakeup address 0xc0001000
On node 0 totalpages: 122864
zone(0): 4096 pages.
zone(1): 118768 pages.
zone(2): 0 pages.
ACPI: RSDP (v000 AWARD                      ) @ 0x000f6fc0
ACPI: RSDT (v001 AWARD  AWRDACPI 16944.11825) @ 0x1dff3000
ACPI: FADT (v001 AWARD  AWRDACPI 16944.11825) @ 0x1dff3040
ACPI: MADT (v001 AWARD  AWRDACPI 16944.11825) @ 0x1dff6740
ACPI: DSDT (v001 AWARD  AWRDACPI 00000.04096) @ 0x00000000
ACPI: BIOS passes blacklist
Kernel command line: root=/dev/hda3 hdc=ide-scsi noapic
ide_setup: hdc=ide-scsi
Initializing CPU#0
Detected 1998.279 MHz processor.
Console: colour VGA+ 80x25
Calibrating delay loop... 3984.58 BogoMIPS
Memory: 479944k/491456k available (1756k kernel code, 8948k reserved, -2028k data, 96k init, 0k highmem)
Dentry cache hash table entries: 65536 (order: 7, 524288 bytes)
Inode cache hash table entries: 32768 (order: 6, 262144 bytes)
Mount-cache hash table entries: 8192 (order: 4, 65536 bytes)
Buffer-cache hash table entries: 32768 (order: 5, 131072 bytes)
Page-cache hash table entries: 131072 (order: 7, 524288 bytes)
CPU: L1 I cache: 0K, L1 D cache: 8K
CPU: L2 cache: 512K
Intel machine check architecture supported.
Intel machine check reporting enabled on CPU#0.
CPU:     After generic, caps: 3febfbff 00000000 00000000 00000000
CPU:             Common caps: 3febfbff 00000000 00000000 00000000
CPU: Intel(R) Pentium(R) 4 CPU 2.00GHz stepping 04
Enabling fast FPU save and restore... done.
Enabling unmasked SIMD FPU exception support... done.
Checking 'hlt' instruction... OK.
POSIX conformance testing by UNIFIX
ACPI: Subsystem revision 20021122
PCI: PCI BIOS revision 2.10 entry at 0xfb530, last bus=1
PCI: Using configuration type 1
    ACPI-0511: *** Info: GPE Block0 defined as GPE0 to GPE15
    ACPI-0511: *** Info: GPE Block1 defined as GPE16 to GPE31
ACPI: Interpreter enabled
ACPI: Using PIC for interrupt routing
ACPI: System [ACPI] (supports S0 S1 S4 S5)
ACPI: PCI Root Bridge [PCI0] (00:00)
PCI: Probing PCI hardware (bus 00)
ACPI: PCI Interrupt Routing Table [\_SB_.PCI0._PRT]
ACPI: PCI Interrupt Link [LNKA] (IRQs 3 4 5 6 7 9 10 *11 12 14 15)
ACPI: PCI Interrupt Link [LNKB] (IRQs 3 4 *5 6 7 9 10 11 12 14 15)
ACPI: PCI Interrupt Link [LNKC] (IRQs 3 4 5 6 7 9 *10 11 12 14 15)
ACPI: PCI Interrupt Link [LNKD] (IRQs 3 4 5 6 7 *9 10 11 12 14 15)
ACPI: PCI Interrupt Link [LNKE] (IRQs 3 4 5 6 7 *9 10 11 12 14 15)
ACPI: PCI Interrupt Link [LNKF] (IRQs 3 4 *5 6 7 9 10 11 12 14 15)
ACPI: PCI Interrupt Link [LNKG] (IRQs 3 4 5 6 7 9 *10 11 12 14 15)
ACPI: PCI Interrupt Link [LNKH] (IRQs 3 4 5 6 7 9 10 *11 12 14 15)
PCI: Probing PCI hardware
PCI: Using ACPI for IRQ routing
PCI: if you experience problems, try using option 'pci=noacpi' or even 'acpi=off'
Linux NET4.0 for Linux 2.4
Based upon Swansea University Computer Society NET3.039
Initializing RT netlink socket
Starting kswapd
Journalled Block Device driver loaded
devfs: v1.12c (20020818) Richard Gooch (rgooch@atnf.csiro.au)
devfs: boot_options: 0x1
Installing knfsd (copyright (C) 1996 okir@monad.swb.de).
i2c-core.o: i2c core module version 2.7.0 (20021208)
i2c-dev.o: i2c /dev entries driver module version 2.7.0 (20021208)
i2c-algo-bit.o: i2c bit algorithm module version 2.7.0 (20021208)
pty: 256 Unix98 ptys configured
Serial driver version 5.05c (2001-07-08) with MANY_PORTS SHARE_IRQ SERIAL_PCI enabled
ttyS00 at 0x03f8 (irq = 4) is a 16550A
ttyS01 at 0x02f8 (irq = 3) is a 16550A
Uniform Multi-Platform E-IDE driver Revision: 6.31
ide: Assuming 33MHz system bus speed for PIO modes; override with idebus=xx
SIS5513: IDE controller on PCI bus 00 dev 15
SIS5513: detected chipset, but driver not compiled in!
SIS5513: chipset revision 0
SIS5513: not 100% native mode: will probe irqs later
    ide0: BM-DMA at 0x4000-0x4007, BIOS settings: hda:DMA, hdb:pio
    ide1: BM-DMA at 0x4008-0x400f, BIOS settings: hdc:DMA, hdd:pio
hda: ST380021A, ATA DISK drive
hdc: LITE-ON LTR-48125W, ATAPI CD/DVD-ROM drive
ide0 at 0x1f0-0x1f7,0x3f6 on irq 14
ide1 at 0x170-0x177,0x376 on irq 15
hda: 156301488 sectors (80026 MB) w/2048KiB Cache, CHS=9729/255/63
Partition check:
 /dev/ide/host0/bus0/target0/lun0: p1 p2 p3
Linux agpgart interface v0.99 (c) Jeff Hartmann
agpgart: Maximum main memory to use for agp memory: 409M
agpgart: Unsupported SiS chipset (device id: 0651), you might want to try agp_try_unsupported=1.
agpgart: no supported devices found.
SCSI subsystem driver Revision: 1.00
kmod: failed to exec /sbin/modprobe -s -k scsi_hostadapter, errno = 2
usb.c: registered new driver hub
hcd.c: ehci-hcd @ 00:03.3, Silicon Integrated Systems [SiS] SiS7002 USB 2.0
hcd.c: irq 11, pci mem de809000
usb.c: new USB bus registered, assigned bus number 1
hcd/ehci-hcd.c: USB 2.0 support enabled, EHCI rev 1. 0
hub.c: USB hub found
hub.c: 6 ports detected
uhci.c: USB Universal Host Controller Interface driver v1.1
usb.c: registered new driver hid
hid-core.c: v1.8.1 Andreas Gal, Vojtech Pavlik <vojtech@suse.cz>
hid-core.c: USB HID support drivers
Initializing USB Mass Storage driver...
usb.c: registered new driver usb-storage
USB Mass Storage support registered.
i2c-core.o: i2c core module version 2.7.0 (20021208)
i2c-dev.o: i2c /dev entries driver module version 2.7.0 (20021208)
devfs_mk_dir(i2c): using old entry in dir: c22b7680 ""
NET4: Linux TCP/IP 1.0 for NET4.0
IP Protocols: ICMP, UDP, TCP, IGMP
IP: routing cache hash table of 4096 buckets, 32Kbytes
TCP: Hash tables configured (established 32768 bind 65536)
NET4: Unix domain sockets 1.0/SMP for Linux NET4.0.
reiserfs: checking transaction log (device 03:03) ...
Using r5 hash to sort names
ReiserFS version 3.6.25
VFS: Mounted root (reiserfs filesystem) readonly.
Mounted devfs on /dev
Freeing unused kernel memory: 96k freed
Adding Swap: 996020k swap-space (priority -1)
8139too Fast Ethernet driver 0.9.26
eth0: RealTek RTL8139 Fast Ethernet at 0xde93e000, 00:30:1b:ab:4a:7c, IRQ 10
eth0:  Identified 8139 chip type 'RTL-8139C'
scsi0 : SCSI host adapter emulation for IDE ATAPI devices
  Vendor: LITE-ON   Model: LTR-48125W        Rev: VS06
  Type:   CD-ROM                             ANSI SCSI revision: 02
ohci1394: $Rev: 578 $ Ben Collins <bcollins@debian.org>
ohci1394_0: OHCI-1394 1.0 (PCI): IRQ=[9]  MMIO=[e0107000-e01077ff]  Max Packet=[2048]
udf: registering filesystem
Attached scsi CD-ROM sr0 at scsi0, channel 0, id 0, lun 0
sr0: scsi3-mmc drive: 48x/48x writer cd/rw xa/form2 cdda tray
sr0: mmc-3 profile capable, current profile: 9h
Uniform CD-ROM driver Revision: 3.12
ieee1394: Host added: Node[00:1023]  GUID[00301bab00004ae0]  [Linux OHCI-1394]
eth0: Setting 100mbps full-duplex based on auto-negotiated partner ability 45e1.
Real Time Clock Driver v1.10e
intel8x0: clocking to 48000
Linux video capture interface: v1.00
bttv: driver version 0.7.106 loaded
bttv: using 4 buffers with 2080k (8320k total) for capture
bttv: Host bridge is Silicon Integrated Systems [SiS] SiS651 Host
bttv: Bt8xx card found (0).
bttv0: Bt878 (rev 2) at 00:0a.0, irq: 5, latency: 32, mmio: 0xe0104000
bttv0: detected: Hauppauge WinTV [card=10], PCI subsystem ID is 0070:13eb
bttv0: using: BT878(Hauppauge (bt878)) [card=10,autodetected]
bttv0: Hauppauge/Voodoo msp34xx: reset line init [5]
i2c-dev.o: Registered 'bt848 #0' as minor 0
bttv0: Hauppauge eeprom: model=62471, tuner=Philips FM1236 (2), radio=yes
bttv0: using tuner=2
bttv0: i2c: checking for MSP34xx @ 0x80... not found
bttv0: i2c: checking for TDA9875 @ 0xb0... not found
bttv0: i2c: checking for TDA7432 @ 0x8a... not found
tvaudio: TV audio decoder + audio/video mux driver
tvaudio: known chips: tda9840,tda9873h,tda9874h/a,tda9850,tda9855,tea6300,tea6420,tda8425,pic16c54 (PV951),ta8874z
tvaudio: found tda9850 @ 0xb6
tuner: probing bt848 #0 i2c adapter [id=0x10005]
tuner: chip found @ 0xc2
tuner: type set to 2 (Philips NTSC (FI1236,FM1236 and compatibles))
bttv0: PLL: 28636363 => 35468950 .. ok
bttv0: registered device video0
bttv0: registered device vbi0
bttv0: registered device radio0

I start hotplug

Code:
sudo /etc/init.d/hotplug start
and then plug in my card reader (with and without the CF card in it already) and dmesg reports nothing new at the end of the output...

any ideas?
 
Old 09-18-2003, 07:56 PM   #2
Thymox
Senior Member
 
Registered: Apr 2001
Location: Plymouth, England.
Distribution: Debian + Ubuntu
Posts: 4,358

Rep: Reputation: 57
Is it one of those 'multi' card readers? If so, then you may need to enable multiple-LUN support in your kernel.

My reader reads the CF bay as the first lun, so it works without fiddleology, but if I want any of the others, then I need to fiddle with the kernel.

Just a thought.
 
Old 09-19-2003, 12:37 PM   #3
bkeating
Member
 
Registered: Mar 2002
Location: San Francisco, CA
Distribution: Open/FreeBSD, Gentoo, SuSE
Posts: 511

Original Poster
Rep: Reputation: 38
Thanks for the tip but shouldn't hotplug atleast report that the device has been plugged in?...

Also; on a basic window98 machine, the CF card slot (of the total 4 slots on the reader) show... so I believe i have the same situation as you; the CF is default.

i try to run usbview to see whats going on and a msgbox comes up;

Quote:
Can not open the file /proc/bus/usb/devices
this may be a important clue, im just not sure how to aply a fix.

Last edited by bkeating; 09-19-2003 at 12:40 PM.
 
Old 09-19-2003, 12:48 PM   #4
Thymox
Senior Member
 
Registered: Apr 2001
Location: Plymouth, England.
Distribution: Debian + Ubuntu
Posts: 4,358

Rep: Reputation: 57
Re: USB Hotplug (card reader) wont show up

Severly edited quote from above:
Code:
usb.c: registered new driver hub
hcd.c: ehci-hcd @ 00:03.3, Silicon Integrated Systems [SiS] SiS7002 USB 2.0
hcd.c: irq 11, pci mem de809000
usb.c: new USB bus registered, assigned bus number 1
hcd/ehci-hcd.c: USB 2.0 support enabled, EHCI rev 1. 0
hub.c: USB hub found
hub.c: 6 ports detected
uhci.c: USB Universal Host Controller Interface driver v1.1
usb.c: registered new driver hid
hid-core.c: v1.8.1 Andreas Gal, Vojtech Pavlik <vojtech@suse.cz>
hid-core.c: USB HID support drivers
Initializing USB Mass Storage driver...
usb.c: registered new driver usb-storage
USB Mass Storage support registered.
It says that the mass storage support is loaded - can you not check to see if any 'new' scsi harddrives have been created in the /dev directory? Also, type cdrecord -scanbus to see if it is registered. If it is, then you can use fdisk -l (that's a little L) to find out which device it is.

Oh, and I'm presuming you're using devfs.
 
Old 09-19-2003, 08:12 PM   #5
bkeating
Member
 
Registered: Mar 2002
Location: San Francisco, CA
Distribution: Open/FreeBSD, Gentoo, SuSE
Posts: 511

Original Poster
Rep: Reputation: 38
Code:
bkeating@blue bkeating $ sudo cdrecord -scanbus
Cdrecord 2.01a14 (i686-pc-linux-gnu) Copyright (C) 1995-2003 J?rg Schilling
Linux sg driver version: 3.1.24
Using libscg version 'schily-0.7'
scsibus0:
        0,0,0     0) 'LITE-ON ' 'LTR-48125W      ' 'VS06' Removable CD-ROM
        0,1,0     1) *
        0,2,0     2) *
        0,3,0     3) *
        0,4,0     4) *
        0,5,0     5) *
        0,6,0     6) *
        0,7,0     7) *
Im using Gentoo now but under RH8/9 a;

Code:
# mount /dev/sda1 /mnt/camera
always did the trick... Seems all is in the right place except for the actual USB daemon (if there is such a thing)
 
Old 09-19-2003, 10:56 PM   #6
bkeating
Member
 
Registered: Mar 2002
Location: San Francisco, CA
Distribution: Open/FreeBSD, Gentoo, SuSE
Posts: 511

Original Poster
Rep: Reputation: 38
OK - I recompiled the kernel and now when I run usbview it doesn't give me an error but it actually shows me my mobo's SiS USB 'chipset' er whatever you'd call it but.... So im assuming that things are working properly they just don't know what to apply themselves too

when I try to get a list od sdaX devices in dev... none exist. Any ideas?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Ndiswrapper ok but Yast wont show card... miamitj SUSE / openSUSE 2 09-06-2005 03:12 AM
USB jumpdrive/ USB hud-card reader issues o0gnubee0o Linux - Hardware 4 07-03-2005 07:12 PM
USB multi-card reader; only one card can be mounted in Slack 10. KidsWriter71 Linux - Hardware 6 09-11-2004 08:24 PM
Mepis: Sandisk Usb Sd Reader and hotplug problems pippos Linux - Hardware 0 04-06-2004 05:31 PM
USB Compact flash card reader hotplug creates /dev/sda but no /dev/sda1 -Mandrake 9.1 bibinono Linux - Hardware 2 08-11-2003 10:37 AM


All times are GMT -5. The time now is 12:39 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration