LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 08-23-2010, 10:38 AM   #1
CMaan
LQ Newbie
 
Registered: Aug 2010
Posts: 4

Rep: Reputation: 0
upload_max_filesize won't change from default? please help


Hallo guys..
This is my first post on this forum, but its also the first problem I never had have with php in linux.

I have searched the net, but have not found a solution to the problem.

The problem is that "upload_max_filesize" wont change when I change the the default 2M to 10M in the php.ini and restart apache.

I have also tried make it change with a .htaccess file.
I have tried to search for all my php.ini files with
Code:
find / -name *php.ini
I get
Code:
/etc/php5/cli/php.ini
/etc/php5/apache2/php.ini
/etc/php5/cgi/php.ini
My system is :Linux Debian-50-lenny-64-minimal 2.6.26-2-amd64
And I have installed a LAMP with the newest packages.
My next idea was to use a different version of php.

But hope someone know the issue an can help me out here.. I am getting
thanks
 
Old 08-23-2010, 10:49 AM   #2
quanta
Member
 
Registered: Aug 2007
Location: Vietnam
Distribution: RedHat based, Debian based, Slackware, Gentoo
Posts: 724

Rep: Reputation: 100Reputation: 100
Make sure you have edited the right php.ini file which Apache is using. You can create a info.php file to check that.
 
Old 08-23-2010, 01:02 PM   #3
CMaan
LQ Newbie
 
Registered: Aug 2010
Posts: 4

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by quanta View Post
Make sure you have edited the right php.ini file which Apache is using. You can create a info.php file to check that.
That I did...
 
Old 08-23-2010, 06:08 PM   #4
CMaan
LQ Newbie
 
Registered: Aug 2010
Posts: 4

Original Poster
Rep: Reputation: 0
It works now... used a PHPINIDir an moved my php.ini file to /www/ now it works ... I think it was not reading the php.ini file..
 
Old 08-23-2010, 06:09 PM   #5
CMaan
LQ Newbie
 
Registered: Aug 2010
Posts: 4

Original Poster
Rep: Reputation: 0
It works now... used a PHPINIDir an moved my php.ini file to /www/ now it works ... I think it was not reading the php.ini file..

please make this thread solved
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
What config file do you change to change default run level McPriMa Linux - Newbie 2 08-05-2009 04:45 PM
php.ini "upload_max_filesize 2meg" error on large pixel images under 1meg DT (D_Turmined) Linux - Newbie 4 03-25-2009 07:46 AM
change grub boot order, all instructions say change default, but I don't see default mhg Linux - Newbie 5 11-09-2008 10:01 AM
php_value upload_max_filesize 10M tooparam Linux - Newbie 1 02-13-2007 07:12 PM
problem with upload_max_filesize directive tooparam Linux - Software 0 01-16-2006 06:43 AM


All times are GMT -5. The time now is 11:15 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration