LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 02-17-2003, 02:55 PM   #1
zurron
LQ Newbie
 
Registered: Feb 2003
Location: Pereira
Distribution: slackware
Posts: 22

Rep: Reputation: 15
upgrading php


I am trying to upgrade PHP 4.2.2 to 4.3

and when i run ./configure


loading cache ./config.cache
checking for Cygwin environment... no
checking for mingw32 environment... no
checking for working sed... sed
checking host system type... i586-pc-linux-gnuoldld
checking for gcc... gcc
checking whether the C compiler (gcc ) works... no
configure: error: installation or configuration problem: C compiler cannot create executables.

so please if someone knows exacly what do i need for fix it?
I can tell you this:

Red hat 8.0

[root@crvenkapa php-4.3.0]# gcc -v
Reading specs from /usr/lib/gcc-lib/i386-redhat-linux/3.2/specs
Configured with: ../configure --prefix=/usr --mandir=/usr/share/man --infodir=/usr/share/info --enable-shared --enable-threads=posix --disable-checking --host=i386-redhat-linux --with-system-zlib --enable-__cxa_atexit
Thread model: posix
gcc version 3.2 20020903 (Red Hat Linux 8.0 3.2-7)
 
Old 02-17-2003, 03:33 PM   #2
LoRd~NiKoN
LQ Newbie
 
Registered: Feb 2003
Location: Toronto
Distribution: Slack 8.1, RH8.0
Posts: 8

Rep: Reputation: 0
1> ok 1st thing to recognize is that your GCC compiler is not werking properly... [based on the info above]...

2> you must first upgrade or download a new version of gcc, or find a different compiler on the net somewhere... my suggestion is [since you are using rh8] www.rpmfind.net it is simple to use and has a good database ...

3> after you have a gcc complier you must configure it with apache [assuming you are going to be setting up a server that has PHP capabilities...]

like this:

./configure --with-apache --prefix=where you want to put php dir


4>then make, and make install

5> All there is to do now is to edit the httpd.conf file to load your modules...
 
Old 02-18-2003, 07:18 AM   #3
zurron
LQ Newbie
 
Registered: Feb 2003
Location: Pereira
Distribution: slackware
Posts: 22

Original Poster
Rep: Reputation: 15
how do you know that C compiler isn't working properly?

I have the last version for Red Hat 8.0, I downloaded it from www.rpmfind.net, I upgraded it already. and still does not work
 
Old 02-18-2003, 07:35 AM   #4
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,414

Rep: Reputation: 1967Reputation: 1967Reputation: 1967Reputation: 1967Reputation: 1967Reputation: 1967Reputation: 1967Reputation: 1967Reputation: 1967Reputation: 1967Reputation: 1967
i'm not all that sure, but i would guess that it'd possibly be a case of not having the glibc headers installed. if they'e not there no programs can be compiled afaik.
 
Old 02-18-2003, 07:43 AM   #5
zurron
LQ Newbie
 
Registered: Feb 2003
Location: Pereira
Distribution: slackware
Posts: 22

Original Poster
Rep: Reputation: 15
and how can I see if the I have the glibc headers installed?
 
Old 02-18-2003, 07:49 AM   #6
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,414

Rep: Reputation: 1967Reputation: 1967Reputation: 1967Reputation: 1967Reputation: 1967Reputation: 1967Reputation: 1967Reputation: 1967Reputation: 1967Reputation: 1967Reputation: 1967
rpm -qa | grep glibc-devel

should do it
 
Old 02-18-2003, 08:31 AM   #7
zurron
LQ Newbie
 
Registered: Feb 2003
Location: Pereira
Distribution: slackware
Posts: 22

Original Poster
Rep: Reputation: 15
yes, it is
glibc-devel-2.2.93-5

Last edited by zurron; 02-18-2003 at 08:34 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Upgrading PHP with RH 9 rtcary Linux - General 1 09-11-2005 12:27 PM
Upgrading php? rickycen Linux - Newbie 4 09-02-2005 09:24 PM
Upgrading PHP?!? gldfngr Linux - Software 1 08-25-2005 10:32 AM
Upgrading Php dlc2000 Linux - Newbie 0 07-16-2003 08:46 AM
Upgrading php 4.2.2 to 4.3.2 maceking Linux - Software 1 06-30-2003 03:02 PM


All times are GMT -5. The time now is 07:22 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration