LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 05-16-2005, 09:08 PM   #1
HellFace
LQ Newbie
 
Registered: May 2005
Posts: 5

Rep: Reputation: 0
Upgrading Firefox in Ubuntu


I am new to Linux and just installed Ubuntu. I tried adding some of my favorite Firefox extensions, but it told me to upgrade to the newest version of Firefox. I downloaded the tarball and extracted it. When I sh firefox-installer I got:
(firefox-installer-bin:27915): Gdk-WARNING **: locale not supported by Xlib

(firefox-installer-bin:27915): Gdk-WARNING **: can not set locale modifiers

(firefox-installer-bin:27915): Gdk-WARNING **: Error converting from UTF-8 to STRING: Conversion from character set 'UTF-8' to 'ISO-8859-1' is not supported

(firefox-installer-bin:27915): Gdk-WARNING **: Error converting from UTF-8 to STRING: Conversion from character set 'UTF-8' to 'ISO-8859-1' is not supported

(firefox-installer-bin:27915): Gtk-WARNING **: /usr/lib/gtk-2.0/2.4.0/engines/libclearlooks.so: cannot open shared object file: No such file or directory

** (firefox-installer-bin:27915): WARNING **: /usr/lib/pango/1.4.0/modules/pango-basic-fc.so: cannot open shared object file: No such file or directory
Failed to load Pango module for id: 'BasicScriptEngineFc'
** (firefox-installer-bin:27915): WARNING **: /usr/lib/pango/1.4.0/modules/pango-basic-fc.so: cannot open shared object file: No such file or directory
Failed to load Pango module for id: 'BasicScriptEngineFc'
** (firefox-installer-bin:27915): WARNING **: /usr/lib/pango/1.4.0/modules/pango-basic-fc.so: cannot open shared object file: No such file or directory
Failed to load Pango module for id: 'BasicScriptEngineFc'
** (firefox-installer-bin:27915): WARNING **: /usr/lib/pango/1.4.0/modules/pango-basic-fc.so: cannot open shared object file: No such file or directory
Failed to load Pango module for id: 'BasicScriptEngineFc'
** (firefox-installer-bin:27915): WARNING **: /usr/lib/pango/1.4.0/modules/pango-basic-fc.so: cannot open shared object file: No such file or directory
Failed to load Pango module for id: 'BasicScriptEngineFc'
** (firefox-installer-bin:27915): WARNING **: /usr/lib/pango/1.4.0/modules/pango-basic-fc.so: cannot open shared object file: No such file or directory
Failed to load Pango module for id: 'BasicScriptEngineFc'
** (firefox-installer-bin:27915): WARNING **: /usr/lib/pango/1.4.0/modules/pango-basic-fc.so: cannot open shared object file: No such file or directory
Failed to load Pango module for id: 'BasicScriptEngineFc'
** (firefox-installer-bin:27915): WARNING **: /usr/lib/pango/1.4.0/modules/pango-basic-fc.so: cannot open shared object file: No such file or directory
Failed to load Pango module for id: 'BasicScriptEngineFc'
** (firefox-installer-bin:27915): WARNING **: /usr/lib/pango/1.4.0/modules/pango-basic-fc.so: cannot open shared object file: No such file or directory
Failed to load Pango module for id: 'BasicScriptEngineFc'
** (firefox-installer-bin:27915): WARNING **: /usr/lib/pango/1.4.0/modules/pango-basic-fc.so: cannot open shared object file: No such file or directory
Failed to load Pango module for id: 'BasicScriptEngineFc'
** (firefox-installer-bin:27915): WARNING **: /usr/lib/pango/1.4.0/modules/pango-basic-fc.so: cannot open shared object file: No such file or directory
Failed to load Pango module for id: 'BasicScriptEngineFc'
(firefox-installer-bin:27915): GLib-GObject-CRITICAL **: file gobject.c: line 1561 (g_object_ref): assertion `G_IS_OBJECT (object)' failed


** (firefox-installer-bin:27915): CRITICAL **: file pango-engine.c: line 68 (_pango_engine_shape_shape): assertion `PANGO_IS_FONT (font)' failed

** ERROR **: file shape.c: line 75 (pango_shape): assertion failed: (glyphs->num_glyphs > 0)
aborting...
firefox-installer: line 56: 27915 Aborted ./${BINNAME}-bin $@



Being relatively new I'm not sure what to do. I'm sorry if there have been similar questions asked, a search turned up nothing helpful for me, probably because I don't know the best words to search for.

Thanks for your help.
 
Old 05-16-2005, 09:30 PM   #2
funkydan2
Member
 
Registered: Mar 2004
Location: Brisbane, Australia
Distribution: VectorLinux; Ubuntu
Posts: 135

Rep: Reputation: 15
Are you running Woody or Hoary?

If you are running Hoary (or would like to upgrade)...

http://ubuntuguide.org/#extrarepositories

Check you /etc/apt-get/sources.list and make sure it looks like this then

sudo apt-get update && sudo apt-get upgrade

To get the most up-to-date packages.

If you're running Warty, you could add the warty backports repository to your sources.list. Search this forum or google for 'warty backports' to find out what to add to your sources.list. After you enable 'backports', then 'sudo apt-get update && sudo apt-get upgrade' should do the trick.

Daniel
 
Old 05-16-2005, 10:13 PM   #3
HellFace
LQ Newbie
 
Registered: May 2005
Posts: 5

Original Poster
Rep: Reputation: 0
Sorry, I guess I should have mentioned I was using Hoary.

I did what you said and it seemed to mostly work, but when I

apt-get upgrade

I get


E: Could not get lock /var/lib/dpkg/lock - open (11 Resource temporarily unavailable)
E: Unable to lock the administration directory (/var/lib/dpkg/), is another process using it?


Any ideas?

Thanks again.
 
Old 05-16-2005, 10:37 PM   #4
funkydan2
Member
 
Registered: Mar 2004
Location: Brisbane, Australia
Distribution: VectorLinux; Ubuntu
Posts: 135

Rep: Reputation: 15
The ideas would be that you had another program open that was using the dpkg tools - maybe synaptic?

Anyway, I just had a look at the Ubuntu packages and security updates (I'm not using Ubuntu at the moment), and it seems that the newest version of Firefox in the reps is 1.0.2.

If you need 1.0.4, have a look in the backports http://backports.ubuntuforums.org/. They look to have 1.0.4.

Daniel
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Upgrading Firefox the right way duffmckagan Ubuntu 39 12-22-2005 01:40 PM
Upgrading to kernel 2.6.9 on Ubuntu neutrin0 Ubuntu 1 10-15-2005 11:59 PM
Problems upgrading MySQL on Ubuntu, with Apache2/PHP4 peruvianllama Linux - Software 0 08-16-2005 09:27 AM
regarding upgrading ubuntu pranith Ubuntu 7 03-18-2005 08:10 AM
Problem upgrading Alsa with Ubuntu sebb Linux - Software 1 11-25-2004 06:24 AM


All times are GMT -5. The time now is 06:19 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration