LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 04-14-2008, 10:36 AM   #1
dale_chip
Member
 
Registered: Jun 2007
Location: India
Posts: 41

Rep: Reputation: 15
upgrade tomboy notes


i am using tomboy 0.3.5 on fc5.
i want it to upgrade it with latest 0.10.0.
while trying to build it from source code i got the following errors
while running ./configure

checking for GTKSPELL... no
checking for DBUS... configure: error: Package requirements (ndesk-dbus-1.0 >= 0.4 ndesk-dbus-glib-1.0 >= 0.3) were not met:

No package 'ndesk-dbus-1.0' found
No package 'ndesk-dbus-glib-1.0' found

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables DBUS_CFLAGS
and DBUS_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.


What should i do ?
 
Old 04-14-2008, 12:27 PM   #2
DavidMcCann
Senior Member
 
Registered: Jul 2006
Location: London
Distribution: CentOS, Salix
Posts: 2,958

Rep: Reputation: 768Reputation: 768Reputation: 768Reputation: 768Reputation: 768Reputation: 768Reputation: 768
Quick answer: upgrade your Fedora!

This is why Linux comes in distros. When you install programs from source, you are left with the job of ensuring that all their requirements are met. You are short of one file (GTKSPELL) and need two upgrading (ndesk-dbus, ndesk-dbus-lib).

Try updating your tomboy with

yum update tomboy

You might find the Fedora repository no longer copes with Fedora 5, but no harm can be done if that is the case.
 
Old 04-15-2008, 09:46 AM   #3
sandyarmstrong
LQ Newbie
 
Registered: Apr 2008
Posts: 2

Rep: Reputation: 1
I agree with DavidMcCann that you should upgrade your distro to get a better experience, but in this case you can drop Tomboy's dbus integration by running ./configure with the --disable-dbus flag. Make sure you use the correct --prefix when running ./configure, too. For most distros you would want to use --prefix=/usr to overwrite the system-installed Tomboy.

But please seriously consider upgrading your Fedora install. It is much easier and will save you a lot of time whenever you get an itch for new versions.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
recovering the notes of sticky notes dissident_goodchild Linux - Software 4 11-12-2007 06:17 PM
Any utility to write notes and search in notes? VicRic Linux - Newbie 2 08-29-2007 05:01 AM
Tomboy problem drawde83 Linux - Software 2 06-20-2007 05:24 PM
LXer: Take notes with Tomboy LXer Syndicated Linux News 0 08-18-2006 03:03 PM
tomboy only runs as root TuxLives Mandriva 0 06-01-2006 01:08 AM


All times are GMT -5. The time now is 06:54 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration