LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 09-14-2002, 02:51 PM   #1
whaase
Member
 
Registered: Aug 2002
Location: Calgary, Alberta, Canada
Distribution: Ubuntu Server, Ubuntu Desktop
Posts: 128

Rep: Reputation: 15
updating SSH


I wanted to update SSHd on my RH7.1. When I downloaded it and tried the following commands, this is what I got:

rpm -U openssh-3.1p1-6.i386.rpm

error: failed dependencies:
libcrypto.so.2 is needed by openssh-3.1p1-6
openssh = 2.5.2p2-5 is needed by openssh-askpass-2.5.2p2-5
openssh = 2.5.2p2-5 is needed by openssh-clients-2.5.2p2-5
openssh = 2.5.2p2-5 is needed by openssh-server-2.5.2p2-5



Then I tried this:

rpm -U openssh-server-3.1p1-6.i386.rpm

error: failed dependencies:
openssh = 3.1p1-6 is needed by openssh-server-3.1p1-6
libcrypto.so.2 is needed by openssh-server-3.1p1-6
libc.so.6(GLIBC_2.2.4) is needed by openssh-server-3.1p1-6


What am I doing wrong? What do I need to do?

Thanks, Walter
 
Old 09-14-2002, 03:20 PM   #2
Mara
Moderator
 
Registered: Feb 2002
Location: Grenoble
Distribution: Debian
Posts: 9,569

Rep: Reputation: 164Reputation: 164
There's a big version difference. Maybe try to compile it from source or find rpms de for RH7.1.
 
Old 09-16-2002, 11:53 AM   #3
stickman
Senior Member
 
Registered: Sep 2002
Location: Nashville, TN
Posts: 1,552

Rep: Reputation: 53
Looks like you need to get the latest versions of glibc and openssl.
 
Old 09-16-2002, 09:03 PM   #4
whaase
Member
 
Registered: Aug 2002
Location: Calgary, Alberta, Canada
Distribution: Ubuntu Server, Ubuntu Desktop
Posts: 128

Original Poster
Rep: Reputation: 15
I did one better. I upgraded to RH 7.3

Walter
 
Old 09-17-2002, 04:19 AM   #5
stickman
Senior Member
 
Registered: Sep 2002
Location: Nashville, TN
Posts: 1,552

Rep: Reputation: 53
Did you apply any patches? I notice that the default RH 7.3 includes OpenSSH 3.1p1 and OpenSSL 0.9.6b. Both of these are affected by recent vulnerabilities. I don't run RH so I didn't check to see if they had fixed versions available.
 
Old 09-17-2002, 10:06 PM   #6
whaase
Member
 
Registered: Aug 2002
Location: Calgary, Alberta, Canada
Distribution: Ubuntu Server, Ubuntu Desktop
Posts: 128

Original Poster
Rep: Reputation: 15
I'll check it out. Thanks.

Walter.
 
Old 09-18-2002, 02:15 PM   #7
markus1982
Senior Member
 
Registered: Aug 2002
Location: Stuttgart (Germany)
Distribution: Debian/GNU Linux
Posts: 1,467

Rep: Reputation: 46
just do a
Code:
 wget ftp://ftp.uni-stuttgart.de/pub/OpenB...rpm/RH73/*3.4*
rpm -Fvh openssh*3.4*.rpm
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
ssh-agent, ssh-add and ssh-keygen AND CVS raylpc Linux - General 2 11-19-2008 03:50 AM
[SSH] Issue logging in [SSH & Permissions] MD3 Linux - Networking 11 12-10-2006 10:25 AM
Mac OS X ssh client / linux sshd : ssh hangs/disconnects Apollo77 Linux - Networking 1 05-24-2006 12:53 PM
downloading and updating with ssh cb951303 Linux - Software 2 09-10-2005 08:51 AM
Q: FTP, Updating, SSH R153-Ab0V3 Linux - Newbie 2 02-23-2004 11:42 AM


All times are GMT -5. The time now is 06:45 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration