LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 01-15-2006, 07:22 PM   #1
kellinjar
Member
 
Registered: Mar 2004
Location: South Korea
Posts: 103

Rep: Reputation: 15
Updated to Gnome 2.12 broke login script


So I went about updating to Gnome 2.12 (which also included a kernel update from 53 to 56.

In the process my login script got broken.

not sure how, or what the problem is. It just tells me there is an invalid entry in the configuration file.

(a side note neither my wireless or built in NIC on the laptop would work after booting. I've since got the NIC back up and running).

Anyone know what this is referring to and how I can fix it? My linux knowledge is so-so, but I'm getting there.
 
Old 01-15-2006, 08:44 PM   #2
NomadX
Member
 
Registered: Jul 2005
Location: Portland, OR
Distribution: Debian Testing
Posts: 78

Rep: Reputation: 15
Quote:
Originally Posted by kellinjar
So I went about updating to Gnome 2.12 (which also included a kernel update from 53 to 56.

In the process my login script got broken.

not sure how, or what the problem is. It just tells me there is an invalid entry in the configuration file.

(a side note neither my wireless or built in NIC on the laptop would work after booting. I've since got the NIC back up and running).

Anyone know what this is referring to and how I can fix it? My linux knowledge is so-so, but I'm getting there.
If your sure it was the kernel update that killed your network access, and GNOME didnt say / do anything with your existing config, then the new kernel source doesnt have build in support and/or modules, for key devices.

You should try to find your orignal kernal image an use it. If gnome then complains you'll at least be able to see whats changed.

Drunk on my only day off If this didnt make any sense reply and I'll do better.

Heres some suggestions for a reply:

What script connects you on the internet? Using ifup? kppp? Send its config file (read all the files in your /etc/chat /etc/ppp /etc/ppp/peers/(ISP specific script or orig dummy script)

Your kernel .config file and a description of your system. If the generic kernel you installed didnt include support for something that your disto's default kernel did it could cause this problem. Dial up or network card?

....

Good luck,
Doc
 
Old 01-15-2006, 08:54 PM   #3
kellinjar
Member
 
Registered: Mar 2004
Location: South Korea
Posts: 103

Original Poster
Rep: Reputation: 15
well so far so good in getting stuff fixed.
All I did was choose a login screen and gnome stopped complaing.
I reinstalled my NIC drivers and all is good
currently fighting with my wireless intel ipw2200BG. it was working, now its being a pain. First it was the firmware, then the firmware was good, (after installing wireless tools) now it decided to crash because I had it working, and tried to connect to an old wireless connection (instead of remaking it) I'm going in again to see if I can convince it to work.

when I dmesg | grep ipw
I get now errors, however when I try to initialize the wireless connection I get:
./ifup-wireless: line 66: 3401 segmentation fault iwconfig $DEVICE key $KEY

any thoughts?

[edit] google has lead me to believe this is the WPA key causing a segmentation fault (though I know it supported WPA before). I haven't found a listed fix for my card specifically, that might help someone who knows what they're doing give me a solution

Last edited by kellinjar; 01-15-2006 at 09:26 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
login script fc3 gnome? boernd Linux - General 1 03-15-2005 05:04 PM
Updated KDE, cant login root aarond_04 Linux - Newbie 1 02-17-2005 07:43 PM
bash script to email updated ip ericnmu Linux - Networking 1 10-01-2004 10:30 PM
gnome broke :( but kde ok :) arpi Linux - Software 0 05-28-2004 08:48 PM
debian gnome broke sms043 Debian 2 05-22-2004 09:23 PM


All times are GMT -5. The time now is 03:29 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration