LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices



Reply
 
Search this Thread
Old 02-28-2004, 09:38 PM   #1
h00ligan
LQ Newbie
 
Registered: Jan 2004
Posts: 23

Rep: Reputation: 15
updated kde now can't start x


I ran rpm -Uvh --nodeps --force *.rpm as suggested in another thread with all the packages provided by suse..

It seemed to update.. things registerred as 3.2 BUT

When I restarted, in runlevel 5, it didn't boot to the gui login.. and when i logged in and ran startx I received an error stating, XIO : fatal IO error 104 (connection reset by peer) on X server ":0.0" after 0 requests (0 known processed) with 0 events remaining.

When I run startkde the following comes up.

xsetroot : unable to open display ''
xset: unable to open display ""
ksplash: cannot connect to xserver
kdeinit : Aborting. $DISPLAY is not set
Warning: connect() failed: : No such file or directory
Error: Can't contact kdeinit!
startkde: Running shutdown scripts
startkde one.

Any thought or do i have to reinstall.. the thought is when stuff like this breaks it's an opportuinity to learn.. so i would appreciate any insight.

Nearest I can figure, something is screwed with my display entry in the XFree86config file.. but it all looks ok to me.

Thanks for your help.
 
Old 02-28-2004, 09:51 PM   #2
Redeye2
Member
 
Registered: Feb 2004
Posts: 489

Rep: Reputation: Disabled
Are you using the nvidia driver? if so, you'll have to rerun the setup.
 
Old 02-28-2004, 09:54 PM   #3
h00ligan
LQ Newbie
 
Registered: Jan 2004
Posts: 23

Original Poster
Rep: Reputation: 15
no i shouldn't be, this is in a thinkpad t20 with savage IX chipset..

how could i rerun the setup from a command line.. sorry, newb
 
Old 02-28-2004, 10:51 PM   #4
quatsch
LQ Addict
 
Registered: Aug 2003
Location: New York, NY
Distribution: gentoo, gentooPPC
Posts: 1,661

Rep: Reputation: 47
startkde is no good. Use
startx
to see the error messages (startkde needs X running already; startx will start X and then start the default gui).
 
Old 02-28-2004, 11:20 PM   #5
h00ligan
LQ Newbie
 
Registered: Jan 2004
Posts: 23

Original Poster
Rep: Reputation: 15
yah, sorry it was a long post.. if you check the top part the error messageis listed when i try to run startx

thanks
 
Old 02-29-2004, 01:52 AM   #6
rmanocha
Member
 
Registered: Oct 2003
Location: Austin,TX
Distribution: Debian SID-->fully content-->Love APT,kernel 2.6.4
Posts: 327

Rep: Reputation: 30
do you have a .xinitrc file in your home directory.
seems like that is missing
put a file ~/.xinitrc with startkde in it.
so ~/.xinitrc should look like:
Code:
startkde
that should work.It did(And still does) work for me.
 
Old 03-09-2004, 09:39 AM   #7
Mr.Ampersand()
Member
 
Registered: Mar 2004
Location: United States, New York, Carmel via Putnam County
Posts: 80

Rep: Reputation: 15
Similar problem like yours. (Just installed Debian Linux)

Hi I just installed Debian linux and $display doesnt want to work for me for some reason. And I cant start X Server and am thrown back in the Shell.

Here is the error I wrote down:

xsetroot unable to open display
ksplash cannot connect to X server
Aborting $display is not set

How do I set it?
I'm going to try those commands above

startkde

and

startx

to see what happens. Maybe that will work
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Updated libpng, now existing GTK prog won't start anymore - Rh9 rylan76 Linux - Software 1 05-12-2005 02:06 PM
Updated KDE, cant login root aarond_04 Linux - Newbie 1 02-17-2005 08:43 PM
updated Kernel via Redhat's up2date; now X won't start Daninchina Linux - Newbie 9 02-01-2005 01:52 AM
Should it be updated. KDE 3.1.4 -> 3.2.2 ? GATTACA Slackware 7 05-20-2004 04:24 PM
Updated Suse 8.1 and KDE Panel now gone? MickeyMouse Linux - General 4 03-16-2003 11:13 AM


All times are GMT -5. The time now is 08:18 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration