I'm trying to install the dependency, webkit, for Handbrake. It gave me this error:
checking for GLIB... configure: error: Package requirements (glib-2.0 >= 2.21.3
gobject-2.0 >= 2.0
gthread-2.0 >= 2.0) were not met:
Requested 'glib-2.0 >= 2.21.3' but version of GLib is 2.18.4
Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.
Alternatively, you may set the environment variables GLIB_CFLAGS
and GLIB_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.
So I downloaded and installed glib 2.26.0. I ran ldconfig manually, tried rebooting the computer. I tried uninstalling and reinstalling glib, but it still gives me this error above.
How can I solve this dependency problem?