Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back > Forums > Linux Forums > Linux - Software
User Name
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.


  Search this Thread
Old 12-26-2005, 09:31 PM   #1
LQ Newbie
Registered: Jan 2005
Location: Brisbane, Australia
Distribution: Slackware 12
Posts: 17

Rep: Reputation: 0
Unwanted 404 error with apache

This issue has been solved. Thank you for reading.

I am running apache 1.3.x with mod_ssl and trying to install the vqadmin gui for qmail but when I try accessing the file over the net, it doesn't seem to exist and I get 404 errors. (/www/mail/cgi-bin/vqadmin/vqadmin.cgi) (This file definatly does exist on the file system)

The home page of the site works ( so i don't think it's a problem with the VirtualHost settings, although I am using mod_ssl, and i'm not used to that. I also have a .htacess file in the vqadmin folder which should allow it to execute cgi scripts

It's really quite annoying... Can anyone help?

UPDATE: I just tried it without ssl on port 82 ( with the same result
Not Found
The requested URL /cgi-bin/vqadmin/vqadmin.cgi was not found on this server.
Here's the contents of the .htaccess file in /www/mail/cgi-bin/vqadmin
AuthType Basic
AuthUserFile /www/mail/.htpasswd
AuthName vQadmin
require valid-user
satisfy any
And the directory informaion in httpd.conf:
<Directory "/www/mail/cgi-bin/vqadmin">
deny from all
Options ExecCGI
AllowOverride AuthConfig
Order deny,allow

<VirtualHost *:82>
DocumentRoot "/www/mail"
Don't worry. Solved it!

Last edited by Vossy; 12-26-2005 at 11:27 PM.


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Apache - CGI include gives 404 error gargsuchi Debian 0 12-24-2005 11:08 AM
why is apache giving me a 404 error linuxmandrake Linux - Software 4 06-17-2005 10:16 AM
odd Apache 404 error Seventh Linux - Software 1 03-27-2005 04:43 AM
trailing slash in Apache gives 404 errors rabbate Linux - General 6 04-30-2004 09:34 AM
Apache custom 404 documents Punker51 Linux - Software 2 12-06-2003 04:23 PM

All times are GMT -5. The time now is 07:58 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration