LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (http://www.linuxquestions.org/questions/linux-software-2/)
-   -   Unexpected crash in SMplayer (Linux Mint) (http://www.linuxquestions.org/questions/linux-software-2/unexpected-crash-in-smplayer-linux-mint-732021/)

nesrail 06-10-2009 03:06 PM

Unexpected crash in SMplayer (Linux Mint)
 
Hello.
When I watch movies with SMplayer in Linux Mint it suddenly crashes. It have never done this before.

It comes with this error messages: MPlayer has finished unexpectedly. Exit code: 1.

Here is the log of what happens when the crash happens:

Quote:

/usr/bin/mplayer -noquiet -nofs -nomouseinput -sub-fuzziness 1 -identify -slave -vo xv -ao alsa -nokeepaspect -framedrop -nodr -double -input conf=/usr/share/smplayer/input.conf -stop-xscreensaver -wid 46137359 -monitorpixelaspect 1 -ass -embeddedfonts -ass-line-spacing 0 -ass-font-scale 1 -ass-styles ~/.config/smplayer/styles.ass -fontconfig -font Arial -subfont-autoscale 0 -subfont-osd-scale 20 -subfont-text-scale 20 -subcp ISO-8859-1 -vid 0 -subpos 100 -cache 2000 -ss 725 -osdlevel 0 -vf-add screenshot -slices -channels 2 -af equalizer=0:0:0:0:0:0:0:0:0:0 -softvol -softvol-max 110 ~/Heroes/Heroes Season 2/Heroes S02E06.avi

MPlayer 1.0rc2-4.3.3 (C) 2000-2007 MPlayer Team
CPU: Intel(R) Celeron(R) CPU 550 @ 2.00GHz (Family: 6, Model: 22, Stepping: 1)
CPUflags: MMX: 1 MMX2: 1 3DNow: 0 3DNow2: 0 SSE: 1 SSE2: 1
Compiled with runtime CPU detection.
mplayer: could not connect to socket
mplayer: No such file or directory
Failed to open LIRC support. You will not be able to use your remote control.
Terminal type `unknown' is not defined.

Playing ~/Heroes/Heroes Season 2/Heroes S02E06.avi.

AVI file format detected.
ID_VIDEO_ID=0
[aviheader] Video stream found, -vid 0
ID_AUDIO_ID=1
[aviheader] Audio stream found, -aid 1
VIDEO: [XVID] 624x352 12bpp 23.976 fps 1052.9 kbps (128.5 kbyte/s)
Clip info:
Software: VirtualDub
ID_CLIP_INFO_NAME0=Software
ID_CLIP_INFO_VALUE0=VirtualDub
ID_CLIP_INFO_N=1
SUB: Detected subtitle file format: subviewer
SUB: Read 643 subtitles.
SUB: Adjusted 9 subtitle(s).
ID_FILE_SUB_ID=0
ID_FILE_SUB_FILENAME=~/Heroes/Heroes Season 2/Heroes S02E06.srt
SUB: Added subtitle file (1): ~/Skrivebord/Heroes/Heroes Season 2/Heroes S02E06.srt
ID_FILENAME=~/Heroes/Heroes Season 2/Heroes S02E06.avi
ID_DEMUXER=avi
ID_VIDEO_FORMAT=XVID
ID_VIDEO_BITRATE=1052904
ID_VIDEO_WIDTH=624
ID_VIDEO_HEIGHT=352
ID_VIDEO_FPS=23.976
ID_VIDEO_ASPECT=0.0000
ID_AUDIO_FORMAT=85
ID_AUDIO_BITRATE=121568
ID_AUDIO_RATE=0
ID_AUDIO_NCH=0
ID_LENGTH=2470.72
xscreensaver_disable: Could not find XScreenSaver window.
GNOME screensaver disabled
[ass] auto-open
Opening video filter: [screenshot]
[ass] Init
[ass] Updating font cache.
==========================================================================
Opening video decoder: [ffmpeg] FFmpeg's libavcodec codec family
Selected video codec: [ffodivx] vfm: ffmpeg (FFmpeg MPEG-4)
==========================================================================
ID_VIDEO_CODEC=ffodivx
==========================================================================
Forced audio codec: mad
Opening audio decoder: [libmad] libmad mpeg audio decoder
AUDIO: 48000 Hz, 2 ch, s16le, 128.0 kbit/8.33% (ratio: 16000->192000)
ID_AUDIO_BITRATE=128000
ID_AUDIO_RATE=48000
ID_AUDIO_NCH=2
Selected audio codec: [mad] afm: libmad (libMAD MPEG layer 1-2-3)
==========================================================================
AO: [alsa] 48000Hz 2ch floatle (4 bytes per sample)
ID_AUDIO_CODEC=mad
Starting playback...
VDec: vo config request - 624 x 352 (preferred colorspace: Planar YV12)
VDec: using Planar YV12 as output csp (no 0)
Movie-Aspect is 1.77:1 - prescaling to correct movie aspect.
ID_VIDEO_ASPECT=1.7727
[swscaler @ 0x896d370]SwScaler: using unscaled yuv420p -> bgr24 special converter
VO: [xv] 624x352 => 624x352 Planar YV12
[ass] PlayResX undefined, setting 511.
[ass] fontconfig: Selected font family is not the requested one: 'Liberation Sans' != 'Arial'
[ass] Glyph 0x92 not found, reselecting font for (Arial, 80, 0)
[ass] fontconfig_select: Using default font: (Arial, 80, 0) -> ~/.mplayer/subfont.ttf, 0
[ass] Error opening font: ~/.mplayer/subfont.ttf, 0


MPlayer interrupted by signal 11 in module: filter_video
ID_SIGNAL=11
- MPlayer crashed by bad usage of CPU/FPU/RAM.
Recompile MPlayer with --enable-debug and make a 'gdb' backtrace and
disassembly. Details in DOCS/HTML/en/bugreports_what.html#bugreports_crash.
- MPlayer crashed. This shouldn't happen.
It can be a bug in the MPlayer code _or_ in your drivers _or_ in your
gcc version. If you think it's MPlayer's fault, please read
DOCS/HTML/en/bugreports.html and follow the instructions there. We can't and
won't help unless you provide this information when reporting a possible bug.
GNOME screensaver enabled


All times are GMT -5. The time now is 11:56 PM.