LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
LinkBack Search this Thread
Old 03-07-2005, 07:59 PM   #1
dagalicous
LQ Newbie
 
Registered: Oct 2003
Location: NC
Posts: 17

Rep: Reputation: 0
Unable to start Apache "Cannot load /etc/httpd/modules/libphp4.so"


I am running a fresh install of Fedora Core 3.

Linux 2.6.10-1.766_FC3 i686 athlon i386 GNU/Linux

I have only updated things via yum.

My web server was working fine with mysql and php. However I belive something in the last "yum update" went wrong as when I attempt to load httpd via "/sbin/service httpd start"

I get the following error:
--------------------------------------------------

Starting httpd: Syntax error on line 6 of /etc/httpd/conf.d/php.conf:
Cannot load /etc/httpd/modules/libphp4.so into server: /usr/lib/libstdc++.so.6: symbol qngetc, version GLIBC_2.0 not defined in file libc.so.6 with link time reference

--------------------------------------------------
current packages installed:
--------------------------------------------------
httpd-2.0.52-3.1

php-4.3.10-3.2
php-pear-4.3.10-3.2
php-ldap-4.3.10-3.2
php-mysql-4.3.10-3.2

mod_auth_mysql-20030510-5
mysql-3.23.58-14
mysql-server-3.23.58-14
libdbi-dbd-mysql-0.6.5-9
mysql-devel-3.23.58-14
php-mysql-4.3.10-3.2
httpd-suexec-2.0.52-3.1
httpd-manual-2.0.52-3.1
system-config-httpd-1.3.1-1

glibc-common-2.3.4-2.fc3
glibc-headers-2.3.4-2.fc3
glib-1.2.10-15
dbus-glib-0.22-10.FC3.2
glibc-kernheaders-2.4-9.1.87
glib2-2.4.8-1.fc3
glib2-devel-2.4.8-1.fc3
glibc-2.3.4-2.fc3
glibc-devel-2.3.4-2.fc3
--------------------------------------------------


php.conf is as follows:
--------------------------------------------------
LoadModule php4_module modules/libphp4.so
AddType application/x-httpd-php .php
DirectoryIndex index.php
--------------------------------------------------

Thanks in advance.



Since this post I have removed all php/mysql/httpd packages and installed them again. I still get this error. Anyone out there have any suggestions?

Last edited by dagalicous; 03-08-2005 at 08:55 PM.
 
Old 03-10-2005, 01:43 AM   #2
dagalicous
LQ Newbie
 
Registered: Oct 2003
Location: NC
Posts: 17

Original Poster
Rep: Reputation: 0
I am not really sure what the fix was, I removed and reinstalled all the php/mysql/httpd rpms. I was pooking around tring to see what glib versions and such I have when the box stopped responding.. I rebooted and now I don't seem to have the problem anymore.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
"Unable to load NLS charset" BUT kernel seems to be right madmarauder Linux - General 1 09-17-2008 10:50 PM
Flash won't load in Konqueror - "Unable to load Netscape plugin" rollo Linux - Software 2 09-10-2005 12:28 PM
httpd: module "mod_perl.c" is not compatible with this version of Apache davidlarsen Linux - Software 2 08-25-2004 07:57 AM
is "httpd start" red hat specific? xilace Linux - Software 2 10-30-2003 05:35 PM
Automatically "force load " modules of PCtel modem on redhat juby Linux - Hardware 2 01-14-2003 11:45 AM


All times are GMT -5. The time now is 07:15 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration