LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
LinkBack Search this Thread
Old 01-06-2005, 03:13 PM   #1
newlinuxgeek
LQ Newbie
 
Registered: Oct 2003
Posts: 18

Rep: Reputation: 0
Unable to send/receive email


I have installed qmail on RH 8.0 using www.ndhsoft.com/qmailtoaster.htm
Everything was flowing smoothly until the past few days :-(

A couple of days ago, users were able to send/receive email locally, but not remotely. Now, we are unable to send nor receive emails locally and remotely. Here is a snippet of the /var/log/qmail/smtp/run file: (We are seeing this message repeatedly)

@4000000041ddab37291d0834 tcpserver: status: 1/20
@4000000041ddab37292418cc tcpserver: pid 4609 from 64.4.16.59
@4000000041ddab37293cf02c tcpserver: warning: dropping connection, unable to read /etc/tcprules.d/tcp.smtp.cdb: access denied
@4000000041ddab37293f16f4 tcpserver: end 4609 status 28416
@4000000041ddab37293f1ec4 tcpserver: status: 0/20
@4000000041ddab5e29df17e4 tcpserver: status: 1/20
@4000000041ddab5e29e672b4 tcpserver: pid 4610 from 64.4.16.80
@4000000041ddab5e29ffcafc tcpserver: warning: dropping connection, unable to read /etc/tcprules.d/tcp.smtp.cdb: access denied
@4000000041ddab5e2a022c5c tcpserver: end 4610 status 28416
@4000000041ddab5e2a023044 tcpserver: status: 0/20




Also, here is a snippet of our /var/log/qmail/send/run file:


@4000000041ddacb62a53fdac status: local 0/10 remote 1/255
@4000000041ddacb62a8dedb4 delivery 1591: deferral: CNAME_lookup_failed_temporarily._(#4.4.3)/
@4000000041ddacb62a8dfd54 status: local 0/10 remote 0/255
@4000000041ddacb82a8c826c starting delivery 1592: msg 195029 to local turnerj@se.fvsu.edu
@4000000041ddacb82a8c920c status: local 1/10 remote 0/255
@4000000041ddacb82a8c95f4 starting delivery 1593: msg 194990 to remote postmaster@fvsse
@4000000041ddacb82a8c9dc4 status: local 1/10 remote 1/255
@4000000041ddacb82a8ca1ac starting delivery 1594: msg 194928 to remote postmaster@fvsse
@4000000041ddacb82a8ca594 status: local 1/10 remote 2/255
@4000000041ddacb82ae214ac delivery 1592: deferral: Unable_to_chdir_to_maildir._(#4.2.1)/
@4000000041ddacb82ae22834 status: local 0/10 remote 2/255
@4000000041ddacb82af6ae1c delivery 1593: deferral: CNAME_lookup_failed_temporarily._(#4.4.3)/
@4000000041ddacb82af6b9d4 status: local 0/10 remote 1/255
@4000000041ddacb82af978f4 delivery 1594: deferral: CNAME_lookup_failed_temporarily._(#4.4.3)/
@4000000041ddacb82af97cdc status: local 0/10 remote 0/255


Any suggestions?



Thanks in advance.
 
Old 01-06-2005, 03:56 PM   #2
Hamsjael
Member
 
Registered: Aug 2003
Location: Vejle, Denmark
Distribution: Mainly Debian, some Fedora for the bleeding edge fix
Posts: 92

Rep: Reputation: 15
chroot

I have had problems with similar symptoms with other programs after install or upgrade, and in many cases (especially when some daemon cant find a bunch of files) it is because the daemon or program runs chrooted (doen't have acccess to entire filesystem)

so: Check if the process is chrooted, and if it is, try switching it (chrooting) off, and see if it helps

just a suggestion.

good luck
 
Old 01-10-2005, 09:07 AM   #3
newlinuxgeek
LQ Newbie
 
Registered: Oct 2003
Posts: 18

Original Poster
Rep: Reputation: 0
I resolved the errors in /var/log/qmail/smtp/run, and users can send email to external accounts now, but I still see the same errors in /var/log/qmail/send/run . Any suggestions on how to get rid of the "cname" errors?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
I can't send out email neither receive any... ultrax Linux - Wireless Networking 2 02-12-2008 09:16 AM
Can send email, not receive hanasi Suse/Novell 5 07-16-2005 04:05 PM
Can receive email but can't send it 60s TV Batman Fedora 10 06-26-2005 07:37 AM
Unable to send or receive email dcroxton Linux - Networking 0 04-29-2004 07:33 AM
Can receive email but can't send retarded Linux - Newbie 7 03-18-2004 07:37 AM


All times are GMT -5. The time now is 04:36 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration