LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 11-11-2008, 03:13 PM   #1
ncsuapex
Member
 
Registered: Dec 2004
Location: Raleigh, NC
Distribution: CentOS 2.6.18-53.1.4.el5
Posts: 770

Rep: Reputation: 42
unable to play a mms stream, that I am hosting using vlc.


I am trying to stream a wmv using vlc but have not been able to get the stream to play.

this is the command I use

The server I am hosting is on the same network as the PC I am trying to view the stream in so no firewall rules should apply. Correct?


cvlc -vvv movie.wmv --sout "#transcode{vcodec=mp2v,vb=128,scale=1,acodec=mpga,ab=32}:std{access=mmsh,mux=asfh,dst=:1234" --loop

Using CentOS5.1
VLC version 0.9.6 Grishenko


I created a new user and put the file in this users home directory. The user has full permissions on the file


error when I try to play it in windows media player:
Windows Media Player cannot find the file. If you are trying to play, burn, or sync an item that is in your library, the item might point to a file that has been moved, renamed, or deleted.


If I play this file locally then WMP plays it fine.


Ive tried the following ways to play the stream in IE and firefox

mms://IP:1234/file.wmv
mms://IP:1234/file.asf


If I run it with vlc -v I get this.


[00000001] main libvlc debug: translation test: code is "C"
[00000001] main libvlc warning: cannot load module `/usr/lib/vlc/video_filter/libswscale_plugin.so' (/usr/lib/vlc/video_filter/libswscale_plugin.so: undefined symbol: sws_freeFilter)
[00000392] playlist demux warning: invalid <playlist> attribute:"xmlns:vlc"
[00000413] inhibit interface error: Failed to connect to the D-Bus session daemon: Failed to execute dbus-launch to autolaunch D-Bus session
[00000413] main interface warning: no interface module matching "inhibit,none" could be loaded
[00000413] main interface error: no suitable interface module
[00000001] main libvlc error: interface "inhibit,none" initialization failed
[00000415] screensaver interface warning: failed to connect to the D-BUS daemon: Failed to execute dbus-launch to autolaunch D-Bus session
[00000419] dummy interface: using the dummy interface module...
config_ChainCreate: invalid options (empty)


ls -l /usr/lib/vlc/video_filter/libswscale_plugin.so
-rwxr-xr-x 1 root root 40136 Nov 9 19:51 /usr/lib/vlc/video_filter/libswscale_plugin.so



vlc -vvv --list | grep avcodec
VLC media player 0.9.6 Grishenko
[00000001] main libvlc debug: VLC media player - version 0.9.6 Grishenko - (c) 1996-2008 the VideoLAN team
[00000001] main libvlc debug: libvlc was configured with ./configure '--build=i686-redhat-linux-gnu' '--host=i686-redhat-linux-gnu' '--target=i386-redhat-linux-gnu' '--program-prefix=' '--prefix=/usr' '--exec-prefix=/usr' '--bindir=/usr/bin' '--sbindir=/usr/sbin' '--sysconfdir=/etc' '--datadir=/usr/share' '--includedir=/usr/include' '--libdir=/usr/lib' '--libexecdir=/usr/libexec' '--localstatedir=/var' '--sharedstatedir=/usr/com' '--mandir=/usr/share/man' '--infodir=/usr/share/info' '--disable-dependency-tracking' '--disable-rpath' '--disable-static' '--with-PIC' '--enable-release' '--enable-aa' '--enable-alsa' '--enable-arts' '--enable-caca' '--enable-cddax' '--enable-dirac' '--enable-dvbpsi' '--enable-dvdread' '--enable-esd' '--enable-faad' '--enable-fbosd' '--enable-ffmpeg' '--with-ffmpeg-tree=ffmpeg-20080225' '--with-ffmpeg-a52' '--with-ffmpeg-faac' '--with-ffmpeg-mp3lame' '--enable-libamr-nb' '--enable-libamr-wb' '--with-ffmpeg-ogg' '--with-ffmpeg-theora' '--with-ffmpeg-vorbis' '--with--ffmpeg-zlib' '--enable-flac' '--enable-galaktos' '--enable-gnomevfs' '--enable-lirc' '--enable-live555' '--with-live555-tree=/dar/build/vlc-0.9.6/live' '--enable-loader' '--enable-musicbrainz' '--enable-ncurses' '--enable-opencv' '--enable-pulse' '--enable-pvr' '--enable-real' '--enable-realrtsp' '--enable-shout' '--enable-snapshot' '--enable-svg' '--enable-svgalib' '--enable-switcher' '--enable-twolame' '--enable-upnp' '--enable-v4l' '--enable-xosd' '--enable-xvmc' 'build_alias=i686-redhat-linux-gnu' 'host_alias=i686-redhat-linux-gnu' 'target_alias=i386-redhat-linux-gnu' 'CFLAGS=-O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector --param=ssp-buffer-size=4 -m32 -march=i386 -mtune=generic -fasynchronous-unwind-tables' 'LDFLAGS=-L/usr/X11R6/lib' 'CXXFLAGS=-O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector --param=ssp-buffer-size=4 -m32 -march=i386 -mtune=generic -fasynchronous-unwind-tables' 'PKG_CONFIG_PATH=/usr/lib/pkgconfig:/usr/share/pkgconfig'
[00000001] main libvlc debug: translation test: code is "C"
[00000001] main libvlc debug: checking builtin modules
[00000001] main libvlc debug: checking plugin modules
[00000001] main libvlc debug: loading plugins cache file /home/streamtest/.cache/vlc/plugins-04041e.dat
[00000001] main libvlc debug: recursively browsing `/usr/lib/vlc'
[00000001] main libvlc warning: cannot load module `/usr/lib/vlc/video_filter/libswscale_plugin.so' (/usr/lib/vlc/video_filter/libswscale_plugin.so: undefined symbol: sws_freeFilter)
[00000001] main libvlc debug: module bank initialized, found 288 modules
avcodec FFmpeg audio/video decoder
avcodec FFmpeg audio/video encoder
avcodec FFmpeg deinterlace video filter
[00000001] main libvlc debug: writing plugins cache /home/streamtest/.cache/vlc/plugins-04041e.dat

Last edited by ncsuapex; 11-11-2008 at 03:19 PM. Reason: .
 
Old 11-11-2008, 04:53 PM   #2
ncsuapex
Member
 
Registered: Dec 2004
Location: Raleigh, NC
Distribution: CentOS 2.6.18-53.1.4.el5
Posts: 770

Original Poster
Rep: Reputation: 42
had to install this font rpm: fonts-ttf-freefont-20060126-2mdv2008.1.noarch.rpm


and change my command to this:

cvlc -v file.wmv --sout "#transcode{vcodec=WMV2,vb=512,scale=1,acodec=WMA2,ab=32}:std{access=mmsh,mux=asfh,dst=:1234" --loop

The video looks ok , still need to adjust the vb but I can't get any audio. According to gspot the audioc codec is 0x0161 (WMA v2)


What do I need to use for the acodec to get sound?
 
Old 11-12-2008, 08:10 AM   #3
ncsuapex
Member
 
Registered: Dec 2004
Location: Raleigh, NC
Distribution: CentOS 2.6.18-53.1.4.el5
Posts: 770

Original Poster
Rep: Reputation: 42
Looks like you have to convert WMV to AVI to get VLC to play the audio. Found this conversion script that seems to do the job.


mencoder infile.wmv -ofps 23.976 -ovc lavc -oac copy -o outfile.avi


I did change the "copy" flag to mp3lame then set the ab to 128 in my cvlc command. Seems to be playing fine.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Looking for a media menu interface for tv (mms stream channels, divx/xvid) r00tb33r Linux - Software 3 10-26-2008 09:29 PM
unable to play .wmv and .avi files in vlc nkd Fedora 11 04-15-2008 08:21 PM
Unable to play mms Irajas Linux - Newbie 1 05-03-2007 07:17 AM
mms stream problem zupermanz Linux - Newbie 9 02-20-2007 12:29 AM
mms stream playing in mplayer but not gxine bl0tt0 Slackware 2 10-31-2006 01:25 PM


All times are GMT -5. The time now is 11:42 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration