LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 06-03-2005, 06:59 AM   #1
ganja_guru
Member
 
Registered: Dec 2003
Location: Chennai, India
Distribution: Arch Linux 0.7
Posts: 393

Rep: Reputation: 30
unable to open apps when 'su'ing to root from user account


im not able to do things which require X if i 'su' to root from my user account within X(kde)...for example, unable to do a "make xconfig" while compiling a kernel, or install crossover office...i get a connection to X server refused ...ill post the exact error..

Xlib: connection to ":0.0" refused by server
Xlib: No protocol specified


Setup requires an X display to run. There is a display variable set, however
you have no permissions to access the X server (:0.0) it points to.
Try running xhost +localhost before su'ing to root.

this ONLY happens if i log in with kdm

Last edited by ganja_guru; 06-03-2005 at 07:05 AM.
 
Old 06-03-2005, 07:06 AM   #2
bathory
Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 10,938

Rep: Reputation: 1330Reputation: 1330Reputation: 1330Reputation: 1330Reputation: 1330Reputation: 1330Reputation: 1330Reputation: 1330Reputation: 1330Reputation: 1330
Run
Code:
xhost +LOCAL:
before su'ing to root
 
Old 06-03-2005, 07:17 AM   #3
slackist
Member
 
Registered: Feb 2004
Location: Phuket, Thailand
Distribution: Slackware 14.1
Posts: 435

Rep: Reputation: Disabled
For me I have to type xhost + as the regular before su-ing to root. Once root type "export DISPLAY=:0.0" without the quotation marks and your X apps should work.

HTH
 
Old 06-03-2005, 10:51 AM   #4
ganja_guru
Member
 
Registered: Dec 2003
Location: Chennai, India
Distribution: Arch Linux 0.7
Posts: 393

Original Poster
Rep: Reputation: 30
thank you very much..it worked just fine..
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Unable to mount cd under user account Hotfeet Debian 24 03-29-2005 09:51 AM
unable to log in to a user account cheema Mandriva 1 12-25-2004 09:34 AM
Unable to login using non-root account saxophobe Linux - Security 4 06-28-2004 08:58 AM
Unable to logon on as non-root user after update as unable to set executable context pls198 Fedora 2 04-09-2004 11:41 AM
Apps wont open as user but will as root slewis1972 Linux - Software 1 10-25-2003 12:07 PM


All times are GMT -5. The time now is 10:17 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration