LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 11-28-2005, 05:18 AM   #1
Xandor
Member
 
Registered: Oct 2005
Distribution: Ubuntu 5.10
Posts: 31

Rep: Reputation: 15
Unable to mount windows harddrive in Linux: "already mounted"


This may go under hardware, if so say something and I will move, with that being said:

I try to mount hdb my Windows 2000 drive via command
Quote:
sudo mount -t ntfs /dev/hdb /mnt/Windows
it gives my the following error
Quote:
mount: /dev/hdb already mounted or /mnt/Windows busy
Now I know atleast for hda1 and hdc it says something like "hda1 already mounted on /" if it truely is mounted already. So that leaves me to the conclusion that /mnt/Windows is busy but I don't see how or why. Either way then I try
Quote:
sudo mount -t ntfs /dev/hdb /mnt/cdrom
and same thing or if I try to mount it to /mnt/dvdrom. It all gives me the same thing. And there is absolutely nothing in the folders. So, I'm absolutely clueless. I have Kubuntu/Ubuntu 5.10 with kernel 2.6.12-9-386.
 
Old 11-28-2005, 05:30 AM   #2
bathory
Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 10,907

Rep: Reputation: 1326Reputation: 1326Reputation: 1326Reputation: 1326Reputation: 1326Reputation: 1326Reputation: 1326Reputation: 1326Reputation: 1326Reputation: 1326
What is the output of:
Code:
mount
cat /etc/mtab
 
Old 11-28-2005, 05:38 AM   #3
Xandor
Member
 
Registered: Oct 2005
Distribution: Ubuntu 5.10
Posts: 31

Original Poster
Rep: Reputation: 15
xandor16@Lucy-II:~$ mount
/dev/hda2 on / type reiserfs (rw,notail)
proc on /proc type proc (rw)
sysfs on /sys type sysfs (rw)
devpts on /dev/pts type devpts (rw,gid=5,mode=620)
tmpfs on /dev/shm type tmpfs (rw)
usbfs on /proc/bus/usb type usbfs (rw)
tmpfs on /lib/modules/2.6.12-9-386/volatile type tmpfs (rw,mode=0755)
tmpfs on /dev type tmpfs (rw,size=10M,mode=0755)

xandor16@Lucy-II:~$ cat /etc/mtab
/dev/hda2 / reiserfs rw,notail 0 0
proc /proc proc rw 0 0
sysfs /sys sysfs rw 0 0
devpts /dev/pts devpts rw,gid=5,mode=620 0 0
tmpfs /dev/shm tmpfs rw 0 0
usbfs /proc/bus/usb usbfs rw 0 0
tmpfs /lib/modules/2.6.12-9-386/volatile tmpfs rw,mode=0755 0 0
tmpfs /dev tmpfs rw,size=10M,mode=0755 0 0

Hope this helps.
 
Old 11-28-2005, 05:53 AM   #4
bathory
Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 10,907

Rep: Reputation: 1326Reputation: 1326Reputation: 1326Reputation: 1326Reputation: 1326Reputation: 1326Reputation: 1326Reputation: 1326Reputation: 1326Reputation: 1326
You must also specify the partition number where win2k resides in your mount command, i.e. for the primary partition:
Code:
mount -t ntfs /dev/hdb1 /mnt/Windows
 
Old 11-28-2005, 06:09 AM   #5
Xandor
Member
 
Registered: Oct 2005
Distribution: Ubuntu 5.10
Posts: 31

Original Poster
Rep: Reputation: 15
lol Figures.... I did that and it works now the folder is locked by permissions. I don't know chmod that well, do you know what permission values I should use?
 
Old 11-28-2005, 06:13 AM   #6
bathory
Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 10,907

Rep: Reputation: 1326Reputation: 1326Reputation: 1326Reputation: 1326Reputation: 1326Reputation: 1326Reputation: 1326Reputation: 1326Reputation: 1326Reputation: 1326
By default you cannot write to an ntfs partition. There are some workarounds but it's very risky to use them. If you want to, then try captive ntfs at your own risk.
 
Old 11-28-2005, 06:14 AM   #7
Xandor
Member
 
Registered: Oct 2005
Distribution: Ubuntu 5.10
Posts: 31

Original Poster
Rep: Reputation: 15
I cannot read it either though.
 
Old 11-28-2005, 06:31 AM   #8
bathory
Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 10,907

Rep: Reputation: 1326Reputation: 1326Reputation: 1326Reputation: 1326Reputation: 1326Reputation: 1326Reputation: 1326Reputation: 1326Reputation: 1326Reputation: 1326
You must be root (or use sudo) to read the mounted ntfs partition
 
Old 11-28-2005, 10:36 AM   #9
Xandor
Member
 
Registered: Oct 2005
Distribution: Ubuntu 5.10
Posts: 31

Original Poster
Rep: Reputation: 15
Can you change the permissions of the folder, that way I don't have to open up konqueror under root or view it in command prompt?
 
Old 11-28-2005, 12:41 PM   #10
KTheorem
LQ Newbie
 
Registered: Nov 2005
Location: Vista, CA, USA
Distribution: Fedora 12
Posts: 24

Rep: Reputation: 16
Don't know if this is feasible for you or not but I mount my ntfs partitions with the option umask="222". Makes every file readable and executable by everyone.
 
Old 11-28-2005, 03:00 PM   #11
Xandor
Member
 
Registered: Oct 2005
Distribution: Ubuntu 5.10
Posts: 31

Original Poster
Rep: Reputation: 15
That's perfect, I'll give it a shot.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Problems w/ Installation -- "Unable to detect and mount CD-ROM"? Sabriel Dyrim Ubuntu 1 09-20-2005 03:38 PM
mount "too many mounted" smbfs BruceC Linux - Newbie 0 07-01-2004 08:34 AM
Unable to Mount," Bogus File System Found" nav_Lin Linux - Newbie 1 04-16-2004 09:27 PM
Why I can only write in mounted windows partition in "su" mode Allen T Linux - Software 5 02-18-2003 01:10 AM
error:"kernel panic: VFS: Unable to mount root fs":-( shyguy Linux - Newbie 1 07-23-2001 04:03 PM


All times are GMT -5. The time now is 01:56 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration