LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 06-18-2009, 11:07 PM   #1
voyage-linux-noob
LQ Newbie
 
Registered: Jun 2009
Posts: 2

Rep: Reputation: 0
Smile Unable to install FFMPEG on voyage linux


Let me start by saying that RPM and YUM are not installed, however, apt-get is.

I run apt-get install ffmpeg and I get the following:

meshLium-AX:/var/cache/apt/archives# apt-get install ffmpeg
Reading package lists... Done
Building dependency tree... Done
ffmpeg is already the newest version.
You might want to run `apt-get -f install' to correct these:
The following packages have unmet dependencies:
ffmpeg: Depends: libavformat52 (>= 4:0.5+svn20090420) but it is not going to be installed or
libavformat-unstripped-52 (>= 4:0.5+svn20090420) but it is not installable
Depends: libavformat52 (< 4:0.5+svn20090420-99) but it is not going to be installed or
libavformat-unstripped-52 (< 4:0.5+svn20090420-99) but it is not installable
libavdevice52: Depends: libavformat52 (>= 4:0.5+svn20090420) but it is not going to be installed or
libavformat-unstripped-52 (>= 4:0.5+svn20090420) but it is not installable
Depends: libavformat52 (< 4:0.5+svn20090420-99) but it is not going to be installed or
libavformat-unstripped-52 (< 4:0.5+svn20090420-99) but it is not installable
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).

==================================================================
I then run apt-get -f install and I get:

meshLium-AX:/var/cache/apt/archives# apt-get -f install
Reading package lists... Done
Building dependency tree... Done
Correcting dependencies... Done
The following extra packages will be installed:
libavformat52
The following NEW packages will be installed:
libavformat52
0 upgraded, 1 newly installed, 0 to remove and 287 not upgraded.
27 not fully installed or removed.
Need to get 0B/700kB of archives.
After unpacking 1544kB of additional disk space will be used.
Do you want to continue [Y/n]? y
WARNING: The following packages cannot be authenticated!
libavformat52
Authentication warning overridden.
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
LANGUAGE = (unset),
LC_ALL = (unset),
LANG = "en_US.UTF-8"
are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").
debconf: delaying package configuration, since apt-utils is not installed
dpkg: regarding .../libavformat52_4%3a0.5+svn20090420-2_i386.deb containing libavformat52:
package uses Breaks; not supported in this dpkg
dpkg: error processing /var/cache/apt/archives/libavformat52_4%3a0.5+svn20090420-2_i386.deb (--unpack):
unsupported dependency problem - not installing libavformat52
Errors were encountered while processing:
/var/cache/apt/archives/libavformat52_4%3a0.5+svn20090420-2_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
meshLium-AX:/var/cache/apt/archives#

=====================================================================
I tried to fix dpkg, so I did (as a website suggested):
"sudo aptitude update && sudo aptitude upgrade"
and got:

meshLium-AX:/var/cache/apt/archives# sudo aptitude update && sudo aptitude upgrade
Get:1 http://security.debian.org testing/updates Release.gpg [1032B]
Get:2 http://ftp.be.debian.org unstable Release.gpg [835B]
Hit http://security.debian.org testing/updates Release
Get:3 http://www.debian-multimedia.org etch Release.gpg [197B]
Get:4 http://www.debian-multimedia.org stable Release.gpg [197B]
Hit http://ftp.be.debian.org unstable Release
Get:5 http://ftp.rediris.es testing Release.gpg [1032B]
Ign http://security.debian.org testing/updates/main Packages/DiffIndex
Hit http://www.debian-multimedia.org etch Release
Hit http://ftp.be.debian.org unstable/main Packages/DiffIndex
Hit http://ftp.rediris.es testing Release
Ign http://security.debian.org testing/updates/contrib Packages/DiffIndex
Hit http://www.debian-multimedia.org stable Release
Hit http://security.debian.org testing/updates/main Packages
Hit http://security.debian.org testing/updates/contrib Packages
Hit http://ftp.rediris.es testing/main Packages/DiffIndex
Hit http://www.debian-multimedia.org etch/main Packages/DiffIndex
Hit http://www.debian-multimedia.org etch/main Sources/DiffIndex
Hit http://www.debian-multimedia.org etch/main Packages/DiffIndex
Hit http://ftp.rediris.es testing/non-free Packages/DiffIndex
Hit http://www.debian-multimedia.org stable/main Sources/DiffIndex
Fetched 5B in 9s (1B/s)
Reading package lists... Done
Reading package lists... Done
Building dependency tree... Done
Reading extended state information
Initializing package states... Done
Building tag database... Done
The following packages have unmet dependencies:
ffmpeg: Depends: libavformat52 (>= 4:0.5+svn20090420) but it is not installable or
libavformat-unstripped-52 (>= 4:0.5+svn20090420) which is a virtual package.
Depends: libavformat52 (< 4:0.5+svn20090420-99) but it is not installable or
libavformat-unstripped-52 (< 4:0.5+svn20090420-99) which is a virtual package.
libavdevice52: Depends: libavformat52 (>= 4:0.5+svn20090420) but it is not installable or
libavformat-unstripped-52 (>= 4:0.5+svn20090420) which is a virtual package.
Depends: libavformat52 (< 4:0.5+svn20090420-99) but it is not installable or
libavformat-unstripped-52 (< 4:0.5+svn20090420-99) which is a virtual package.

======================================================================
and then I did:
"sudo aptitude reinstall dpkg"
and got:

meshLium-AX:/var/cache/apt/archives# sudo aptitude reinstall dpkg
Reading package lists... Done
Building dependency tree... Done
Reading extended state information
Initializing package states... Done
Building tag database... Done
The following packages are BROKEN:
ffmpeg libavdevice52
The following packages have been kept back:
adduser apache2 apache2-mpm-prefork apache2-utils apache2.2-common apt
aptitude base-files base-passwd bash bcrelay binfmt-support binutils
bluez-firmware bluez-hcidump bluez-utils bridge-utils bsdutils busybox
ca-certificates coreutils cpio cpp cpp-4.1 cpp-4.2 cron cryptmount
cryptsetup dbus debconf debconf-english debconf-utils
debian-archive-keyring debianutils dhcp-client dhcp3-common dhcp3-server
diff dmsetup dnsmasq e2fslibs e2fsprogs ebtables elvis-tiny expect file
findutils gcc gcc-4.1 gcc-4.1-base gcc-4.2 gcc-4.2-base gcc-4.3-base
gettext-base gnupg gpgv gpsd gpsd-clients grep grub gzip hostap-utils
hostapd hostname ifenslave-2.6 ifupdown initramfs-tools initscripts iperf
iproute iptables iptraf iputils-ping klibc-utils klogd less lesstif2
libacl1 libapache2-mod-php5 libapr1 libaprutil1 libatm1 libattr1
libavahi-common-data libavahi-common3 libavahi-glib1 libbeecrypt6
libblkid1 libbluetooth2 libboost-date-time1.34.1 libboost-thread1.34.1
libbz2-1.0 libc6 libc6-dev libccid libcomerr2 libcurl3 libcurl3-dbg
libcurl3-gnutls libdb4.2 libdb4.6 libdbd-mysql-perl libdbi-perl
libdbus-1-3 libdbus-1-dev libdbus-glib-1-2 libdbus-glib-1-dev
libdc1394-22 libdevmapper1.02.1 libedit2 libexpat1 libgcc1 libgcrypt11
libgdbm3 libglib2.0-0 libglib2.0-0-dbg libglib2.0-cil libglib2.0-data
libglib2.0-dev libglibmm-2.4-1c2a libglibmm-2.4-dbg libglibmm-2.4-dev
libgnutls26 libgpg-error0 libgssapi-krb5-2 libhal1 libice6 libidn11
libiw29 libk5crypto3 libkeyutils1 libklibc libkrb5-3 libkrb53
libkrb5support0 libldap-2.4-2 liblzo2-2 libmagic1 libmono-corlib1.0-cil
libmono-system1.0-cil libmudflap0 libmudflap0-dev libmysqlclient15off
libncurses5 libncursesw5 libneon27 libnet-daemon-perl libnewt0.52
libopenobex1 libopenobex1-dev libpam-modules libpam-runtime libpam0g
libpcap0.8 libpcre3 libpcsclite1 libplrpc-perl libpng12-0 libpopt0
libreadline5 libsasl2-2 libselinux1 libsepol1 libsigc++-2.0-0c2a
libsigc++-2.0-dev libslang2 libslp1 libsm6 libsqlite3-0 libss2 libssh2-1
libssl0.9.8 libstdc++6 libsysfs2 libtasn1-3 libterm-readkey-perl
libusb-0.1-4 libusb-1.0-0 libusb-dev libuuid1 libwrap0 libx11-6
libx11-data libx86-1 libxau6 libxaw7 libxdmcp6 libxext6 libxml++2.6-2
libxml2 libxp6 libxplc0.3.13 libxpm4 lilo linux-libc-dev locales login
logrotate lsb-base makedev mawk mbr mime-support mktemp modconf
module-init-tools mono-common mono-jit mount mysql-client-5.0
mysql-common mysql-server mysql-server-5.0 nano ncurses-base ncurses-bin
net-tools netbase nmap ntpdate olsrd olsrd-plugins openbsd-inetd
openobex-apps openssh-client openssh-server openssl openvpn parprouted
passwd pciutils perl perl-base perl-doc perl-modules php5 php5-common
php5-curl php5-mysql pkg-config portmap ppp pppconfig pppoeconf pptpd
procps psmisc python python-minimal python2.4 python2.4-minimal
readline-common rsync sed sqlite3 ssh strace sudo sysklogd sysv-rc
sysvinit sysvinit-utils tar tcl8.4 tcpd tcpdump traceroute tzdata ucf
udev update-inetd util-linux vim vim-common vim-runtime vlan watchdog
wavemon wget whiptail wireless-tools wpasupplicant wvdial x11-common
xml-core zlib1g
The following packages will be REINSTALLED:
dpkg
0 packages upgraded, 0 newly installed, 1 reinstalled, 0 to remove and 286 not upgraded.
Need to get 0B of archives. After unpacking 0B will be used.
The following packages have unmet dependencies:
ffmpeg: Depends: libavformat52 (>= 4:0.5+svn20090420) but it is not installable or
libavformat-unstripped-52 (>= 4:0.5+svn20090420) which is a virtual package.
Depends: libavformat52 (< 4:0.5+svn20090420-99) but it is not installable or
libavformat-unstripped-52 (< 4:0.5+svn20090420-99) which is a virtual package.
libavdevice52: Depends: libavformat52 (>= 4:0.5+svn20090420) but it is not installable or
libavformat-unstripped-52 (>= 4:0.5+svn20090420) which is a virtual package.
Depends: libavformat52 (< 4:0.5+svn20090420-99) but it is not installable or
libavformat-unstripped-52 (< 4:0.5+svn20090420-99) which is a virtual package.
Resolving dependencies...
E: I wasn't able to locate file for the dpkg package. This might mean you need to manually fix this package.
The following actions will resolve these dependencies:

Install the following packages:
libavformat52 [4:0.5+svn20090420-2 (testing, unstable)]

Score is -19

Accept this solution? [Y/n/q/?] y
The following NEW packages will be automatically installed:
libavformat52
The following packages have been kept back:
adduser apache2 apache2-mpm-prefork apache2-utils apache2.2-common apt
aptitude base-files base-passwd bash bcrelay binfmt-support binutils
bluez-firmware bluez-hcidump bluez-utils bridge-utils bsdutils busybox
ca-certificates coreutils cpio cpp cpp-4.1 cpp-4.2 cron cryptmount
cryptsetup dbus debconf debconf-english debconf-utils
debian-archive-keyring debianutils dhcp-client dhcp3-common dhcp3-server
diff dmsetup dnsmasq e2fslibs e2fsprogs ebtables elvis-tiny expect file
findutils gcc gcc-4.1 gcc-4.1-base gcc-4.2 gcc-4.2-base gcc-4.3-base
gettext-base gnupg gpgv gpsd gpsd-clients grep grub gzip hostap-utils
hostapd hostname ifenslave-2.6 ifupdown initramfs-tools initscripts iperf
iproute iptables iptraf iputils-ping klibc-utils klogd less lesstif2
libacl1 libapache2-mod-php5 libapr1 libaprutil1 libatm1 libattr1
libavahi-common-data libavahi-common3 libavahi-glib1 libbeecrypt6
libblkid1 libbluetooth2 libboost-date-time1.34.1 libboost-thread1.34.1
libbz2-1.0 libc6 libc6-dev libccid libcomerr2 libcurl3 libcurl3-dbg
libcurl3-gnutls libdb4.2 libdb4.6 libdbd-mysql-perl libdbi-perl
libdbus-1-3 libdbus-1-dev libdbus-glib-1-2 libdbus-glib-1-dev
libdc1394-22 libdevmapper1.02.1 libedit2 libexpat1 libgcc1 libgcrypt11
libgdbm3 libglib2.0-0 libglib2.0-0-dbg libglib2.0-cil libglib2.0-data
libglib2.0-dev libglibmm-2.4-1c2a libglibmm-2.4-dbg libglibmm-2.4-dev
libgnutls26 libgpg-error0 libgssapi-krb5-2 libhal1 libice6 libidn11
libiw29 libk5crypto3 libkeyutils1 libklibc libkrb5-3 libkrb53
libkrb5support0 libldap-2.4-2 liblzo2-2 libmagic1 libmono-corlib1.0-cil
libmono-system1.0-cil libmudflap0 libmudflap0-dev libmysqlclient15off
libncurses5 libncursesw5 libneon27 libnet-daemon-perl libnewt0.52
libopenobex1 libopenobex1-dev libpam-modules libpam-runtime libpam0g
libpcap0.8 libpcre3 libpcsclite1 libplrpc-perl libpng12-0 libpopt0
libreadline5 libsasl2-2 libselinux1 libsepol1 libsigc++-2.0-0c2a
libsigc++-2.0-dev libslang2 libslp1 libsm6 libsqlite3-0 libss2 libssh2-1
libssl0.9.8 libstdc++6 libsysfs2 libtasn1-3 libterm-readkey-perl
libusb-0.1-4 libusb-1.0-0 libusb-dev libuuid1 libwrap0 libx11-6
libx11-data libx86-1 libxau6 libxaw7 libxdmcp6 libxext6 libxml++2.6-2
libxml2 libxp6 libxplc0.3.13 libxpm4 lilo linux-libc-dev locales login
logrotate lsb-base makedev mawk mbr mime-support mktemp modconf
module-init-tools mono-common mono-jit mount mysql-client-5.0
mysql-common mysql-server mysql-server-5.0 nano ncurses-base ncurses-bin
net-tools netbase nmap ntpdate olsrd olsrd-plugins openbsd-inetd
openobex-apps openssh-client openssh-server openssl openvpn parprouted
passwd pciutils perl perl-base perl-doc perl-modules php5 php5-common
php5-curl php5-mysql pkg-config portmap ppp pppconfig pppoeconf pptpd
procps psmisc python python-minimal python2.4 python2.4-minimal
readline-common rsync sed sqlite3 ssh strace sudo sysklogd sysv-rc
sysvinit sysvinit-utils tar tcl8.4 tcpd tcpdump traceroute tzdata ucf
udev update-inetd util-linux vim vim-common vim-runtime vlan watchdog
wavemon wget whiptail wireless-tools wpasupplicant wvdial x11-common
xml-core zlib1g
The following packages will be REINSTALLED:
dpkg
The following NEW packages will be installed:
libavformat52
0 packages upgraded, 1 newly installed, 1 reinstalled, 0 to remove and 286 not upgraded.
Need to get 0B/700kB of archives. After unpacking 1544kB will be used.
Do you want to continue? [Y/n/?] y
Writing extended state information... Error!
E: I wasn't able to locate file for the dpkg package. This might mean you need to manually fix this package.
E: Couldn't lock list directory..are you root?


=============================================================

I don't know what to do; please help. This is my first post on a forum, so I'm sorry if I made it to long. Thanks in advanced .
 
Old 10-30-2010, 07:34 AM   #2
archtoad6
Senior Member
 
Registered: Oct 2004
Location: Houston, TX (usa)
Distribution: MEPIS, Debian, Knoppix,
Posts: 4,727
Blog Entries: 15

Rep: Reputation: 230Reputation: 230Reputation: 230
Did you mean to mark this "[SOLVED]"?

If so, kindly post the solution -- even though this is an old post, it still might help someone else w/ the same, or a similar, problem.

As far as long posts are concerned, put code & output listings in "Code:" blocks or pastebins.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
LXer: Linux Store Open for Business: A Fantastic Voyage LXer Syndicated Linux News 0 04-11-2009 09:31 PM
LXer: Do More With Less: 802.1Q VLANs with Voyage Linux LXer Syndicated Linux News 0 02-13-2008 10:30 AM
about voyage-2.4.24.patch kpachopoulos Linux - Wireless Networking 1 01-11-2006 05:14 PM


All times are GMT -5. The time now is 09:41 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration