LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices



Reply
 
Search this Thread
Old 04-19-2013, 03:21 AM   #1
usr345
Member
 
Registered: Jan 2012
Posts: 80
Blog Entries: 1

Rep: Reputation: Disabled
udevadm slow boot


After I upgraded from Slackware 13.70 to 14.0, when the machine is booting, it takes 10 seconds to execute this line:

Quote:
/sbin/udevadm trigger --action=add
I added --verbose statement to it, and found, that it is slow on this command:

Quote:
/sys/devices/virtual/block/md0
I googled, and found, that this is often mentioned together with RAID. But I don't have RAID.

What does this device stand for? Is it possible to make it boot faster?
 
Old 04-27-2013, 10:38 AM   #2
Sigg3.net
Member
 
Registered: Mar 2008
Location: Oslo, Norway
Distribution: Fedora 17, Ubuntu 12 LTS and Ubuntu server 10.04
Posts: 161

Rep: Reputation: 23
Yup! If you don't have raid add
append="raid=noautodetect"
to your /etc/lilo.conf, run lilo and reboot.

Code:
Example:
# Linux bootable partition config begins
image = /boot/vmlinuz-huge-smp-3.2.13-smp
  root = /dev/sda3
  label = Slackware
  append = "raid=noautodetect"
  read-only
# Linux bootable partition config ends
 
Old 04-27-2013, 02:34 PM   #3
usr345
Member
 
Registered: Jan 2012
Posts: 80
Blog Entries: 1

Original Poster
Rep: Reputation: Disabled
Did it. But the problem persists. Any ideas, how to debug?
 
Old 04-28-2013, 03:55 AM   #4
Sigg3.net
Member
 
Registered: Mar 2008
Location: Oslo, Norway
Distribution: Fedora 17, Ubuntu 12 LTS and Ubuntu server 10.04
Posts: 161

Rep: Reputation: 23
By the way, in dmesg output, what is the process just BEFORE initializing RAID. That could just as well be the real culprit, in my experience.
 
  


Reply

Tags
booting, udev


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Slackware 14.0 install hangs at udevadm jtdippold Slackware - Installation 2 03-30-2013 06:00 PM
udevadm timeout amtd Slackware 0 04-08-2012 05:24 AM
udevadm info -a -p , how to work with it ? hen770 Linux - Desktop 0 09-18-2011 06:18 PM
Boot - UDEVADM modsRule Debian 4 02-24-2009 02:35 PM
slow to boot, slow dns resolution after host name change FC5 edavis6678 Linux - Newbie 3 01-03-2007 07:26 PM


All times are GMT -5. The time now is 06:06 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration