-   Linux - Software (
-   -   Two Video Devices - /dev/video0 & /dev/video1 (

liguorir 07-16-2003 11:53 PM

Two Video Devices - /dev/video0 & /dev/video1
My video editor card comes up on /dev/video0.

When I put in my USB web came, this takes over /dev/video0.

How can I configure one for video0 and the other for video1.


Robert Liguori

slapNUT 07-21-2003 08:20 PM

Whatever the driver is for the webcam, you need to query the driver and see if you can tell it to use /dev/video1.

For instance I have a Logitech QuickCam Express and the driver is mod_quickcam so I enter this:


# modinfo mod_quickcam
filename:    /lib/modules/2.4.21/kernel/drivers/usb/mod_quickcam.o
description: "Logitech Quickcam Express Webcam driver"
author:      "see README"
license:    "GPL"
parm:        debug int, description "Sets the debug output (1,2,4,8,16,32)"
parm:        interpolation int, description "Sets the interpolation mode (0-1)"
parm:        mode int, description "Sets the speed (0-1)"
parm:        keepexposure int, description "Keep gain settings across one open to another (0-1)"
parm:        tobgr int, description "Automatic RGB -> BGR conversion"
parm:        rgain int, description "Initial value of red gain (0-255)"
parm:        bgain int, description "Initial value of blue gain (0-255)"
parm:        ggain int, description "Initial value of green gains (0-255)"
parm:        bright int, description "Initial value for brightness (0-65535)"
parm:        video_nr int, description "Set videodevice number (/dev/videoX)"

So I hi-lighted the parameter I need to pass to the driver i.e. video_nr 1. Now I just edit /etc/modules.conf and pass the parameter to the mod_quickcam driver like thus:

alias camera mod_quickcam video_nr 1

To verify it worked I check in /proc/video/dev


# cat video0
name            : BT878(Hauppauge (bt878))
hardware        : 0x1
[dev]# cat video1
name            : Logitech Quickcam Express USB
type            : VID_TYPE_CAPTURE
hardware        : 0xcf1aa310

All times are GMT -5. The time now is 10:51 AM.