LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 05-16-2006, 04:12 AM   #1
jlinkels
Senior Member
 
Registered: Oct 2003
Location: Bonaire
Distribution: Debian Wheezy/Jessie/Sid, Linux Mint DE
Posts: 4,193

Rep: Reputation: 538Reputation: 538Reputation: 538Reputation: 538Reputation: 538Reputation: 538
Tryying to keep Konqueror in "Detailed List View", but it always reverts to Icon View


I am running Debian Etch with KDE 3.4.

In Konqueror I created a new folder in the side bar. The folder's URL is /media.

When I look at the tree view in the left pane I see:

media
+cdrom
+floppy
+hda1
+hda5
+hda6
+hda7

That is correct. When I click on for example hda1 I see the contents of /dev/hda1.

I set "view | detailed list mode". Then I saved the settings using the "Settings | Save View Profile "File Management"

When I don't do anyhting else, close Konqueror and restart it, it shows /dev/hda1 again in detailed list view.

However, when I click on "media" in the tree view, the view reverts to Icon View. I can set that to "Detailed List View", but when I go back to /dev/hda1, it reverts to Icon View again.

No matter how much I save this view profile, any time that I go to media, OR to another device, the view changes back to Icon View. I always have to tell Konqueror explicitely to go back to Detailed List View. All other settings are preserved when I save the settings, but this Icon View seems to be glued in somewhere.

This is very annoying. Also, in the settings menu, the "Save View Settings Per Folder" is always grayed out.

This also happens when I load a view profile which is standard in Detailed List View, for example Midnight Commander View. When I go to Media, it changes to Icon View.

I have checked the konquerorrc file, and the ~/.kde/share/apps/konqueror file, but there is not a single reference to icon view anywhere.

Is this a bug, or am I doing something wrong? I despise icon view, and this keeps me from upgrading to kde 3.4.

jlinkels
 
Old 05-16-2006, 12:11 PM   #2
jlinkels
Senior Member
 
Registered: Oct 2003
Location: Bonaire
Distribution: Debian Wheezy/Jessie/Sid, Linux Mint DE
Posts: 4,193

Original Poster
Rep: Reputation: 538Reputation: 538Reputation: 538Reputation: 538Reputation: 538Reputation: 538
The bug is reported here:
http://bugs.kde.org/show_bug.cgi?id=108542

And also a workaround by Gerrit Fricke. The workaround works! Besides, the bug is recognized and a patch is available.

jlinkels

Last edited by jlinkels; 05-16-2006 at 09:35 PM.
 
Old 05-16-2006, 01:21 PM   #3
kencaz
Senior Member
 
Registered: Mar 2005
Location: Las Vegas, NV
Distribution: Mandriva Slackware FreeBSD
Posts: 1,468

Rep: Reputation: 48
check ~/.kde/config/konquerorrc

[MainView Settings]
BackRightClick=false
ToggableViewsShown=
ViewMode=konq_iconview

KC
 
Old 05-16-2006, 09:45 PM   #4
jlinkels
Senior Member
 
Registered: Oct 2003
Location: Bonaire
Distribution: Debian Wheezy/Jessie/Sid, Linux Mint DE
Posts: 4,193

Original Poster
Rep: Reputation: 538Reputation: 538Reputation: 538Reputation: 538Reputation: 538Reputation: 538
Kencaz,

The problem is solved. I posted the link as shown in my previous post. I was short on time, so as soon as I discovered the workaround I posted the link, but without explanation.

This behaviour can NOT be set in konquerorrc. The problem is that the view is stored correctly, but it is only valid for directories. The media:/ folder is not considered a dierctory by Konqueror, but a KDEdevice. KDEdevices have a different behaviour. This behaviour can be set in KDE Configuration screen. You have to specify for each media type (cdrom, hdd, dvd etc) what the default file association is. Here you can specify whether it should be displayed as icon OR as detailed list.

This is what I understood from the explanation. I think the correct behaviour for konqueror is to override this setting and use its own view setting. This is abviously not true, but the workaround fortunately works.

Thanks anyway for suggesting a solution.

jlinkels
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
KDE Konqueror View Mode Icons (Image Preview/Tree View) sadarax Linux - General 7 06-27-2006 01:45 PM
In addition to "view new posts" about "View last 24 hours" KimVette LQ Suggestions & Feedback 3 10-30-2005 11:22 AM
Konqueror - Hover over an icon to view metadata RoaCh Of DisCor Linux - Software 12 07-25-2005 11:54 AM
SAMBA / Win98 "..cannot view the list of users.." calabash Linux - Networking 1 10-01-2003 09:38 PM
View more than 25 threads on the "view new posts" page lfslinux LQ Suggestions & Feedback 2 02-02-2002 01:07 PM


All times are GMT -5. The time now is 09:11 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration