LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 11-22-2008, 01:05 AM   #1
twelvenine
Member
 
Registered: Sep 2006
Posts: 72

Rep: Reputation: 16
trying to use GNU screen. backspace makes screen flash.


I really like using screen, but there's one thing that has really been bugging me. when i backspace too much, like when there's nothing on a line and i hit backspace, the screen flashes white(or whatever the text color is). I often just hold backspace until i have a clear line if i make a mistake, and the screen flashing just kinda hurts my eyes and i'd like to stop this behavior.

Anybody know what i'm talking about? or how to fix it? it happens when i'm using screen in console(like runlevel 2,3, etc.) and when running screen in an x terminal emulator.
 
Old 11-22-2008, 09:47 AM   #2
estabroo
Senior Member
 
Registered: Jun 2008
Distribution: debian, ubuntu, sidux
Posts: 1,094
Blog Entries: 2

Rep: Reputation: 111Reputation: 111
Its called visible bell or visual bell. I'm not sure how to turn it off in general, but in an xterm you can bring up the VT options menu (ctrl-middle-mouse-button) and uncheck enable visual bell or in your ~/.Xdefaults file set it to off and in screen C-a C-g toggles it.
 
Old 11-22-2008, 11:15 AM   #3
twelvenine
Member
 
Registered: Sep 2006
Posts: 72

Original Poster
Rep: Reputation: 16
visual bell huh? i've never seen it when i'm just using a regular shell. i have had the system speaker beep at me when i over-backspace. had to disable the system speaker on one of my computers. i'll look into disabling the visual bell in screen. thanks.
 
Old 11-23-2008, 12:40 AM   #4
twelvenine
Member
 
Registered: Sep 2006
Posts: 72

Original Poster
Rep: Reputation: 16
ok so i looked around and c-a c-g did the trick for changing from visual to audible bell. now the screen doesn't flash and since i don't have a system speaker i don't hear anything. i'd really like to turn off these bells altogether.
 
Old 11-23-2008, 04:35 PM   #5
estabroo
Senior Member
 
Registered: Jun 2008
Distribution: debian, ubuntu, sidux
Posts: 1,094
Blog Entries: 2

Rep: Reputation: 111Reputation: 111
Well you could use ctrl-u to clear the line instead of backspaces, that would certainly cut down on the number of 'bells' going off
 
Old 08-07-2009, 08:37 PM   #6
Thr4wn
LQ Newbie
 
Registered: Oct 2008
Posts: 2

Rep: Reputation: 0
visual bell

The feature is called "visual bell".

here are applicable properties you can set in your ~/.screenrc file

vbell_msg "bell: window ~%" # Message for visual bell
vbellwait 2 # Seconds to pause the screen for visual bell
vbell off # Turns visual bell off
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
installing screen(http://www.gnu.org/software/screen/) dreamlemon Solaris / OpenSolaris 5 09-29-2007 03:36 PM
Backspace won't work in screen JussiKp Linux - General 1 11-30-2006 06:44 PM
backspace in screen? andrew001 Linux - Software 3 01-09-2004 05:38 PM
Backspace not working at login screen bspicer Linux - General 2 04-11-2002 11:20 AM


All times are GMT -5. The time now is 02:37 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration