LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 04-17-2007, 09:01 AM   #1
Rig24
LQ Newbie
 
Registered: Dec 2002
Location: McLean
Posts: 28

Rep: Reputation: 15
Trying to upgrade openssh


Have a RedHat Linux Enterprise server v. 3. Currently it has OpenSSH 3.6.1 installed. To get the system certified I need to get it up to 3.7.1. I went to rpm.pbone.net and found "penssh-3.7.1p1-1.i386.rpm". Tried to install it and got the following:

[root@Server ssh]# rpm -Uvh openssh-3.7.1p1-1.i386.rpm
error: Failed dependencies:
libcrypto.so.0.9.7 is needed by openssh-3.7.1p1-1
openssh = 3.6.1p2-33.30.13 is needed by (installed) openssh-clients-3.6.1p2-33.30.13
openssh = 3.6.1p2-33.30.13 is needed by (installed) openssh-askpass-3.6.1p2-33.30.13
openssh = 3.6.1p2-33.30.13 is needed by (installed) openssh-askpass-gnome-3.6.1p2-33.30.13
openssh = 3.6.1p2-33.30.13 is needed by (installed) openssh-server-3.6.1p2-33.30.13



What do I do now?
 
Old 04-17-2007, 09:11 AM   #2
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,398

Rep: Reputation: 1965Reputation: 1965Reputation: 1965Reputation: 1965Reputation: 1965Reputation: 1965Reputation: 1965Reputation: 1965Reputation: 1965Reputation: 1965Reputation: 1965
you install the dependencies it asks for, that's why it's told you.

openssh-clients-3.7.1p1-1.i386.rpm
openssh-server-3.7.1p1-1.i386.rpm

etc...
 
Old 04-17-2007, 10:02 AM   #3
Rig24
LQ Newbie
 
Registered: Dec 2002
Location: McLean
Posts: 28

Original Poster
Rep: Reputation: 15
I was able ot install openssl-0.9.7c-3.i386.rpm and that got rid of the libcrypto.so.0.9.7.

Now when I try to install the others I am getting:

[root@Server ssh]# rpm -ivh openssh-askpass-3.7.1p1-1.i386.rpm
warning: openssh-askpass-3.7.1p1-1.i386.rpm: V3 DSA signature: NOKEY, key ID 86ff9c48
error: Failed dependencies:
openssh = 3.7.1p1-1 is needed by openssh-askpass-3.7.1p1-1

This is coming up if I use -ivh or -Uvh. So I tried openssh-3.7.1p1-1 again and got:

[root@Server ssh]# rpm -Uvh openssh-3.7.1p1-1.i386.rpm
warning: openssh-3.7.1p1-1.i386.rpm: V3 DSA signature: NOKEY, key ID 86ff9c48
error: Failed dependencies:
openssh = 3.6.1p2-33.30.13 is needed by (installed) openssh-clients-3.6.1p2-33.30.13
openssh = 3.6.1p2-33.30.13 is needed by (installed) openssh-askpass-3.6.1p2-33.30.13
openssh = 3.6.1p2-33.30.13 is needed by (installed) openssh-askpass-gnome-3.6.1p2-33.30.13
openssh = 3.6.1p2-33.30.13 is needed by (installed) openssh-server-3.6.1p2-33.30.13

Sorry for being such a newbie, but this has been forced on my with a short deadline.
 
Old 04-17-2007, 10:16 AM   #4
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,398

Rep: Reputation: 1965Reputation: 1965Reputation: 1965Reputation: 1965Reputation: 1965Reputation: 1965Reputation: 1965Reputation: 1965Reputation: 1965Reputation: 1965Reputation: 1965
get all the files in that series you're upgrading to, and install them all on ONE single command line, using the U option, not i.
 
Old 04-17-2007, 11:23 AM   #5
Rig24
LQ Newbie
 
Registered: Dec 2002
Location: McLean
Posts: 28

Original Poster
Rep: Reputation: 15
It worked!!! Didn't know you could do that (part of being new to it I guess). Thanks very much for the help.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
openssh bong.mau Linux - Software 2 11-09-2005 12:04 PM
unable to upgrade openSSH on RH6.2 assdee Linux - Software 2 12-29-2003 05:05 PM
X by openSSH Grimmy Linux - Security 2 03-16-2003 08:43 AM
openSSH? MrJoshua Linux - General 3 10-09-2002 12:17 PM
OpenSSH Tarantismic Yak Linux - Security 2 07-14-2001 04:26 AM


All times are GMT -5. The time now is 11:59 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration