LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 06-02-2003, 06:26 PM   #1
Therm
LQ Newbie
 
Registered: Jun 2003
Location: United States
Distribution: Mandrake
Posts: 10

Rep: Reputation: 0
Trying to install proftpd


When I downloaded the rpm for proftpd for Mandrake I get this message and I really don't know if I should do it or not cause last time I did it updateing perl base it crashed my whole system and I got kernel panic

The following packages have to be removed for others to be upgraded:
Guppi-0.40.3-5mdk (due to missing libgnomeprint.so.15)
LinNeighborhood-0.6.5-2mdk (due to missing samba-client)
OpenOffice.org-1.0.2-7mdk (due to missing ghostscript)
OpenOffice.org-help-en-1.0.2-7mdk (due to unsatisfied OpenOffice.org == 1.0.2)
OpenOffice.org-l10n-en-1.0.2-7mdk (due to unsatisfied OpenOffice.org == 1.0.2)
SysVinit-2.84-2mdk (due to unsatisfied pam >= 0.66-5)
XFree86-100dpi-fonts-4.3-5mdk (due to unsatisfied XFree86 == 4.3)
XFree86-4.3-5mdk (due to unsatisfied utempter *)
XFree86-75dpi-fonts-4.3-5mdk (due to unsatisfied XFree86 == 4.3)
XFree86-server-4.3-5mdk (due to unsatisfied XFree86 == 4.3-5mdk)
XFree86-xfs-4.3-5mdk (due to unsatisfied rpm-helper *)
apache-conf-2.0.44-11mdk (due to unsatisfied rpm-helper *)
apache2-2.0.45-4.3mdk (due to unsatisfied apache2-conf *)
utempter-0.5.2-10mdk (due to unsatisfied coreutils *)
xinetd-2.3.11-1.1mdk (due to unsatisfied rpm-helper *)
xinitrc-2.4.4-73mdk (due to unsatisfied XFree86 >= 3.3.5-12mdk)
xlockmore-5.06-1mdk (due to unsatisfied pam >= 0.59)
xmms-arts-0.4-8mdk (due to missing libartsc.so.0)
xpdf-2.01-2mdk (due to missing urw-fonts)
xscreensaver-4.07-1mdk (due to missing libkrb5.so.3)
yelp-2.2.0-2mdk (due to missing docbook-dtd31-sgml)
[do you agree ?

This list is about 3 times longer, but I think you get the idea of whats wrong.
 
Old 06-03-2003, 02:31 AM   #2
MasterC
LQ Guru
 
Registered: Mar 2002
Location: Salt Lake City, UT - USA
Distribution: Gentoo ; LFS ; Kubuntu
Posts: 12,612

Rep: Reputation: 68
Wow, that looks nuts! I'd try creating a different mirror and using urmpi to set that up. I don't know if I'd be changing/upgrading/downgrading all those packages. You'll run into other problems likely. If urpmi gives you something similar, just grab a tarball and use it.

Cool
 
Old 06-03-2003, 05:53 AM   #3
Therm
LQ Newbie
 
Registered: Jun 2003
Location: United States
Distribution: Mandrake
Posts: 10

Original Poster
Rep: Reputation: 0
Yeah, I tried urpmi and it said "everything already installed"
What mirror would you suggest if you had have one that you know off..
 
Old 06-03-2003, 08:45 AM   #4
MasterC
LQ Guru
 
Registered: Mar 2002
Location: Salt Lake City, UT - USA
Distribution: Gentoo ; LFS ; Kubuntu
Posts: 12,612

Rep: Reputation: 68
I usually go for the ga tech or carroll.cac.psu.edu

They seem to be the fastest and most reliable for me

Cool
 
Old 06-03-2003, 03:44 PM   #5
Therm
LQ Newbie
 
Registered: Jun 2003
Location: United States
Distribution: Mandrake
Posts: 10

Original Poster
Rep: Reputation: 0
Well I got it installed I did it the hard way.. Well its hard for me anyways I downloaded the tarball and compiled it and installed it now I have to figure out how to set up the config file
 
Old 06-03-2003, 07:40 PM   #6
MasterC
LQ Guru
 
Registered: Mar 2002
Location: Salt Lake City, UT - USA
Distribution: Gentoo ; LFS ; Kubuntu
Posts: 12,612

Rep: Reputation: 68


You could still grab an rpm, and dump the file, grab that config file, and use it. It might help you since it's probably more tailored to your system
man rpm for more info (rpm --dump)

Cool
 
Old 06-03-2003, 09:04 PM   #7
Therm
LQ Newbie
 
Registered: Jun 2003
Location: United States
Distribution: Mandrake
Posts: 10

Original Poster
Rep: Reputation: 0
yeah I guess i could do that

It told me to edit the proftpd.conf file because it will not run unless you do. Of course i did edit it and when I run proftpd from terminal nothing happens so I must be missing something.
 
Old 06-03-2003, 09:38 PM   #8
MasterC
LQ Guru
 
Registered: Mar 2002
Location: Salt Lake City, UT - USA
Distribution: Gentoo ; LFS ; Kubuntu
Posts: 12,612

Rep: Reputation: 68
How do you "run" it? and, How do you test if it's working? Also, post up your conf file so we can take a look at it to suggest thing

COol
 
Old 06-04-2003, 03:47 PM   #9
Therm
LQ Newbie
 
Registered: Jun 2003
Location: United States
Distribution: Mandrake
Posts: 10

Original Poster
Rep: Reputation: 0
This is the proftpd.conf file it tells me that I have to edit before it will run..

# This is a basic ProFTPD configuration file (rename it to
# 'proftpd.conf' for actual use. It establishes a single server
# and a single anonymous login. It assumes that you have a user/group
# "nobody" and "ftp" for normal operation and anon.

ServerName "Thermites Test Linux Server"
ServerType standalone
DefaultServer on

# Port 21 is the standard FTP port.
Port 21

# Umask 022 is a good standard umask to prevent new dirs and files
# from being group and world writable.
Umask 022

# To prevent DoS attacks, set the maximum number of child processes
# to 30. If you need to allow more than 30 concurrent connections
# at once, simply increase this value. Note that this ONLY works
# in standalone mode, in inetd mode you should use an inetd server
# that allows you to limit maximum number of processes per service
# (such as xinetd).
MaxInstances 30

# Set the user and group under which the server will run.
User therm
Group nogroup

# To cause every FTP user to be "jailed" (chrooted) into their home
# directory, uncomment this line.
#DefaultRoot ~

# Normally, we want files to be overwriteable.
<Directory />
AllowOverwrite on
</Directory>

# A basic anonymous configuration, no upload directories. If you do not
# want anonymous users, simply delete this entire <Anonymous> section.
<Anonymous ~ftp>
User therm
Group nogroup

# We want clients to be able to login with "anonymous" as well as "ftp"
UserAlias anonymous ftp

# Limit the maximum number of anonymous logins
MaxClients 10

# We want 'welcome.msg' displayed at login, and '.message' displayed
# in each newly chdired directory.
DisplayLogin welcome.msg
DisplayFirstChdir .message

# Limit WRITE everywhere in the anonymous chroot
<Limit WRITE>
DenyAll
</Limit>
</Anonymous>

This is the part of the instructions I am at...

7. Modify the proftpd configuration file.
If the User and Group specified in proftpd.conf do not exist on your
system proftpd WILL NOT RUN. Edit and modify proftpd.conf as needed.
Many systems have the group "nobody" instead of the group "nogroup".
Decide how you want to run proftpd, either started by inetd (or xinetd)
or as a standalone daemon. Then edit the proftpd.conf file and change
the ServerType directive to match your choice, either "ServerType inetd"
or "ServerType standalone". The "basic.conf" config file, installed by
'make install' in Step 4, has a default setting of "standalone".


8. Modify the inetd superserver configuration file.
Edit /etc/inetd.conf and then send the inetd process the -HUP signal,
so that it will reread the updated configuration file. On some systems
there are other mechanisms to tell inetd to reread its configuration file,
e.g. 'refresh -s inetd' on AIX. Check your system documentation to see
what command is appropriate.

If proftpd is to be run from inetd, find the line in /etc/inetd.conf
that looks something like:

ftp stream tcp nowait root /usr/sbin/in.ftpd in.ftpd

And replace it with:

ftp stream tcp nowait root /usr/local/sbin/proftpd proftpd

Or, if the tcp wrappers package is installed on your system, you may
use a line something like:

ftp stream tcp nowait root /usr/sbin/tcpd /usr/local/sbin/proftpd

If proftpd is to be run in standalone mode, you should comment out any
ftp line in the /etc/inetd.conf file by inserting a '#' at the beginning
of the line. Then signal the inetd process to reread /etc/inetd.conf.

If your system is using xinetd instead of inetd then either edit
your /etc/xinetd.conf file or add a proftpd file in /etc/xinetd.d/

service ftp
{
flags = REUSE
socket_type = stream
instances = 50
wait = no
user = root
server = /usr/sbin/proftpd
bind = <the-ip-you-wish-to-bind-to>
log_on_success = HOST PID
log_on_failure = HOST RECORD
}

More information can be found in the FAQ and Userguide and in the
xinetd documentation for your system

I have the xinetd.conf file on my server I haven't edited it yet so I am thinking thats why it isn't working let me know what you think or if you got any ideas.
 
Old 06-04-2003, 08:31 PM   #10
MasterC
LQ Guru
 
Registered: Mar 2002
Location: Salt Lake City, UT - USA
Distribution: Gentoo ; LFS ; Kubuntu
Posts: 12,612

Rep: Reputation: 68
I don't think that you will need to. I don't think it's required if you are going to run proftpd in standalone mode. However, I could easily be wrong (and hopefully someone will correct if that is so).

The only problem I see so far is that you are trying to run it as a priviledged user. You want to run it as a user on the system, but not one with priviledges. So change your "user" values to something like "nobody". First, check to see that nobody exists in /etc/passwd with:
cat /etc/passwd
If it does, then good. If not, create that user somehow, giving them no values for a shell, no password (so no one can login with them) and no real home directory (such as /home/false), however this user has existed on every pre-built system I've dealt with, so I doubt it'll be missing from yours.

Then, start proftpd, and try to connect to your system:
ftp localhost
If that doesn't work, you definitely won't get anything from outside. Check the log file. You can define it in the proftpd.conf file:
Code:
SystemLog                       /var/log/proftpd.log
TransferLog                     /var/log/xferlog
With those 2 entries. So read /var/log/proftpd.log to see why it wouldn't start. This is usually a good way to troubleshoot your way to success (or at least give us something to go with when helping).

Cool
 
Old 06-04-2003, 08:45 PM   #11
Therm
LQ Newbie
 
Registered: Jun 2003
Location: United States
Distribution: Mandrake
Posts: 10

Original Poster
Rep: Reputation: 0
I changed my user values to nobody like you suggested it was there.

I tried to start proftpd by $ proftpd and nothing. So I went to look for the logs you suggested and there isn't any logs for it in log but I noticed a folder called proftpd in the logs directory so I switched there and there isn't any logs in there at all. I must not be running it right, but thats the only way I can think on how to run the program. I must be missing something simple or doing something totaly wrong. Any ideas?
 
Old 06-04-2003, 09:19 PM   #12
Therm
LQ Newbie
 
Registered: Jun 2003
Location: United States
Distribution: Mandrake
Posts: 10

Original Poster
Rep: Reputation: 0
Hey MasterC I got it.

It turns out it was running in the backgroud

[root@localhost therm]# ps ax |grep ftpd
1920 ? S 0:00 [proftpd]
20411 pts/0 S 0:00 grep ftpd

I did ftp local host and was able to log in so it is running and it does work now all I need to do is configure some more stuff Thanks for the help MasterC
 
Old 06-04-2003, 11:24 PM   #13
MasterC
LQ Guru
 
Registered: Mar 2002
Location: Salt Lake City, UT - USA
Distribution: Gentoo ; LFS ; Kubuntu
Posts: 12,612

Rep: Reputation: 68
You're Welcome

Cool
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
proftpd install problem fridgider Linux - Software 2 04-11-2005 05:44 PM
Proftpd install issue upr8830 Linux - Networking 2 06-17-2003 11:07 PM
proftpd install dumfounded Linux - Networking 0 01-05-2003 12:39 PM
ProFTPd install rivang Linux - Networking 1 05-10-2002 07:01 PM
Install ProFTPd on RedHat 7.1 sc300t Linux - General 4 01-23-2002 02:17 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 03:52 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration