LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (http://www.linuxquestions.org/questions/linux-software-2/)
-   -   Trying to install apcupsd. (http://www.linuxquestions.org/questions/linux-software-2/trying-to-install-apcupsd-351880/)

Carpinus 08-10-2005 12:17 PM

Trying to install apcupsd.
 
I am trying to install apcupsd, I am using Libranet 2.8.1 when I do apt-get install this is what I get. Could someone help me, I am not sure what to do with the broken packages, or dependencies.


root@GNULinux01:/home/peterhin# apt-get install apcupsd
Reading Package Lists... Done
Building Dependency Tree... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.

Since you only requested a single operation it is extremely likely that
the package is simply not installable and a bug report against
that package should be filed.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
apcupsd: Depends: libgd2-noxpm (>= 2.0.33) but it is not going to be installed or
libgd2-xpm (>= 2.0.33) but it is not going to be installed
E: Broken packages

Thanks for your time.

Matir 08-10-2005 01:10 PM

Have you tried installing those packages as well?

Carpinus 08-10-2005 02:52 PM

Trying to install apcupsd.
 
This is what I get when I try to install the packages.

root@GNULinux01:/home/peterhin# apt-get install libgd2-noxpm
Reading Package Lists... Done
Building Dependency Tree... Done


The following packages have unmet dependencies:
libgd2-noxpm: Depends: libpng12-0 (>= 1.2.7) but 1.2.5.0-4 is to be installed
E: Broken packages
root@GNULinux01:/home/peterhin# apt-get install libgd2-xpm
Reading Package Lists... Done
Building Dependency Tree... Done


The following packages have unmet dependencies:
libgd2-xpm: Depends: libpng12-0 (>= 1.2.7) but 1.2.5.0-4 is to be installed
E: Broken packages
root@GNULinux01:/home/peterhin# apt-get install libpng12-0
Reading Package Lists... Done
Building Dependency Tree... Done
libpng12-0 is already the newest version.
0 packages upgraded, 0 newly installed, 0 to remove and 552 not upgraded.
root@GNULinux01:/home/peterhin#

I am not sure where to go from here.

Matir 08-10-2005 02:58 PM

Yeah, that's not very nice. :-P I can't imagine why apcupsd needs even libxpm, or libpng. You could do it from source, of course.

Carpinus 08-10-2005 03:55 PM

Trying to install apcupsd.
 
I have not done any work with source before. i try to avoid any big downloads as I am in the country on a dial-up connection. I am using Libranet 2.8.1 with no update for that reason. Possibly that is the problem.?

Matir 08-10-2005 08:19 PM

Yes, most likely, you'd need updates to get that up and running. Hadn't considered that.


All times are GMT -5. The time now is 12:58 PM.