LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (http://www.linuxquestions.org/questions/linux-software-2/)
-   -   Trouble with window position (http://www.linuxquestions.org/questions/linux-software-2/trouble-with-window-position-559754/)

kaelthas 06-06-2007 08:38 PM

Trouble with window position
 
I am having an issue with window position ever since i installed the proprietary nvidia driver and enabled desktop effects. Every window I open ends up with the title bar off-screen, and the menus underneath the top bar. I'm using Fedora 6, and gnome. Anyone else run into this, and solved it? I'd appreciate any help.

hollywoodb 06-06-2007 09:18 PM

Compiz (desktop effects) isn't loading the "place" plugin.

I've fixed this before, but its been a while since I've used gnome so bear with me...

1) install gconf-editor ( yum install gconf-editor ).
2) run gconf-editor either via a terminal or else from Applications -> System Tools -> Configuration Editor
3) navigate to apps --> compiz --> general --> allscreens --> options and edit the active_plugins node on the right
4) put "place" in the series right after "resize" (with commas and such to keep them seperate)
5) disable & re-enable desktop effects.

kaelthas 06-06-2007 09:36 PM

Quote:

Originally Posted by hollywoodb
Compiz (desktop effects) isn't loading the "place" plugin.

I've fixed this before, but its been a while since I've used gnome so bear with me...

1) install gconf-editor ( yum install gconf-editor ).
2) run gconf-editor either via a terminal or else from Applications -> System Tools -> Configuration Editor
3) navigate to apps --> compiz --> general --> allscreens --> options and edit the active_plugins node on the right
4) put "place" in the series right after "resize" (with commas and such to keep them seperate)
5) disable & re-enable desktop effects.

Worked beautifully, thank you very much :)

MemoryDump 10-26-2007 10:36 AM

Quote:

Originally Posted by hollywoodb (Post 2778131)
Compiz (desktop effects) isn't loading the "place" plugin.

I've fixed this before, but its been a while since I've used gnome so bear with me...

1) install gconf-editor ( yum install gconf-editor ).
2) run gconf-editor either via a terminal or else from Applications -> System Tools -> Configuration Editor
3) navigate to apps --> compiz --> general --> allscreens --> options and edit the active_plugins node on the right
4) put "place" in the series right after "resize" (with commas and such to keep them seperate)
5) disable & re-enable desktop effects.

I just tried this since my window locations always seems to reset to default every time I restart an app and it didn't work.

Is there not a way for gnome to remember the last position you closed a certain app? (save window location/position)

thanks
-MD

x64 04-22-2011 08:42 AM

I had this problem, plus I also had "Place Windows" activated in CompizConfig Settings Manager. So I just deactivated the "Put" plugin and now it all seems to be ok. Thanks for the heads-up.


All times are GMT -5. The time now is 07:08 PM.